summaryrefslogtreecommitdiff
path: root/app-i18n/fcitx-chinese-addons
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/fcitx-chinese-addons')
-rw-r--r--app-i18n/fcitx-chinese-addons/Manifest2
-rw-r--r--app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.4.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/app-i18n/fcitx-chinese-addons/Manifest b/app-i18n/fcitx-chinese-addons/Manifest
index bbd0f6c0653e..a62da9b1c694 100644
--- a/app-i18n/fcitx-chinese-addons/Manifest
+++ b/app-i18n/fcitx-chinese-addons/Manifest
@@ -1,3 +1,5 @@
DIST fcitx5-chinese-addons-5.1.3_dict.tar.xz 884664 BLAKE2B 6e9f931c146798bbbd76e7a55d62d50de2c8173d0dddcb48ea78259dac62fe41cb4be4421c6d6d81a5b094a3ebe258b1d20b42e2891451da55723e3978c1379a SHA512 4ea52ec45af70b552d8d4af3ed077662d6d839d3984bc41858b4710fe5b1dc169c63e223770f5400718c1c18aa745e77305f242409fa1cc523cee8475eb2e9ff
+DIST fcitx5-chinese-addons-5.1.4_dict.tar.xz 885456 BLAKE2B 239b2092d9b4ca77d7c0373a85e7a0e5b03e223c477b8704e36657349cf3ba006791e77a064826cd452eb6e5e81d33831feceabb9a51a8d26275f70deb04658a SHA512 99f3cc101532879c126e2699d338528a25531b782a5c1f1e93cd363437567c1ba7b0173aca56f887089d4379e86aecf7977139b5b5c44d54e0bd9a416b01e976
EBUILD fcitx-chinese-addons-5.1.3.ebuild 1488 BLAKE2B 077940de82ba0e09f522382bd27043f3de32efa76353133f91386628fa3a48e8d4cc6f8e2fee09b8a16e546e58f5ef4c566d5fabd5b356d2f1200c166417ab97 SHA512 38abe8a0d6a5e940b760bc128e5fe4cb6daa98d54b9bdc179dbc8cc6dbe559257e7815ac133d40ba72a5a3231854c73d0835b1228b975c1f8645487002916dd1
+EBUILD fcitx-chinese-addons-5.1.4.ebuild 1488 BLAKE2B 077940de82ba0e09f522382bd27043f3de32efa76353133f91386628fa3a48e8d4cc6f8e2fee09b8a16e546e58f5ef4c566d5fabd5b356d2f1200c166417ab97 SHA512 38abe8a0d6a5e940b760bc128e5fe4cb6daa98d54b9bdc179dbc8cc6dbe559257e7815ac133d40ba72a5a3231854c73d0835b1228b975c1f8645487002916dd1
MISC metadata.xml 993 BLAKE2B 034a9f1ca3966a67fb884f3e0ce6baeb83c3ccfb2b7d7d99d41e54ef30087c94d5a0c9729902e08eb8b781deeb71daf57b27f3d238beebf6e356e690aae7723b SHA512 05140cdf9695922cf2ddad40744d51d197fc3beab99ca7ba5d19b38a7c22762195f2e3a3c2e2ded46f253e1efeab06259429725830328c5f2001fe0752cd2b26
diff --git a/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.4.ebuild b/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.4.ebuild
new file mode 100644
index 000000000000..009b5efe7416
--- /dev/null
+++ b/app-i18n/fcitx-chinese-addons/fcitx-chinese-addons-5.1.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-chinese-addons"
+
+inherit cmake xdg
+
+DESCRIPTION="Addons related to Chinese, including IME previous bundled inside fcitx4."
+HOMEPAGE="https://github.com/fcitx/fcitx5-chinese-addons"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}_dict.tar.xz"
+
+LICENSE="GPL-2+ LGPL-2+"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+SLOT="5"
+IUSE="+data +gui webengine +cloudpinyin +qt5 qt6 lua +opencc test"
+REQUIRED_USE="
+ webengine? ( gui )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-i18n/fcitx-5.1.6:5
+ >=app-i18n/libime-1.1.3:5[data?]
+ >=dev-libs/boost-1.61:=
+ cloudpinyin? ( net-misc/curl )
+ lua? ( app-i18n/fcitx-lua:5 )
+ opencc? ( app-i18n/opencc:= )
+ gui? (
+ qt5? (
+ dev-qt/qtconcurrent:5
+ app-i18n/fcitx-qt:5[qt5,-onlyplugin]
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ )
+ qt6? (
+ dev-qt/qtbase:6[concurrent]
+ app-i18n/fcitx-qt:5[qt6,-onlyplugin]
+ webengine? ( dev-qt/qtwebengine:6[widgets] )
+ )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_BROWSER=$(usex webengine)
+ -DENABLE_CLOUDPINYIN=$(usex cloudpinyin)
+ -DENABLE_DATA=$(usex data)
+ -DENABLE_GUI=$(usex gui)
+ -DENABLE_OPENCC=$(usex opencc)
+ -DENABLE_TEST=$(usex test)
+ -DUSE_WEBKIT=no
+ -DUSE_QT6=$(usex qt6)
+ )
+ cmake_src_configure
+}