summaryrefslogtreecommitdiff
path: root/app-i18n/bidiv/bidiv-1.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/bidiv/bidiv-1.5-r1.ebuild')
-rw-r--r--app-i18n/bidiv/bidiv-1.5-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-i18n/bidiv/bidiv-1.5-r1.ebuild b/app-i18n/bidiv/bidiv-1.5-r1.ebuild
new file mode 100644
index 000000000000..86d05fe04bf0
--- /dev/null
+++ b/app-i18n/bidiv/bidiv-1.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A BiDirectional Text Viewer"
+HOMEPAGE="http://www.ivrix.org.il"
+SRC_URI="http://ftp.ivrix.org.il/pub/ivrix/src/cmdline/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/fribidi-0.19.2-r2"
+DEPEND="${DEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fribidi.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin bidiv
+ dodoc README WHATSNEW
+ doman bidiv.1
+}