summaryrefslogtreecommitdiff
path: root/app-forensics/sleuthkit/sleuthkit-4.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/sleuthkit/sleuthkit-4.0.2.ebuild')
-rw-r--r--app-forensics/sleuthkit/sleuthkit-4.0.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-forensics/sleuthkit/sleuthkit-4.0.2.ebuild b/app-forensics/sleuthkit/sleuthkit-4.0.2.ebuild
new file mode 100644
index 000000000000..8101b681c641
--- /dev/null
+++ b/app-forensics/sleuthkit/sleuthkit-4.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="A collection of file system and media management forensic analysis tools"
+HOMEPAGE="http://www.sleuthkit.org/sleuthkit/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 IBM"
+SLOT="0/9" # subslot = major soname version
+KEYWORDS="amd64 hppa ppc x86"
+IUSE="aff ewf static-libs"
+
+DEPEND="dev-db/sqlite:3
+ ewf? ( app-forensics/libewf )
+ aff? ( app-forensics/afflib )"
+RDEPEND="${DEPEND}
+ dev-perl/Date-Manip"
+
+DOCS=( NEWS.txt README.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.0-system-sqlite.patch
+ "${FILESDIR}"/${PN}-3.2.3-tools-shared-libs.patch
+)
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with aff afflib)
+ $(use_with ewf libewf)
+ )
+ autotools-utils_src_configure
+}