summaryrefslogtreecommitdiff
path: root/app-forensics/radamsa/radamsa-0.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/radamsa/radamsa-0.5-r1.ebuild')
-rw-r--r--app-forensics/radamsa/radamsa-0.5-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-forensics/radamsa/radamsa-0.5-r1.ebuild b/app-forensics/radamsa/radamsa-0.5-r1.ebuild
new file mode 100644
index 000000000000..89a3a070b6ae
--- /dev/null
+++ b/app-forensics/radamsa/radamsa-0.5-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A general purpose fuzzer"
+HOMEPAGE="https://github.com/aoh/radamsa"
+SRC_URI="https://github.com/aoh/radamsa/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # needs an owl-lisp
+
+DOCS=( LICENCE NEWS README.md )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
+
+ einstalldocs
+}