summaryrefslogtreecommitdiff
path: root/app-forensics/mac-robber/mac-robber-1.02-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/mac-robber/mac-robber-1.02-r1.ebuild')
-rw-r--r--app-forensics/mac-robber/mac-robber-1.02-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-forensics/mac-robber/mac-robber-1.02-r1.ebuild b/app-forensics/mac-robber/mac-robber-1.02-r1.ebuild
new file mode 100644
index 000000000000..b5e75816e7ae
--- /dev/null
+++ b/app-forensics/mac-robber/mac-robber-1.02-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="mac-robber is a digital forensics and incident response tool that collects data"
+HOMEPAGE="http://www.sleuthkit.org/mac-robber/index.php"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+
+PATCHES=( "${FILESDIR}"/${P}-posix.patch )
+
+src_prepare() {
+ default
+ # just rely on implicit rules
+ rm Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_compile() {
+ emake mac-robber
+}
+
+src_install() {
+ dobin mac-robber
+ einstalldocs
+}