summaryrefslogtreecommitdiff
path: root/app-forensics/libbfio/libbfio-0.0.20120425_alpha.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/libbfio/libbfio-0.0.20120425_alpha.ebuild')
-rw-r--r--app-forensics/libbfio/libbfio-0.0.20120425_alpha.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-forensics/libbfio/libbfio-0.0.20120425_alpha.ebuild b/app-forensics/libbfio/libbfio-0.0.20120425_alpha.ebuild
new file mode 100644
index 000000000000..a69e104313cd
--- /dev/null
+++ b/app-forensics/libbfio/libbfio-0.0.20120425_alpha.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit versionator
+
+MY_DATE="$(get_version_component_range 3)"
+
+DESCRIPTION="Library for providing a basic file input/output abstraction layer"
+HOMEPAGE="https://github.com/libyal/libbfio"
+SRC_URI="http://dev.pentoo.ch/~zero/distfiles/${PN}-alpha-${MY_DATE}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="unicode"
+
+S="${WORKDIR}/${PN}-${MY_DATE}"
+
+src_configure() {
+ econf $(use_enable unicode wide-character-type)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Failed to install"
+}