summaryrefslogtreecommitdiff
path: root/app-forensics/autopsy
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/autopsy')
-rw-r--r--app-forensics/autopsy/Manifest5
-rw-r--r--app-forensics/autopsy/autopsy-2.24-r1.ebuild60
-rw-r--r--app-forensics/autopsy/metadata.xml8
3 files changed, 73 insertions, 0 deletions
diff --git a/app-forensics/autopsy/Manifest b/app-forensics/autopsy/Manifest
new file mode 100644
index 000000000000..9825e56d0f2b
--- /dev/null
+++ b/app-forensics/autopsy/Manifest
@@ -0,0 +1,5 @@
+DIST autopsy-2.24.tar.gz 387873 SHA256 ab787f519942783d43a561d12be0554587f11f22bc55ab79d34d8da703edc09e SHA512 09cd337c2c6e095c533cba449684b36e4a926cbe5736be6da4f644e733525069984550b5b76a902a32d797ac311218a2ec88626603f1dd4381d52f3f94d3cedb WHIRLPOOL 3dbc39cf3a16920f6816b7a0bf50939624d8d4ce455342ba3e6114a3993ffa3df2518612c96c885cad93f59d574994c46056cf8e686d389aebb2005d0d8bc9c7
+EBUILD autopsy-2.24-r1.ebuild 1348 SHA256 3052e348ff22289549b75ddf107ac916778e95855850231a6ca9d3b79f20995e SHA512 62b44121c7adda0e379c284e2d3915c9c2f94d19aa501b85979896ac681772dac42ea10a599145838fcf2926ba12458a58e4060eee7b8ab255667299f472df90 WHIRLPOOL 723ce51a7365d5d69d981bb11a97a5645356dd347446b2d8faa6fec40469e039127d2e02ca6b20a6599b01935fa3ff525b8cd540958d85ea1768942ad4dd6d59
+MISC ChangeLog 2436 SHA256 583f5a605883bb686df1221cd61b2ac6f5b172ae1dd770aa199cb7c7e0b31656 SHA512 281085230a9817f2127239b53605a8451a15f62850c957aa0887e306c70a286a28f5da28f57eb85d75a87ba6803bac363516ac20bd4e1060d590dbbd9fa0d4c4 WHIRLPOOL 013effd060087e1534e5e43f61d6636409c35a6cd27f6ae880f45bad0a5a55adec7a24a509b30481c27cec92d09bd5fd7a39db24d3a7e1cf6a498ceaa949fa44
+MISC ChangeLog-2015 5133 SHA256 3ea147b1c136b9b867b39e44f6ccf94536c9d1830ea2362586fe098b4581c487 SHA512 c7a68aa254bf3d0a3facd565e104fe8fe032c98889ae9a17381c700b88e360fdfb16f17ba9e535acda06d9c9af60fa177a761439eb17ce12f3d18daead6f650f WHIRLPOOL 905265350e60a8b6f4e042f524ddfbf63b29e057708dacbff0f502b4caa749ea0b2ba1d7dad6d262c444ef8a5e93de4d2bf17dc1f89e9c210a4a6b6db9b89c7d
+MISC metadata.xml 244 SHA256 ee4bf5169af53da93f989dc266a7d61ba7b597805908a860b138d68525729fbb SHA512 4fc4a70fe6ed1036680005b53b6871d77a909c482a9187e903336b15ac77905cd6bd2a6f28db3edf2adffbc377906822287a320a409ed4d6cc1743de823e08fb WHIRLPOOL f52d1853b410a0f31f30983ae4ad1f077bc6fa67949932a1b6643a5909579213cf2872723bdfdfb21b1ef787d42f2b53d73e542ba9444fae17febe691b5372a6
diff --git a/app-forensics/autopsy/autopsy-2.24-r1.ebuild b/app-forensics/autopsy/autopsy-2.24-r1.ebuild
new file mode 100644
index 000000000000..c5a3d53c2aa1
--- /dev/null
+++ b/app-forensics/autopsy/autopsy-2.24-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+DESCRIPTION="A graphical interface to the digital forensic analysis tools in The Sleuth Kit"
+HOMEPAGE="http://www.sleuthkit.org/autopsy/"
+SRC_URI="mirror://sourceforge/autopsy/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc x86"
+IUSE=""
+
+# Runtime depend on grep and file deliberate
+RDEPEND=">=dev-lang/perl-5.8.0
+ >=app-forensics/sleuthkit-3.0.0
+ sys-apps/grep
+ sys-apps/file"
+DEPEND=""
+
+src_configure() {
+ ./configure 2>&1 >/dev/null <<-EOF
+ n
+ /tmp
+ EOF
+
+ cat <<-EOF > autopsy
+ #!/usr/bin/perl -wT
+ use lib '/usr/lib/autopsy/';
+ use lib '/usr/lib/autopsy/lib/';
+ EOF
+ cat base/autopsy.base >> autopsy
+
+ sed -i 's:conf.pl:/etc/autopsy.pl:' $(grep -lr conf\.pl ./)
+ sed -i "s:INSTALLDIR = .*:INSTALLDIR = \'/usr/lib/autopsy\';:" conf.pl
+}
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/lib/autopsy
+ doins autopsy
+ doins global.css
+ insinto /usr/lib/autopsy/help
+ doins help/*
+ insinto /usr/lib/autopsy/lib
+ doins lib/*
+ insinto /usr/lib/autopsy/pict
+ doins pict/*
+ insinto /etc
+ newins conf.pl autopsy.pl
+
+ dodir /usr/bin
+ dosym /usr/lib/autopsy/autopsy /usr/bin/autopsy
+ fperms +x /usr/lib/autopsy/autopsy
+
+ doman $(find man/ -type f)
+ dodoc CHANGES.txt README* TODO.txt docs/sleuthkit-informer*.txt
+}
diff --git a/app-forensics/autopsy/metadata.xml b/app-forensics/autopsy/metadata.xml
new file mode 100644
index 000000000000..93a26a3f58d2
--- /dev/null
+++ b/app-forensics/autopsy/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">autopsy</remote-id>
+ </upstream>
+</pkgmetadata>