summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-blas
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-blas')
-rw-r--r--app-eselect/eselect-blas/Manifest4
-rw-r--r--app-eselect/eselect-blas/eselect-blas-0.2.ebuild28
-rw-r--r--app-eselect/eselect-blas/files/blas.eselect-0.2168
-rw-r--r--app-eselect/eselect-blas/files/blas.eselect.534
4 files changed, 223 insertions, 11 deletions
diff --git a/app-eselect/eselect-blas/Manifest b/app-eselect/eselect-blas/Manifest
index 3d18447d946f..766a9f6948be 100644
--- a/app-eselect/eselect-blas/Manifest
+++ b/app-eselect/eselect-blas/Manifest
@@ -1,4 +1,6 @@
AUX blas.eselect-0.1 350 BLAKE2B a21d38edf3188c2f26d384010d070048c0df19dcf87338ecfa1c08b9667ae97bb2875d6ae9958d797a416524de28540a4a95597c36d25df340bbe956ed95d342 SHA512 25f9250c3fae6d31871ca08260f1cd6597d9263fe51d3d696dd55c8648b604ea52b705dc5d128c7d9677cc1cd63f9aa1e31e124bdf52374eaf02f991db0045f2
-AUX blas.eselect.5 2065 BLAKE2B a86cf9f357871021867c30a24fe945435d247b755eec8557c4e6986fab7658ee2ee7246e46c650998a5ce252544f35142ec4d67a8c4e865602d02779e812ac20 SHA512 94264f61bbe29ac027d9ec82b3921e99cc8f7108544682508748e407fbe7d393748cef876c240796adf82122370ac963def90fd8b01a3186049223e3eaf21ffd
+AUX blas.eselect-0.2 4952 BLAKE2B 14d60fdbae1dded65d6846f7e1fb6214994b7fce6d7d6340f9261e1e9081a46d21084c622ca2dcf2568dc07e0110b925ffc957e254d24850f741d943fa22f91c SHA512 a85f27c9808debaf9f47831c9d35194084bf0db818d3b8264532a7956b084633d9d462dfdda4a84f9a011721dbfc3abc419465e887a7ff9d17328f43a8f91790
+AUX blas.eselect.5 2368 BLAKE2B 8545c10ff73bafc4b9abdaab6410e0cba4d543ebcb7615f96357c72b63253c48158b08f85693005e8793982e86fa1e47c518d90a9302eb15cab6da84e584bf87 SHA512 46a423dc25d6f44769f92babcd8c98a8fa6f19bd64717fc894b9be1984e5f7ea4e00a458d9dd25724fd40377fa633b7f9c513878000a653b386f6be75532f531
EBUILD eselect-blas-0.1.ebuild 701 BLAKE2B 07d2cb7f44eaf74d802d02eaf7732a17d215bc875088933794ee175ff422d15c9bf1a240e265ac1c015cb819e51b5c471d7dafbe7cff80528cc9a48dbaf72a81 SHA512 4d0e04454caf2ae898917df40a8c25578b7fd35d3bd7d0481d5a645b5ca2255063dc108540db68e6e25b3dd82e95ebcbc70f3c9d74142ec57399a5f2d9c5b666
+EBUILD eselect-blas-0.2.ebuild 661 BLAKE2B a1f105fb0f3accdcb3977eb07c8d24cb16d3cbb0f3d8b64094898175dd520cdf418d67f027931b0b21583117ef2910f18d08678ccd3f202bb7ecfcdc4b8aba78 SHA512 0c34ecd4d9f473aea069d0e2ab881a8d52a5fadf843733d757e7ae05b005788964a518dbe27bb115c7cc26674c58cce682fbadb9ea8e0884aad3a9fd6522caf4
MISC metadata.xml 249 BLAKE2B 03207049d5e7c62319639b2c37769d9d8c0d9cbf1e44fbc6cab9ea006e60bff3526193fea60902a0e64a362b02463104969700074602e31d8fb8f86a042d1ed8 SHA512 29a9c1817fd4299246d5fa995b73b9f1996b112b70f468139cf9cd8f07077d831e0788d3b93aaba67bb38dce5850830c27543fccbddbac02b0da4ff899def519
diff --git a/app-eselect/eselect-blas/eselect-blas-0.2.ebuild b/app-eselect/eselect-blas/eselect-blas-0.2.ebuild
new file mode 100644
index 000000000000..c69353354359
--- /dev/null
+++ b/app-eselect/eselect-blas/eselect-blas-0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="BLAS/CBLAS module for eselect"
+HOMEPAGE="https://www.gentoo.org"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+# Need skel.bash lib
+RDEPEND=( ">=app-admin/eselect-1.0.5"
+ "!app-eselect/eselect-cblas" )
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ local MODULEDIR="/usr/share/eselect/modules"
+ local MODULE="blas"
+ insinto ${MODULEDIR}
+ newins "${FILESDIR}"/${MODULE}.eselect-${PVR} ${MODULE}.eselect
+ doman "${FILESDIR}"/blas.eselect.5
+}
diff --git a/app-eselect/eselect-blas/files/blas.eselect-0.2 b/app-eselect/eselect-blas/files/blas.eselect-0.2
new file mode 100644
index 000000000000..001ddb941e82
--- /dev/null
+++ b/app-eselect/eselect-blas/files/blas.eselect-0.2
@@ -0,0 +1,168 @@
+# -*-eselect-*- vim: ft=eselect
+# Copyright 2019 Gentoo Foundation
+# Distributed under the terms of the GNU GPL version 2 or later
+
+inherit config tests multilib skel
+
+MODULE="BLAS/CBLAS"
+IFACE="blas"
+DESCRIPTION="Manage installed alternatives of $MODULE shared objects"
+MAINTAINER="lumin@debian.org"
+VERSION="20190621"
+
+### helper utility to find all available BLAS/CBLAS implementations
+find_targets_in() {
+ [[ $# -eq 1 ]] || die -q "in which libdir?"
+
+ local cand
+ for cand in ${EROOT}/etc/env.d/blas/$1/*; do
+ [[ "config" = $(basename ${cand}) ]] && continue
+ [[ -r ${cand} ]] && basename ${cand}
+ done
+}
+
+### helper utility to validate a BLAS/CBLAS library directory
+validate_blaslibdir() {
+ [[ -d $1 ]] || return 2 # dir doesn't exist
+ [[ -r "${1}/libblas.so.3" ]] && [[ -r "${1}/libblas.so" ]] \
+ && [[ -r "${1}/libcblas.so.3" ]] && [[ -r "${1}/libcblas.so" ]] \
+ || return 1
+}
+
+### show action
+do_show() {
+ # do_show -- show both lib64 and lib32 selection
+ # do_show libxx -- show libxx selection
+ local libdir cur libdirs=( $(list_libdirs) )
+
+ # if manually specified libdirs
+ if [[ ! $# -eq 0 ]]; then
+ for libdir in $@; do
+ has $libdir ${libdirs[@]} || die -q "invalid libdir '$libdir'!"
+ done
+ libdirs=( $@ )
+ fi
+
+ for libdir in ${libdirs[@]}; do
+ [[ ! -d ${EROOT}/usr/$libdir ]] && continue
+ [[ ! -r ${EROOT}/etc/env.d/blas/${libdir}/config ]] && continue
+ cur=$(load_config ${EROOT}/etc/env.d/blas/${libdir}/config CURRENT)
+ echo ${libdir}: $cur
+ done
+}
+
+### list action
+do_list() {
+ local i cur targets
+ local libdir libdirs=( $(list_libdirs) )
+
+ # if manually specified libdirs
+ if [[ ! $# -eq 0 ]]; then
+ for libdir in $@; do
+ has $libdir ${libdirs[@]} || die -q "invalid libdir '$libdir'!"
+ done
+ libdirs=( $@ )
+ fi
+
+ for libdir in ${libdirs[@]}; do
+ [[ ! -d ${EROOT}/usr/$libdir ]] || [[ -L ${EROOT}/usr/$libdir ]] && continue
+ targets=( $(find_targets_in $libdir) )
+ cur=$(load_config ${EROOT}/etc/env.d/blas/${libdir}/config CURRENT)
+
+ write_list_start "Available BLAS/CBLAS ($libdir) candidates:"
+ for (( i = 0; i < ${#targets[@]}; i++ )); do
+ [[ ${targets[i]} = $cur ]] \
+ && targets[i]=$(highlight_marker "${targets[i]}")
+ done
+ write_numbered_list -m "(none found)" "${targets[@]}"
+ done
+}
+
+### validate action
+describe_validate() {
+ echo "validate candidates and remove invalid ones"
+}
+
+do_validate() {
+ local i ldpath targets target candidate
+ local libdir libdirs=( $(list_libdirs) )
+ for libdir in ${libdirs[@]}; do
+ [[ ! -d ${EROOT}/usr/$libdir ]] || [[ -L ${EROOT}/usr/$libdir ]] && continue
+ targets=( $(find_targets_in $libdir) )
+ for target in ${targets[@]}; do
+ candidate=${EROOT}/etc/env.d/blas/${libdir}/${target}
+ ldpath=$(load_config $candidate LDPATH)
+ if ! validate_blaslibdir $ldpath; then
+ echo "Removing invalid BLAS/CBLAS candidate ($candidate) ..."
+ rm -v $candidate
+ fi
+ done
+ done
+}
+
+### set action
+
+describe_set() {
+ echo "Activate one of the installed $MODULE implementations"
+}
+
+describe_set_parameters() {
+ echo "[<libdir>] <implementation>"
+}
+
+describe_set_options() {
+ echo "libdir: lib64 or lib32. Will use the native one when omitted."
+ echo "implementation : implementation name or number (from 'list' action)"
+}
+
+do_set() {
+ local libdirs=( $(list_libdirs) )
+ local targets libdir ldconf libpath impl
+
+ # check argument existence
+ [[ $# -eq 1 ]] || [[ $# -eq 2 ]] || \
+ die -q "Please specify [<libdir>] <impl> to activate!"
+ # read argumenets
+ if [[ $# -eq 2 ]]; then libdir="$1"; else libdir="$(get_libdir)"; fi
+ if [[ $# -eq 2 ]]; then impl="$2"; else impl="$1"; fi
+ # validate arguments
+ has "$libdir" "${libdirs[@]}" || die -q "Invalid libdir ($libdir) !"
+ targets=( $(find_targets_in $libdir) )
+ if ! has "$impl" "${targets[@]}"; then
+ if [[ ${impl} -gt 0 ]] && [[ ${impl} -le ${#targets[@]} ]]; then
+ impl=${targets[(${impl} - 1)]}
+ else
+ die -q "Invalid impl ($impl) !"
+ fi
+ fi
+ # store the configuration to env.d
+ store_config ${EROOT}/etc/env.d/blas/${libdir}/config CURRENT "${impl}"
+ # generate ld.so.conf file
+ ldconf="${EROOT}/etc/ld.so.conf.d/81-blas-${libdir}.conf"
+ libpath=$(load_config ${EROOT}/etc/env.d/blas/${libdir}/${impl} LDPATH)
+ truncate -s0 $ldconf
+ echo "# Auto-generated by eselect::blas. DON'T EDIT." >> $ldconf
+ echo "$libpath" >> $ldconf
+
+ # refresh cache. env-update will call ldconfig (see
+ # portage::env_update.py) so we don't need to call it explicitly.
+ env-update
+}
+
+### add action
+describe_add_parameters() {
+ echo "<libdir> <dir> <impl>"
+}
+
+describe_add_options() {
+ echo "libdir : library directory where $MODULE implementation is installed (lib, lib64, etc.)"
+ echo "dir : directory containing lib{,c}blas.so{.3}"
+ echo "impl : name of the $MODULE implementation"
+}
+
+do_add() {
+ [[ $# -eq 3 ]] \
+ || die -q "Please specify <libdir> <dir> <impl> to activate!"
+ validate_blaslibdir $2 || die -q "invalid blas libdir!"
+ store_config ${EROOT}/etc/env.d/blas/$1/$3 LDPATH $2
+}
diff --git a/app-eselect/eselect-blas/files/blas.eselect.5 b/app-eselect/eselect-blas/files/blas.eselect.5
index c9df9fde8d7f..9779268bc65b 100644
--- a/app-eselect/eselect-blas/files/blas.eselect.5
+++ b/app-eselect/eselect-blas/files/blas.eselect.5
@@ -1,22 +1,22 @@
-.TH "ESELECT" "5" "June 2006" "Gentoo Linux" "eselect"
+.TH "ESELECT" "5" "June 2019" "Gentoo Linux" "eselect"
.SH "NAME"
blas.eselect \- The BLAS management module for Gentoo's eselect
.SH "SYNOPSIS"
\fBeselect blas\fR [\fBhelp\fR|\fBusage\fR]
.br
-\fBeselect blas\fR \fBlist\fR [\fIoptions\fR]
+\fBeselect blas\fR \fBlist\fR [\fIlibdir\fR]
.br
\fBeselect blas\fR \fBadd\fR
.br
-\fBeselect blas\fR \fBset\fR \fIimplementation\fR [\fIoptions\fR]
+\fBeselect blas\fR \fBset\fR [\fIlibdir\fR] \fIimplementation\fR
.br
-\fBeselect blas\fR \fBshow\fR [\fIoptions\fR]
+\fBeselect blas\fR \fBshow\fR [\fIlibdir\fR]
.SH "DESCRIPTION"
\fBeselect\fR is Gentoo's configuration and management tool. It features
modules that care for the individual administrative tasks.
.SH "ACTION: LIST"
-\fBeselect blas list\fR [\fIoptions\fR]
+\fBeselect blas list\fR [\fIlibdir\fR]
.br
Displays an ordered list of installed BLAS implementations. It distinguishes between versions with different
Application Binary Interfaces (e.g. x86/AMD64). Furthermore, it also distinguishes
@@ -31,7 +31,7 @@ Installed BLAS for libdir \fBlib\fR
[1] atlas *
[2] reference
-Possible \fIoptions\fR to the \fBlist\fR action are restrictions to
+Possible \fIlibdir\fR to the \fBlist\fR action are restrictions to
handle only certain ABI\-specific library directories. For example,
\fBeselect blas list lib64\fR
@@ -39,7 +39,7 @@ handle only certain ABI\-specific library directories. For example,
lists only BLAS implementations found in \fB/usr/lib64\fR.
.SH "ACTION: SHOW"
-\fBeselect blas show\fR [\fIoptions\fR]
+\fBeselect blas show\fR [\fIlibdir\fR]
.br
Shows your system's currently active BLAS implementations.
@@ -49,17 +49,31 @@ lib: atlas
.br
lib64: reference
-The same \fIoptions\fR that apply to the \fBlist\fR action can be used
+The same \fIlibdir\fR that apply to the \fBlist\fR action can be used
with the \fBshow\fR action to restrict it to given ABIs.
.SH "ACTION: SET"
-\fBeselect blas set\fR \fIimplementation\fR [\fIoptions\fR]
+\fBeselect blas set\fR [\fIlibdir\fR] \fIimplementation\fR
.br
Sets your system's currently active BLAS implementations to \fIimplementation\fR.
-The same \fIoptions\fR that apply to the \fBlist\fR action can be used
+The same \fIlibdir\fR that apply to the \fBlist\fR action can be used
with the \fBset\fR action to restrict it to given ABIs.
phi / # eselect blas set atlas
+
+.SH "ACTION: VALIDATE"
+\fBeselect blas validate\fR
+.br
+Validates BLAS/CBLAS candidates under the /etc/env.d directory and automatically
+remove the invalid ones.
+
+.SH "ACTION: ADD"
+\fBeselect blas add\fR \fIlibdir\fR \fIdir\fR \fIimpl\fR
+.br
+Add a new BLAS/CBLAS implementation.
+
.SH "AUTHOR"
Danny van Dyk <kugelfang@gentoo.org>
.br
Donnie Berkholz <spyderous@gentoo.org>
+.br
+Mo Zhou <lumin@debian.org>