summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-blas
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-blas')
-rw-r--r--app-eselect/eselect-blas/Manifest4
-rw-r--r--app-eselect/eselect-blas/eselect-blas-0.1.ebuild27
-rw-r--r--app-eselect/eselect-blas/files/blas.eselect-0.114
-rw-r--r--app-eselect/eselect-blas/files/blas.eselect.565
-rw-r--r--app-eselect/eselect-blas/metadata.xml8
5 files changed, 118 insertions, 0 deletions
diff --git a/app-eselect/eselect-blas/Manifest b/app-eselect/eselect-blas/Manifest
new file mode 100644
index 000000000000..afc0575d6d9c
--- /dev/null
+++ b/app-eselect/eselect-blas/Manifest
@@ -0,0 +1,4 @@
+AUX blas.eselect-0.1 350 BLAKE2B a21d38edf3188c2f26d384010d070048c0df19dcf87338ecfa1c08b9667ae97bb2875d6ae9958d797a416524de28540a4a95597c36d25df340bbe956ed95d342 SHA512 25f9250c3fae6d31871ca08260f1cd6597d9263fe51d3d696dd55c8648b604ea52b705dc5d128c7d9677cc1cd63f9aa1e31e124bdf52374eaf02f991db0045f2
+AUX blas.eselect.5 2065 BLAKE2B a86cf9f357871021867c30a24fe945435d247b755eec8557c4e6986fab7658ee2ee7246e46c650998a5ce252544f35142ec4d67a8c4e865602d02779e812ac20 SHA512 94264f61bbe29ac027d9ec82b3921e99cc8f7108544682508748e407fbe7d393748cef876c240796adf82122370ac963def90fd8b01a3186049223e3eaf21ffd
+EBUILD eselect-blas-0.1.ebuild 705 BLAKE2B e38600034c9ea73493becd2d2ea98cfc04c8ad7bc048ac48d1ef9fc39872f8ac318f2f5baa8d25d9ad1ab3a4049ed3ea0c99395b168cc049f96db13e388f65df SHA512 46fad0931295638d1fef7f976d16ff1151c95fe9fa209b02239e85c97a1f1d89e541bac67c95ec39a34b9395655c1c81d35605c7e45d1f3401f48be827fec27c
+MISC metadata.xml 249 BLAKE2B 03207049d5e7c62319639b2c37769d9d8c0d9cbf1e44fbc6cab9ea006e60bff3526193fea60902a0e64a362b02463104969700074602e31d8fb8f86a042d1ed8 SHA512 29a9c1817fd4299246d5fa995b73b9f1996b112b70f468139cf9cd8f07077d831e0788d3b93aaba67bb38dce5850830c27543fccbddbac02b0da4ff899def519
diff --git a/app-eselect/eselect-blas/eselect-blas-0.1.ebuild b/app-eselect/eselect-blas/eselect-blas-0.1.ebuild
new file mode 100644
index 000000000000..9409504502f1
--- /dev/null
+++ b/app-eselect/eselect-blas/eselect-blas-0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="BLAS module for eselect"
+HOMEPAGE="https://www.gentoo.org"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+# Need skel.bash lib
+RDEPEND=">=app-admin/eselect-1.0.5"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+src_install() {
+ local MODULEDIR="/usr/share/eselect/modules"
+ local MODULE="blas"
+ insinto ${MODULEDIR}
+ newins "${FILESDIR}"/${MODULE}.eselect-${PVR} ${MODULE}.eselect
+ doman "${FILESDIR}"/blas.eselect.5
+}
diff --git a/app-eselect/eselect-blas/files/blas.eselect-0.1 b/app-eselect/eselect-blas/files/blas.eselect-0.1
new file mode 100644
index 000000000000..cb2a03cd8668
--- /dev/null
+++ b/app-eselect/eselect-blas/files/blas.eselect-0.1
@@ -0,0 +1,14 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit skel
+
+MODULE="BLAS"
+IFACE="blas"
+
+DESCRIPTION="Manage installed $MODULE implementations"
+MAINTAINER="spyderous@gentoo.org"
+SVN_DATE='$Date: 2015/03/31 16:46:52 $'
+VERSION=$(svn_date_to_version "${SVN_DATE}" )
+
+# vim: set ft=eselect :
diff --git a/app-eselect/eselect-blas/files/blas.eselect.5 b/app-eselect/eselect-blas/files/blas.eselect.5
new file mode 100644
index 000000000000..c9df9fde8d7f
--- /dev/null
+++ b/app-eselect/eselect-blas/files/blas.eselect.5
@@ -0,0 +1,65 @@
+.TH "ESELECT" "5" "June 2006" "Gentoo Linux" "eselect"
+.SH "NAME"
+blas.eselect \- The BLAS management module for Gentoo's eselect
+.SH "SYNOPSIS"
+\fBeselect blas\fR [\fBhelp\fR|\fBusage\fR]
+.br
+\fBeselect blas\fR \fBlist\fR [\fIoptions\fR]
+.br
+\fBeselect blas\fR \fBadd\fR
+.br
+\fBeselect blas\fR \fBset\fR \fIimplementation\fR [\fIoptions\fR]
+.br
+\fBeselect blas\fR \fBshow\fR [\fIoptions\fR]
+
+.SH "DESCRIPTION"
+\fBeselect\fR is Gentoo's configuration and management tool. It features
+modules that care for the individual administrative tasks.
+.SH "ACTION: LIST"
+\fBeselect blas list\fR [\fIoptions\fR]
+.br
+Displays an ordered list of installed BLAS implementations. It distinguishes between versions with different
+Application Binary Interfaces (e.g. x86/AMD64). Furthermore, it also distinguishes
+between interfaces to high-level programming languages. Each line holds
+a number and the implementation's name. An asterisk next to one of the list
+elements denotes an active implementation.
+
+phi / # eselect blas list
+.br
+Installed BLAS for libdir \fBlib\fR
+.br
+ [1] atlas *
+ [2] reference
+
+Possible \fIoptions\fR to the \fBlist\fR action are restrictions to
+handle only certain ABI\-specific library directories. For example,
+
+\fBeselect blas list lib64\fR
+
+lists only BLAS implementations found in \fB/usr/lib64\fR.
+
+.SH "ACTION: SHOW"
+\fBeselect blas show\fR [\fIoptions\fR]
+.br
+Shows your system's currently active BLAS implementations.
+
+phi / # eselect blas show
+.br
+lib: atlas
+.br
+lib64: reference
+
+The same \fIoptions\fR that apply to the \fBlist\fR action can be used
+with the \fBshow\fR action to restrict it to given ABIs.
+.SH "ACTION: SET"
+\fBeselect blas set\fR \fIimplementation\fR [\fIoptions\fR]
+.br
+Sets your system's currently active BLAS implementations to \fIimplementation\fR.
+The same \fIoptions\fR that apply to the \fBlist\fR action can be used
+with the \fBset\fR action to restrict it to given ABIs.
+
+phi / # eselect blas set atlas
+.SH "AUTHOR"
+Danny van Dyk <kugelfang@gentoo.org>
+.br
+Donnie Berkholz <spyderous@gentoo.org>
diff --git a/app-eselect/eselect-blas/metadata.xml b/app-eselect/eselect-blas/metadata.xml
new file mode 100644
index 000000000000..0c6991d7902b
--- /dev/null
+++ b/app-eselect/eselect-blas/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+</maintainer>
+</pkgmetadata>