summaryrefslogtreecommitdiff
path: root/app-emulation
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/Manifest.gzbin15301 -> 15298 bytes
-rw-r--r--app-emulation/uxn/Manifest4
-rw-r--r--app-emulation/uxn/uxn-0_p20240304.ebuild72
-rw-r--r--app-emulation/uxn/uxn-9999.ebuild66
4 files changed, 116 insertions, 26 deletions
diff --git a/app-emulation/Manifest.gz b/app-emulation/Manifest.gz
index 0efd56b1a0d5..e5ac0ecc31b0 100644
--- a/app-emulation/Manifest.gz
+++ b/app-emulation/Manifest.gz
Binary files differ
diff --git a/app-emulation/uxn/Manifest b/app-emulation/uxn/Manifest
index 3374b9ca0a31..9edbb1e7b316 100644
--- a/app-emulation/uxn/Manifest
+++ b/app-emulation/uxn/Manifest
@@ -1,5 +1,7 @@
AUX uxn-0_p20230609-build.sh.patch 626 BLAKE2B 08b58d26f892354e5a6b6e19bfd11584ed62ae4b4640fee99f5baf636eb42a3c9e28d073d95e30e6fcba2ef17b3ad59ae9d06568e0883c244233b42f60b284f9 SHA512 b95e1026abbb28dc152cc5ecb176921d7ff3db9356c2dce95220ab0d360b9535bfc5996839ad19b77a9346304c51e430b9f69747b7dd39a6621f86330e382cb3
DIST uxn-0_p20230803.tar.gz 293291 BLAKE2B 2e295f83bc695861732ad0412900435900bd10c08a99b0a6e88a5a5e10fde3f462b8ff35261365bfec1f7777306e1684eb1dac767cf7a1f83b3e30e36e79d98e SHA512 89b666b11099037404e48cd6cc7467bcbc84fb90c24cc3df183996f26f2a6817d84fe47857d2d9777acd0aed9885e17c726f3b2f32253d0ba3a77f32b46f8abf
+DIST uxn-0_p20240304.tar.gz 307083 BLAKE2B 2b3a556c5094fd777d82d75c87f721d1a9ea136334cdbc8553662281ae498beb79514e9e567e79b84a625b2fe60b486aa7f6892594cbd08abbbfeb4c9a50b2e9 SHA512 048e24e33de04913e03fbf1b242837dd1ad190f52ede16c302cf436399f0ee478afca545236dd438e03d8dfc29252478c2d79c9b6d3e8d34bb83c99f1930d026
EBUILD uxn-0_p20230803.ebuild 1343 BLAKE2B fc067b1ac212846944ee6259e515607263e5757a76895bda5ea1df7ea8dba641ea0346e58b2cd13c3b6ecf08bc8bbef8741ec7f7f61aa9c2904fc33f6f31e2da SHA512 12a2d3600a4cee4357f841464b7b9119eaed5f54d382dfd29f5785cda0925d61c8aa4e419f1aa8cd2da1405d483b330ed1ecfb2eb4332a2945222be1d396089c
-EBUILD uxn-9999.ebuild 1323 BLAKE2B 376bd1edb1b84cf377032ff9df309e114364ea6b48014c8c5c2f8c8e532b3443405ee58842d0137e7b38e91c99b5cd1da8ff8cd2ef5f834498b62840722a868f SHA512 25d37ae437f9b36a080c8f9c5dde25b8c13954d7ba781c4e487efa3bf2d460867625c771c90cdd7f7f22dc7c5688b56ea41a3af5352ba681132fd5e02bdf9c28
+EBUILD uxn-0_p20240304.ebuild 1646 BLAKE2B 434f20522a3389e650c334d4ddcd1590d698ce1668aaf686278e6a2c50520315b91af7aa534cb29ea6622c2fe2fe4ef4b86a0f78e4c75d9bec48ebfa6a39c8e9 SHA512 528ebaae0b341070543c66fdc7cf836c4b9a16bae08fbaf1b7bd98513f0ffc35354c570969f17564756ab6d25e98e4a99f139c8eeaf8b171257ec5d3e9587975
+EBUILD uxn-9999.ebuild 1646 BLAKE2B 434f20522a3389e650c334d4ddcd1590d698ce1668aaf686278e6a2c50520315b91af7aa534cb29ea6622c2fe2fe4ef4b86a0f78e4c75d9bec48ebfa6a39c8e9 SHA512 528ebaae0b341070543c66fdc7cf836c4b9a16bae08fbaf1b7bd98513f0ffc35354c570969f17564756ab6d25e98e4a99f139c8eeaf8b171257ec5d3e9587975
MISC metadata.xml 643 BLAKE2B 11f4437dbab961e620e204294cb8b18e1ef43c2c79411f8b1224a36276c6a4781e3cb5e854040c979eaa27dc145eb606576ba20076d16a301e33aea6bdcd0df4 SHA512 b5bf43fdcafed44459ac77576f631105175691078b8094d505657fdacc0519856ca063890d432051aa5bff8853ca55f7b10d3b8f680230605de63f69b0acf997
diff --git a/app-emulation/uxn/uxn-0_p20240304.ebuild b/app-emulation/uxn/uxn-0_p20240304.ebuild
new file mode 100644
index 000000000000..ef6e9fc2dafe
--- /dev/null
+++ b/app-emulation/uxn/uxn-0_p20240304.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An assembler and emulator for the Uxn stack-machine, written in ANSI C"
+HOMEPAGE="https://wiki.xxiivv.com/site/uxn.html
+ https://git.sr.ht/~rabbits/uxn/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://git.sr.ht/~rabbits/${PN}"
+elif [[ "${PV}" == *_p20240304 ]] ; then
+ COMMIT=e7c25fad05850f0e577fc83a140405ca6ccd93c2
+ SRC_URI="https://git.sr.ht/~rabbits/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/uxn-${COMMIT}"
+
+ KEYWORDS="~amd64 ~x86"
+else
+ die "wrong package version (PV), please update the ebuild, given: ${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ media-libs/libsdl2:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}/uxn-0_p20230609-build.sh.patch"
+)
+
+src_compile() {
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ ./build.sh --no-run \
+ || die "building with \"build.sh\" failed"
+
+ # Fails to assemble via following loop.
+ # Possibly not mean to be assembled by hand.
+ rm -rf ./projects/library ./projects/software/{asma,launcher}.tal || die
+
+ local tal_file
+ local tal_file_base
+
+ while read -r tal_file ; do
+ tal_file_base="$(basename "${tal_file}" .tal)"
+
+ ebegin "Assembling ROM ${tal_file_base}"
+ bin/uxnasm "${tal_file}" "$(dirname "${tal_file}")/${tal_file_base}.rom"
+ eend ${?} || die "failed to assemble ${tal_file}"
+ done \
+ < <(find projects -type f -name "*.tal")
+}
+
+src_install() {
+ insinto /usr/bin
+ doins bin/uxn*
+ fperms 0755 /usr/bin/uxn*
+
+ insinto /usr/share/uxn
+ doins -r projects
+
+ einstalldocs
+}
diff --git a/app-emulation/uxn/uxn-9999.ebuild b/app-emulation/uxn/uxn-9999.ebuild
index 65b28334a901..ef6e9fc2dafe 100644
--- a/app-emulation/uxn/uxn-9999.ebuild
+++ b/app-emulation/uxn/uxn-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,47 +9,63 @@ DESCRIPTION="An assembler and emulator for the Uxn stack-machine, written in ANS
HOMEPAGE="https://wiki.xxiivv.com/site/uxn.html
https://git.sr.ht/~rabbits/uxn/"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://git.sr.ht/~rabbits/uxn"
-elif [[ ${PV} == *_p20230609 ]] ; then
- COMMIT=f3674b2562e6c5557fc008edbac71d9fcfde64ff
- SRC_URI="https://git.sr.ht/~rabbits/uxn/archive/${COMMIT}.tar.gz
+
+ EGIT_REPO_URI="https://git.sr.ht/~rabbits/${PN}"
+elif [[ "${PV}" == *_p20240304 ]] ; then
+ COMMIT=e7c25fad05850f0e577fc83a140405ca6ccd93c2
+ SRC_URI="https://git.sr.ht/~rabbits/${PN}/archive/${COMMIT}.tar.gz
-> ${P}.tar.gz"
- S="${WORKDIR}"/uxn-${COMMIT}
+ S="${WORKDIR}/uxn-${COMMIT}"
+
KEYWORDS="~amd64 ~x86"
else
- die "wrong package version (PV), given: ${PV}"
+ die "wrong package version (PV), please update the ebuild, given: ${PV}"
fi
LICENSE="MIT"
SLOT="0"
-RDEPEND="media-libs/libsdl2:="
-DEPEND="${RDEPEND}"
+RDEPEND="
+ media-libs/libsdl2:=
+"
+DEPEND="
+ ${RDEPEND}
+"
-PATCHES=( "${FILESDIR}"/uxn-0_p20230609-build.sh.patch )
+PATCHES=(
+ "${FILESDIR}/uxn-0_p20230609-build.sh.patch"
+)
src_compile() {
- CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}" ./build.sh --no-run ||
- die "build failed"
-
- local f
- local f_base
- for f in ./projects/{examples/*,software,utils}/*.tal ; do
- f_base="$(basename "${f}" .tal)"
- ebegin "Assembling ROM ${f_base}"
- ./bin/uxnasm "${f}" "$(dirname "${f}")"/"${f_base}".rom
- eend ${?} || die "failed to assemble ${f}"
- done
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ ./build.sh --no-run \
+ || die "building with \"build.sh\" failed"
+
+ # Fails to assemble via following loop.
+ # Possibly not mean to be assembled by hand.
+ rm -rf ./projects/library ./projects/software/{asma,launcher}.tal || die
+
+ local tal_file
+ local tal_file_base
+
+ while read -r tal_file ; do
+ tal_file_base="$(basename "${tal_file}" .tal)"
+
+ ebegin "Assembling ROM ${tal_file_base}"
+ bin/uxnasm "${tal_file}" "$(dirname "${tal_file}")/${tal_file_base}.rom"
+ eend ${?} || die "failed to assemble ${tal_file}"
+ done \
+ < <(find projects -type f -name "*.tal")
}
src_install() {
- exeinto /usr/bin
- doexe bin/uxn*
+ insinto /usr/bin
+ doins bin/uxn*
+ fperms 0755 /usr/bin/uxn*
insinto /usr/share/uxn
- doins bin/*.rom
doins -r projects
einstalldocs