summaryrefslogtreecommitdiff
path: root/app-emulation
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/Manifest.gzbin14829 -> 14826 bytes
-rw-r--r--app-emulation/protontricks/Manifest2
-rw-r--r--app-emulation/protontricks/protontricks-1.10.2.ebuild57
3 files changed, 59 insertions, 0 deletions
diff --git a/app-emulation/Manifest.gz b/app-emulation/Manifest.gz
index 8384ee261f15..9a885af86d5f 100644
--- a/app-emulation/Manifest.gz
+++ b/app-emulation/Manifest.gz
Binary files differ
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index 1cdfdf7b7f8e..7cc609310094 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1,3 +1,5 @@
DIST protontricks-1.10.1.tar.gz 160943 BLAKE2B 12361ce009a62bdba8c420069f87879bf22e047df8bd6d843fb8672222fe6ab04d61f03a44c43a147729461a2f872e2239ee97d737aba28ffdbb273e797be218 SHA512 0b6e3277ea8a106d2bc52cc805b0c3a023733f0a6554fabfe9f32ff27d1bdf04058a419a719c7ca81dc45759a803a83b03408806e4b9328664e572655a3c4df0
+DIST protontricks-1.10.2.tar.gz 162325 BLAKE2B 5e9d0bf2970ad0e9a5ef5e399af5e327781c94f3e76e36db3a93a93d59102436a54e926a72a22b4640178534d2b9e62452543706c7ec10ce4591f15ce00ac4f3 SHA512 f644e13f356f899b8084ed1d347c210b624c09676f3a644f973610d1134658dd2951e8f85178606639b0eca8c386e9abac89c658a7076e4126278ff955549f10
EBUILD protontricks-1.10.1.ebuild 1400 BLAKE2B feec99d4f2752b0d7735527ea8440db1da66347202a57146ce1d733132409313a222e15c8310de411ff4c1f8f43ab2b34b0f207b78de1faa0e905ea6a3e3ad3e SHA512 6c6e74e9f11951dafa2baaafcc0eb6a703635e546551ae7620ef667b4c4d388eeca6e69740a17c64e1c9c1247012e28c0eea8ff5907cf1572b3cb59507f3a002
+EBUILD protontricks-1.10.2.ebuild 1354 BLAKE2B 096ef197b4dbf053f225846f91af2d4fc4ddaa6ea34663a3647c9e291b52bf2fc473434de2424159680b2031a472e08668dab34c227cf0c89c33207b58a4b73b SHA512 60f5a31286cfbc810d8adec51428416dda24bc707507a8262bd020dfd1dc7e3a089730f8dd12232087e0fb45efc41125c50674c27816dae48c43715314cde249
MISC metadata.xml 809 BLAKE2B dc0506e6f3224adc867438699359c4eafc389041846c644818732036e04bcb9c789e358a08effdb4b9ff4430521f7fe8ff6800b75aa93d6313e3d85395467741 SHA512 351bb79dc7921e6c62100b3354546185d31578b044393ea5e5b5fea089eb47164882ff4ede30d8a575dea31ec9d0927793f8109d9e63ca4ad6954c1affdbe6f4
diff --git a/app-emulation/protontricks/protontricks-1.10.2.ebuild b/app-emulation/protontricks/protontricks-1.10.2.ebuild
new file mode 100644
index 000000000000..dae98e9c173d
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.10.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi xdg-utils
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="app-emulation/winetricks
+ $(python_gen_cond_dep '
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/vdf[${PYTHON_USEDEP}]
+ ')
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+BDEPEND="$(python_gen_cond_dep '
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+')"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}