summaryrefslogtreecommitdiff
path: root/app-emulation
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/Manifest.gzbin15331 -> 15336 bytes
-rw-r--r--app-emulation/vkd3d/Manifest2
-rw-r--r--app-emulation/vkd3d/vkd3d-1.7.1.ebuild44
3 files changed, 46 insertions, 0 deletions
diff --git a/app-emulation/Manifest.gz b/app-emulation/Manifest.gz
index fa51b6cbb312..9eb348e460ef 100644
--- a/app-emulation/Manifest.gz
+++ b/app-emulation/Manifest.gz
Binary files differ
diff --git a/app-emulation/vkd3d/Manifest b/app-emulation/vkd3d/Manifest
index f7e7db455b0d..4282200720e5 100644
--- a/app-emulation/vkd3d/Manifest
+++ b/app-emulation/vkd3d/Manifest
@@ -1,3 +1,5 @@
+DIST vkd3d-1.7.1.tar.xz 806772 BLAKE2B f83fd405dd2fedb2bc38bf64fd5e401fab1b9d5364b812eb34bc45cdeef684786cd59abe304ce71c722b8fe7a729bef18a90b1cb86f2522e45fa1f4d2d0340bb SHA512 59958d3ca6a6485173cc43d701dba4e82eca1eee895128520b5eb0c392fc2911cade37d945ba52a8f50a2639fa5d8d487609c5f3f88ae76e6d914a448ac179b6
DIST vkd3d-1.7.tar.xz 807176 BLAKE2B 1e2b03c8440bdf9306e9c08d557dd6b622c689e94f7d4bcb4ce752cbfbe48ddb0b577f9fee14ab8ac2fc08395205328efc5b437a8fc67d5bb0fd868db0902378 SHA512 008c63742d939e8dc755bd382208d52e145d3ad7a5fe7ae71d41be3e3efd609b513add2ec43c6947a183b6a7595e3f0d8bdc6628835577fa5b7f7ec8a5dea347
+EBUILD vkd3d-1.7.1.ebuild 955 BLAKE2B 6c07bfaf9fef56957b298efa120a79d4b20a5ab7da8af1ac5d47a8b12e2e08566c080c8fcb8498bd7dff3c1c70c2bd5e7bf4d8452cd019cc8441683716776fd6 SHA512 4ff642fb41072a96ed8f8571bf1effe3ba2628f08e3b957ca0d2da29143da2db42b60f0c42b55e6065588aa8c997d713d14530eaafaec63e92987fc5826930ab
EBUILD vkd3d-1.7.ebuild 953 BLAKE2B 0e57f0cdb2b971e06df97e10df11d18d00ec517d809a72eb77352f621322767b69fb4601f4c9a22d326a0557cb6bc5c78ee9cd59dcdb130acf37e2b86820c207 SHA512 48082c3b522bbca92debe3121731623e8c5fbd8e302e23394250a4af77ddc1cdd917a72a3d732efe64fcaeb169930f755e632a4b2a2cefbd4f9112faa471bda6
MISC metadata.xml 563 BLAKE2B c976a16a495bdb5863811acda56b2cc628683a63fc2a22c18d2a09775d3a38c845e00f83b97b318d9a0e5267bb470dd56d334dc9f43e3716784254802b8db60b SHA512 3d5afb7890b3b10ad424fcfe3fa2b42a9227ba0b82be8ab85308126966f476798818ee0ecc88c53105b218f465a72b213efe00968112431169884a4a6f48c6a8
diff --git a/app-emulation/vkd3d/vkd3d-1.7.1.ebuild b/app-emulation/vkd3d/vkd3d-1.7.1.ebuild
new file mode 100644
index 000000000000..cea4a98c8e5e
--- /dev/null
+++ b/app-emulation/vkd3d/vkd3d-1.7.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="D3D12 to Vulkan translation library"
+HOMEPAGE="https://gitlab.winehq.org/wine/vkd3d/"
+SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses spirv-tools"
+RESTRICT="test" #838655
+
+RDEPEND="
+ media-libs/vulkan-loader[${MULTILIB_USEDEP}]
+ ncurses? ( sys-libs/ncurses:= )
+ spirv-tools? ( dev-util/spirv-tools[${MULTILIB_USEDEP}] )"
+DEPEND="
+ ${RDEPEND}
+ dev-util/spirv-headers
+ dev-util/vulkan-headers"
+BDEPEND="
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig"
+
+multilib_src_configure() {
+ local conf=(
+ $(multilib_native_use_with ncurses)
+ $(use_with spirv-tools)
+ --disable-doxygen-pdf
+ --without-xcb
+ )
+
+ ECONF_SOURCE=${S} econf "${conf[@]}"
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f -name '*.la' -delete || die
+}