summaryrefslogtreecommitdiff
path: root/app-emulation/wine-staging/wine-staging-9.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine-staging/wine-staging-9.2.ebuild')
-rw-r--r--app-emulation/wine-staging/wine-staging-9.2.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-emulation/wine-staging/wine-staging-9.2.ebuild b/app-emulation/wine-staging/wine-staging-9.2.ebuild
index 9790d6480e7e..6b83fcb60f31 100644
--- a/app-emulation/wine-staging/wine-staging-9.2.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9.2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
MULTILIB_COMPAT=( abi_x86_{32,64} )
PYTHON_COMPAT=( python3_{10..12} )
-inherit autotools edo flag-o-matic multilib multilib-build
+inherit autotools edo flag-o-matic optfeature multilib multilib-build
inherit prefix python-any-r1 toolchain-funcs wrapper
WINE_GECKO=2.47.4
@@ -461,6 +461,9 @@ pkg_postinst() {
ewarn "applications under ${PN} will likely not be usable."
fi
+ optfeature "/dev/hidraw* access used for *some* controllers (e.g. DualShock4)" \
+ games-util/game-device-udev-rules
+
eselect wine update --if-unset || die
}