summaryrefslogtreecommitdiff
path: root/app-emulation/virt-manager/virt-manager-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/virt-manager/virt-manager-9999.ebuild')
-rw-r--r--app-emulation/virt-manager/virt-manager-9999.ebuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/app-emulation/virt-manager/virt-manager-9999.ebuild b/app-emulation/virt-manager/virt-manager-9999.ebuild
index 40577b554f57..2b7f150c0d93 100644
--- a/app-emulation/virt-manager/virt-manager-9999.ebuild
+++ b/app-emulation/virt-manager/virt-manager-9999.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{8,9,10} )
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_SETUPTOOLS=no
-inherit gnome2 distutils-r1
+inherit gnome2 distutils-r1 optfeature
DESCRIPTION="A graphical tool for administering virtual machines"
-HOMEPAGE="http://virt-manager.org"
+HOMEPAGE="https://virt-manager.org https://github.com/virt-manager/virt-manager"
if [[ ${PV} = *9999* ]]; then
inherit git-r3
@@ -19,7 +19,7 @@ if [[ ${PV} = *9999* ]]; then
EGIT_BRANCH="master"
else
SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
fi
LICENSE="GPL-2"
@@ -42,17 +42,14 @@ RDEPEND="${PYTHON_DEPS}
gnome-base/dconf
>=net-libs/gtk-vnc-0.3.8[gtk3(+),introspection]
net-misc/spice-gtk[usbredir,gtk3,introspection,sasl?]
- net-misc/x11-ssh-askpass
x11-libs/gtk+:3[introspection]
x11-libs/gtksourceview:4[introspection]
x11-libs/vte:2.91[introspection]
policykit? ( sys-auth/polkit[introspection] )
- )
-"
-DEPEND="${RDEPEND}
- dev-python/docutils
- dev-util/intltool
-"
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/docutils
+ dev-util/intltool"
distutils_enable_tests pytest
@@ -63,8 +60,7 @@ src_prepare() {
}
python_configure() {
- esetup.py configure \
- --default-graphics=spice
+ esetup.py configure --default-graphics=spice
}
python_install() {
@@ -96,4 +92,5 @@ pkg_preinst() {
pkg_postinst() {
use gtk && gnome2_pkg_postinst
+ optfeature "SSH_ASKPASS program implementation" lxqt-base/lxqt-openssh-askpass net-misc/ssh-askpass-fullscreen net-misc/x11-ssh-askpass
}