summaryrefslogtreecommitdiff
path: root/app-emulation/uade
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/uade')
-rw-r--r--app-emulation/uade/Manifest2
-rw-r--r--app-emulation/uade/files/uade-2.13-configure.patch24
-rw-r--r--app-emulation/uade/uade-2.13-r1.ebuild39
3 files changed, 65 insertions, 0 deletions
diff --git a/app-emulation/uade/Manifest b/app-emulation/uade/Manifest
index 2d8e35048e7a..208d7f31b79e 100644
--- a/app-emulation/uade/Manifest
+++ b/app-emulation/uade/Manifest
@@ -1,3 +1,5 @@
+AUX uade-2.13-configure.patch 620 BLAKE2B 4266246e968f5bcbfee755896047c5c0587a5199d8fc7882b4f9665175865a94491d6bfceaf3549b6f825e46688ab2f6164f6b4111101212f907d9bdec3f2b28 SHA512 08d5caa315054553414961cd44149f949099341f9c91b4dd7ee957649fa029b9c1927f583bd581e6b213f381b3eb43fe5097a87747ce7e36e94487fafdc96c76
DIST uade-2.13.tar.bz2 2897931 BLAKE2B 7d5ba128fc53bb683a6a21616e3c9c2a7376361086f3d91a59026ac89eb48d9520f89342914078ccb4614a16826a8c90f86a6052caffc9d5cc4e1e0ab6b092f0 SHA512 675c3369ed55a314cab81ae7ba8a09b277ab1cfe2354eac92194f746803ec2464b7603d665cf30da41caef5997c21515e69f0313d8d2b079c242a08fef786183
+EBUILD uade-2.13-r1.ebuild 824 BLAKE2B 383a094b4634f1f733832b2c3d66d71d7f4f28ff2d85c0e41f20652c2c9da5d320868b077f49dc558fade5c82548fac5e81f53f433cace622b91eb382f0489b7 SHA512 c61726e48b585d2ec2b96e4c765793e601c036855f2b5e29fcea888d51e704550c90efdf49a6297edb77f1b408ee0cb5ba6e5f2425541e1f3cd97cdb4bb693f0
EBUILD uade-2.13.ebuild 703 BLAKE2B f70f7552702e66e71bb5762cc98675dafaf6009f7d5b8dce66d0be26dc8aafffbfe50bfa68a9cf3fed562900bd0b13b886706514d9c298726f08cedee8c8af41 SHA512 51aa80ca564ec7baa6c89a36be7f4ac36c5e6884cc936099b4cfb426f0de154f6239183de22b26767b3310a627865060194aa73217bd5e1ec2eac08910d8a531
MISC metadata.xml 249 BLAKE2B 7113a758d7abc93accec998a8843d8ef51ca8b72d72e659e224d5cec2a1a6a63e6c0605958091532ac6e51fa0d501ca4fd9f3f4a9e55baeb31519a02971b465f SHA512 895577c3a805c40581da03057b94e3f28f05f23012bf350c1e3575847d1a0fe40bb044a46f909012a200d991a400f6389358a60e9c2b5bef0da01fb26f846118
diff --git a/app-emulation/uade/files/uade-2.13-configure.patch b/app-emulation/uade/files/uade-2.13-configure.patch
new file mode 100644
index 000000000000..305e354766fb
--- /dev/null
+++ b/app-emulation/uade/files/uade-2.13-configure.patch
@@ -0,0 +1,24 @@
+--- uade-2.13/configure 2009-10-29 22:01:12.000000000 +0100
++++ uade-2.13-r1/configure 2020-06-30 20:03:45.237913031 +0200
+@@ -342,8 +342,11 @@
+ if test -z "$prefix"; then
+ prefix="/usr/local"
+ fi
++ if test -z "$libdir" ; then
++ libdir="$prefix/lib"
++ fi
+ uadedatadir="$prefix/share/uade2"
+- uadelibdir="$prefix/lib/uade2"
++ uadelibdir="$libdir/uade2"
+ if test -z "$bindir"; then
+ bindir="$prefix/bin"
+ fi
+@@ -439,7 +442,7 @@
+ fi
+ fi
+
+-pkgconfigdir="$prefix/lib/pkgconfig"
++pkgconfigdir="$libdir/pkgconfig"
+ rm -f uade.pc
+ if test -n "$PKG_CONFIG" ; then
+ installuadepcrule=""
diff --git a/app-emulation/uade/uade-2.13-r1.ebuild b/app-emulation/uade/uade-2.13-r1.ebuild
new file mode 100644
index 000000000000..c98dd0660e1a
--- /dev/null
+++ b/app-emulation/uade/uade-2.13-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE emulation"
+HOMEPAGE="https://zakalwe.fi/uade"
+SRC_URI="https://zakalwe.fi/uade/uade2/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="media-libs/libao"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog doc/BUGS doc/PLANS )
+
+PATCHES=( "${FILESDIR}"/${P}-configure.patch )
+
+src_configure() {
+ tc-export CC
+
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --package-prefix="${D}" \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --with-text-scope \
+ --without-xmms \
+ --without-audacious || die
+}
+
+src_install() {
+ default
+ doman doc/uade123.1
+}