summaryrefslogtreecommitdiff
path: root/app-emulation/runc/runc-1.0.0_rc7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/runc/runc-1.0.0_rc7.ebuild')
-rw-r--r--app-emulation/runc/runc-1.0.0_rc7.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/app-emulation/runc/runc-1.0.0_rc7.ebuild b/app-emulation/runc/runc-1.0.0_rc7.ebuild
deleted file mode 100644
index 9a9686fa4afe..000000000000
--- a/app-emulation/runc/runc-1.0.0_rc7.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN="github.com/opencontainers/${PN}"
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-build golang-vcs
-else
- MY_PV="${PV/_/-}"
- RUNC_COMMIT="69ae5da6afdcaaf38285a10b36f362e41cb298d6" # Change this when you update the ebuild
- SRC_URI="https://${EGO_PN}/archive/${RUNC_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64"
- inherit golang-build golang-vcs-snapshot
-fi
-
-DESCRIPTION="runc container cli tools"
-HOMEPAGE="http://runc.io"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="+ambient apparmor hardened +kmem +seccomp"
-
-RDEPEND="
- apparmor? ( sys-libs/libapparmor )
- seccomp? ( sys-libs/libseccomp )
- !app-emulation/docker-runc
-"
-
-src_prepare() {
- pushd src/${EGO_PN}
- default
- sed -i -e "/^GIT_BRANCH/d"\
- -e "/^GIT_BRANCH_CLEAN/d"\
- -e "/^COMMIT_NO/d"\
- -e "s/COMMIT :=.*/COMMIT := ${RUNC_COMMIT}/"\
- Makefile || die
- popd || die
-}
-
-src_compile() {
- # Taken from app-emulation/docker-1.7.0-r1
- export CGO_CFLAGS="-I${ROOT}/usr/include"
- export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
- -L${ROOT}/usr/$(get_libdir)"
-
- # build up optional flags
- local options=(
- $(usex ambient 'ambient' '')
- $(usex apparmor 'apparmor' '')
- $(usex seccomp 'seccomp' '')
- $(usex kmem '' 'nokmem')
- )
-
- GOPATH="${S}" emake BUILDTAGS="${options[*]}" -C src/${EGO_PN}
-}
-
-src_install() {
- pushd src/${EGO_PN} || die
- dobin runc
- dodoc README.md PRINCIPLES.md
- popd || die
-}