summaryrefslogtreecommitdiff
path: root/app-emulation/ruffle/ruffle-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/ruffle/ruffle-9999.ebuild')
-rw-r--r--app-emulation/ruffle/ruffle-9999.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/app-emulation/ruffle/ruffle-9999.ebuild b/app-emulation/ruffle/ruffle-9999.ebuild
index 4fb5bd694470..ced4e9790b1e 100644
--- a/app-emulation/ruffle/ruffle-9999.ebuild
+++ b/app-emulation/ruffle/ruffle-9999.ebuild
@@ -80,7 +80,16 @@ src_configure() {
}
src_test() {
- virtx cargo_src_test
+ xdg_environment_reset
+
+ local skip=(
+ # this should be fine on real hardware, but currently fails with mesa's
+ # software rendering (bug #911320) -- note they are auto-skipped if
+ # USE=-gles2 on mesa, and this just forces to skip regardless
+ --skip visual/filters/displacement_map
+ )
+
+ virtx cargo_src_test -- "${skip[@]}"
}
src_install() {