summaryrefslogtreecommitdiff
path: root/app-emulation/reg/reg-0.13.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/reg/reg-0.13.4.ebuild')
-rw-r--r--app-emulation/reg/reg-0.13.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emulation/reg/reg-0.13.4.ebuild b/app-emulation/reg/reg-0.13.4.ebuild
new file mode 100644
index 000000000000..f22026d1213f
--- /dev/null
+++ b/app-emulation/reg/reg-0.13.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/reg"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="8dba69bce413988846a6defa063f35ab38a31991"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Docker registry v2 command line client"
+HOMEPAGE="https://github.com/genuinetools/reg"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/reg . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc src/${EGO_PN}/README.md
+}