summaryrefslogtreecommitdiff
path: root/app-emulation/qtrvsim
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/qtrvsim')
-rw-r--r--app-emulation/qtrvsim/Manifest3
-rw-r--r--app-emulation/qtrvsim/metadata.xml11
-rw-r--r--app-emulation/qtrvsim/qtrvsim-0.9.7.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/app-emulation/qtrvsim/Manifest b/app-emulation/qtrvsim/Manifest
new file mode 100644
index 000000000000..3e271531e1cb
--- /dev/null
+++ b/app-emulation/qtrvsim/Manifest
@@ -0,0 +1,3 @@
+DIST qtrvsim-0.9.7.tar.gz 1421805 BLAKE2B 9128dbe513860eafd01e0f37a99547797d385b57a404e06aea310404012e66e6be802920cdea62acb914d355fc842cd3759fc794d2cd417257b941f9ec62fbec SHA512 0d53e21681630cbf97db472472bd96dfe4914e0d275a1094cb18a7f0372cef23b0dea3c33092b6ab6d2403737070ef0b6f2b1f5d9d35eea8923b24a80ac6adfe
+EBUILD qtrvsim-0.9.7.ebuild 504 BLAKE2B 209df140832a50bf7c7850bd281919064b8fda8a0f68455801fd4bd8b4746c83fd451e372037874dcf34914187a7073a9bd6d6a5ecefed06d88dd7addcca455e SHA512 fcacb079387d05edd43edde6edb0ccde9c32e34e3bec22cc3b92cd5aa87c0ea558e27a385b18cc24ed258a8b481b8520b2c3f8c6b6d76910d3d74adb39eafa4e
+MISC metadata.xml 324 BLAKE2B 88e9410454f1433824206295d14983c6cd3121248db77d052d1aadce997e7fdcbfa982837bbe3ec01038af57e3d54ac0f025874c91f3e4b938a17d330b185e98 SHA512 be34381fedb16ca3f974824e0c7af4033cc1f3fd0089e93449fd04dc84624581a05ee9083dc23b12fa58f6a55994e77a0fe58b5a9263b55b36acdd52e071591f
diff --git a/app-emulation/qtrvsim/metadata.xml b/app-emulation/qtrvsim/metadata.xml
new file mode 100644
index 000000000000..38cc1db28ca8
--- /dev/null
+++ b/app-emulation/qtrvsim/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>flow@gentoo.org</email>
+ <name>Florian Schmaus</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cvut/qtrvsim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emulation/qtrvsim/qtrvsim-0.9.7.ebuild b/app-emulation/qtrvsim/qtrvsim-0.9.7.ebuild
new file mode 100644
index 000000000000..88e56acd60ea
--- /dev/null
+++ b/app-emulation/qtrvsim/qtrvsim-0.9.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="RISC-V CPU simulator for education"
+HOMEPAGE="https://github.com/cvut/qtrvsim"
+SRC_URI="https://github.com/cvut/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-qt/qtbase:6[gui,widgets]
+ virtual/libelf:=
+"
+RDEPEND="${DEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # Fails in 0.9.7, but not in master.
+ cli_stalls
+)