summaryrefslogtreecommitdiff
path: root/app-emulation/qemu/qemu-6.2.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/qemu/qemu-6.2.0-r2.ebuild')
-rw-r--r--app-emulation/qemu/qemu-6.2.0-r2.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/app-emulation/qemu/qemu-6.2.0-r2.ebuild b/app-emulation/qemu/qemu-6.2.0-r2.ebuild
index 481bf31b0386..10b0bf44d7de 100644
--- a/app-emulation/qemu/qemu-6.2.0-r2.ebuild
+++ b/app-emulation/qemu/qemu-6.2.0-r2.ebuild
@@ -34,8 +34,8 @@ SLOT="0"
IUSE="accessibility +aio alsa bpf bzip2 capstone +caps +curl debug +doc
+fdt fuse glusterfs gnutls gtk infiniband iscsi io-uring
- jack jemalloc +jpeg kernel_linux
- kernel_FreeBSD lzo multipath
+ jack jemalloc +jpeg
+ lzo multipath
ncurses nfs nls numa opengl +oss pam +pin-upstream-blobs
plugins +png pulseaudio python rbd sasl +seccomp sdl sdl-image selinux
+slirp
@@ -472,11 +472,9 @@ qemu_src_configure() {
$(use_enable alsa)
$(use_enable debug debug-info)
$(use_enable debug debug-tcg)
- $(use_enable doc docs)
$(use_enable jack)
$(use_enable nls gettext)
$(use_enable oss)
- $(use_enable pam auth-pam)
$(use_enable plugins)
$(use_enable pulseaudio pa)
$(use_enable selinux)
@@ -523,6 +521,7 @@ qemu_src_configure() {
$(conf_notuser capstone)
$(conf_notuser caps cap-ng)
$(conf_notuser curl)
+ $(conf_tools doc docs)
$(conf_notuser fdt)
$(conf_notuser fuse)
$(conf_notuser glusterfs)
@@ -541,6 +540,7 @@ qemu_src_configure() {
$(conf_notuser nfs libnfs)
$(conf_notuser numa)
$(conf_notuser opengl)
+ $(conf_notuser pam auth-pam)
$(conf_notuser png vnc-png)
$(conf_notuser rbd)
$(conf_notuser sasl vnc-sasl)
@@ -647,11 +647,6 @@ qemu_src_configure() {
echo "../configure ${conf_opts[*]}"
cd "${builddir}"
../configure "${conf_opts[@]}" || die "configure failed"
-
- # FreeBSD's kernel does not support QEMU assigning/grabbing
- # host USB devices yet
- use kernel_FreeBSD && \
- sed -i -E -e "s|^(HOST_USB=)bsd|\1stub|" "${S}"/config-host.mak
}
src_configure() {