summaryrefslogtreecommitdiff
path: root/app-emulation/qemu/files/qemu-9999-fix-firmware-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/qemu/files/qemu-9999-fix-firmware-path.patch')
-rw-r--r--app-emulation/qemu/files/qemu-9999-fix-firmware-path.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/app-emulation/qemu/files/qemu-9999-fix-firmware-path.patch b/app-emulation/qemu/files/qemu-9999-fix-firmware-path.patch
new file mode 100644
index 000000000000..ffff31402b6c
--- /dev/null
+++ b/app-emulation/qemu/files/qemu-9999-fix-firmware-path.patch
@@ -0,0 +1,17 @@
+Set absolute filename in files like
+ /usr/share/qemu/firmware/50-edk2-x86_64-secure.json
+
+Bug: https://bugs.gentoo.org/766743
+Bug: https://bugs.launchpad.net/qemu/+bug/1913012
+Patch-by: Jannik Glückert
+--- a/pc-bios/descriptors/meson.build
++++ b/pc-bios/descriptors/meson.build
+@@ -9,7 +9,7 @@ if install_edk2_blobs
+ ]
+ configure_file(input: files(f),
+ output: f,
+- configuration: {'DATADIR': qemu_datadir},
++ configuration: {'DATADIR': get_option('prefix') / qemu_datadir},
+ install: get_option('install_blobs'),
+ install_dir: qemu_datadir / 'firmware')
+ endforeach