summaryrefslogtreecommitdiff
path: root/app-emulation/punes/punes-0.102.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/punes/punes-0.102.ebuild')
-rw-r--r--app-emulation/punes/punes-0.102.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-emulation/punes/punes-0.102.ebuild b/app-emulation/punes/punes-0.102.ebuild
new file mode 100644
index 000000000000..cb13a8549234
--- /dev/null
+++ b/app-emulation/punes/punes-0.102.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools xdg-utils
+
+DESCRIPTION="Nintendo Entertainment System (NES) emulator"
+HOMEPAGE="https://github.com/punesemu/puNES"
+SRC_URI="https://github.com/punesemu/puNES/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cg"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ cg? ( media-gfx/nvidia-cg-toolkit )
+ media-libs/alsa-lib
+ media-libs/libsdl[opengl]
+ virtual/opengl"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/puNES-${PV}"
+
+src_prepare() {
+ default
+
+ sed -i "/update-desktop-database/d" misc/Makefile.am || die
+ eautoreconf
+ # FIXME why eautoreconf can't handle this?
+ cd "src/extra/lib7zip-1.6.5" || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-qt5 \
+ $(use_with cg opengl-nvidia-cg)
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}