summaryrefslogtreecommitdiff
path: root/app-emulation/protontricks/protontricks-1.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/protontricks/protontricks-1.3.1.ebuild')
-rw-r--r--app-emulation/protontricks/protontricks-1.3.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-emulation/protontricks/protontricks-1.3.1.ebuild b/app-emulation/protontricks/protontricks-1.3.1.ebuild
new file mode 100644
index 000000000000..0b0e576d39a3
--- /dev/null
+++ b/app-emulation/protontricks/protontricks-1.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_SINGLE_IMPL=1
+inherit distutils-r1
+
+DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
+HOMEPAGE="https://github.com/Matoking/protontricks"
+SRC_URI="https://codeload.github.com/Matoking/${PN}/tar.gz/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+RDEPEND="${PYTHON_DEPS}
+ app-emulation/winetricks
+ dev-python/vdf[${PYTHON_USEDEP}]
+ gui? ( gnome-extra/zenity
+ || (
+ app-emulation/winetricks[gtk]
+ app-emulation/winetricks[kde]
+ )
+ )"
+
+DOCS=(CHANGELOG.md README.md)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ elog
+
+ if ! use gui; then
+ ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
+ ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
+ ewarn
+ fi
+
+ elog "Protontricks can only find games for which a Proton prefix already exists."
+ elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
+ elog
+}