summaryrefslogtreecommitdiff
path: root/app-emulation/pcem
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/pcem')
-rw-r--r--app-emulation/pcem/Manifest3
-rw-r--r--app-emulation/pcem/files/pcem-17-respect-cflags.patch13
-rw-r--r--app-emulation/pcem/pcem-17.ebuild77
3 files changed, 93 insertions, 0 deletions
diff --git a/app-emulation/pcem/Manifest b/app-emulation/pcem/Manifest
index 089eda497358..be8d0cc823f2 100644
--- a/app-emulation/pcem/Manifest
+++ b/app-emulation/pcem/Manifest
@@ -1,4 +1,7 @@
AUX pcem-15-respect-cflags.patch 300 BLAKE2B 4531829e43d43501fe889b34381fc056ffa2734ca499686558cf39ef245f3808e6488c32d6938487d018175ab8a370a28e491cc957406ea6e430a9afff44dae2 SHA512 7800d9056fc1ab4b38f97a6021da7288b990ab9c562846be1ae4ec6636c888fd444c635076f070c50f39681202995a41575823a225c77017d389638feaf1a93c
+AUX pcem-17-respect-cflags.patch 273 BLAKE2B 5c6bb6335677a1784b7fe99de3ebfc47351ab1c849d03f656e5428fd309256c46736ce6faf709aa379279c52ebdc7b46ea2e15ab1aa60a43dbdfc91fa09581af SHA512 4b83837f623971ccb91f525cee9bace2b9fd6b3a776a7d6907ec8e8796a021d8d68e665fc0dff7db083c7e068d6e07d3d61049ee2d9209c5b3d59a0fca388064
DIST PCemV16Linux.tar.gz 1859892 BLAKE2B e388031e661b9320cc783e6400bdb7c191a2f946d9c207d9a58daa9270115b32ed55ac6a0b87227b51d10168e7d161bb03811eb83f5405ed1a71f7bfc6fd8aa5 SHA512 97d33ae1c4b59f281abe553ed4297c0d6c3956cf32b44474bfd5773700dd5c4ea6c209c679b9add5d4a7cba61748ee9794afa3c59af3230fa2a15812e13fd1c5
+DIST PCemV17Linux.tar.gz 1880868 BLAKE2B 64068f0f98e8fe3e9bfe42a04f462375a7ee0cb8259b103237f3b0542f54ad13ed625a55c8379e2c54a87348ed504496a6b163419855ceeda8e4f18e1ea5dcd9 SHA512 6d84c8cbe9b6116f6439f542ac08139cfc5652a34b615a1ed841a6f8c227e77f1d26573ec35d57511b9a69e7472fbe51f2abb9307f8f8c1207c74fbe8107cadd
EBUILD pcem-16-r1.ebuild 1633 BLAKE2B 735440b0bda54c7433fda65d0147c201ce0afa98f138afaa2f5837ee1fffdbb2613996b15ddeb97f0c529db498336a58225b1647c1d760c41c8a21a0dbe79cce SHA512 6896184bbdb47b3e112abffe1296c147f67b07fe56ecb5bff7a399ee8de4dd42d2642eec936c0ceb08e45d8142fba1879a66fc658bf151f961a3fc42033548a2
+EBUILD pcem-17.ebuild 1664 BLAKE2B d43817f2f4f7cde340a081d4f9d740bad55d776d6926bdebe167aceaee72f2f3852734e51514fa093f7d7011ac0578286411f6c4c35294b8aae013bf6fa0aa50 SHA512 ddd6634df57c85ec406ac1147707b61c2035c59a56bc85ddafe85f16eee8ca36626f45d3bd642fd4a26f3c7eb25034b250f7496621cf2566fa0503d739d4cd41
MISC metadata.xml 857 BLAKE2B c678e4578dca5c14416690cf8a421d4d1d8887237a4600580aad48d1d4ea6b641cc3c1f47c6c00be44344b760aa87c2b9bbded7625e0ccaedd0c8c2cb14dd057 SHA512 e610d16662365ae271fab8a2364e5781ba4be7a841d36759bc4e319b7f87a589c02131aeea83f194eabf940c0c4439459127468c0a65a72e3e2e91c74c0d409d
diff --git a/app-emulation/pcem/files/pcem-17-respect-cflags.patch b/app-emulation/pcem/files/pcem-17-respect-cflags.patch
new file mode 100644
index 000000000000..73cac4541bf1
--- /dev/null
+++ b/app-emulation/pcem/files/pcem-17-respect-cflags.patch
@@ -0,0 +1,13 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -31,8 +31,8 @@
+ CXXFLAGS="-Wall -O0 -g -D_DEBUG -fcommon"
+ AC_MSG_RESULT([yes])
+ else
+- CFLAGS="-O3 -fcommon"
+- CXXFLAGS="-O3 -fcommon"
++ CFLAGS?="-O3 -fcommon"
++ CXXFLAGS?="-O3 -fcommon"
+ AC_MSG_RESULT([no])
+ fi
+
diff --git a/app-emulation/pcem/pcem-17.ebuild b/app-emulation/pcem/pcem-17.ebuild
new file mode 100644
index 000000000000..825619a6ac61
--- /dev/null
+++ b/app-emulation/pcem/pcem-17.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop flag-o-matic wxwidgets
+
+WX_GTK_VER="3.0-gtk3"
+
+DESCRIPTION="A PC emulator that specializes in running old operating systems and software"
+HOMEPAGE="
+ https://pcem-emulator.co.uk/
+ https://github.com/sarah-walker-pcem/pcem/
+"
+SRC_URI="https://pcem-emulator.co.uk/files/PCemV${PV}Linux.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="alsa networking"
+
+S="${WORKDIR}"
+
+RDEPEND="
+ alsa? ( media-libs/alsa-lib )
+ media-libs/libsdl2
+ media-libs/openal
+ x11-libs/wxGTK:${WX_GTK_VER}[tiff,X]
+"
+
+DEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "TESTED.md" )
+
+PATCHES=( "${FILESDIR}/${PN}-17-respect-cflags.patch" )
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # Does not compile with -fno-common.
+ # See https://pcem-emulator.co.uk/phpBB3/viewtopic.php?f=3&t=3443
+ append-cflags -fcommon
+
+ local myeconfargs=(
+ --enable-release-build
+ $(use_enable alsa)
+ $(use_enable networking)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/pcem
+ doins -r configs nvr roms
+
+ newicon src/icons/32x32/motherboard.png pcem.png
+ make_desktop_entry "pcem" "PCem" pcem "Development;Utility"
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "In order to use PCem, you will need some roms for various emulated systems."
+ elog "You can either install globally for all users or locally for yourself."
+ elog ""
+ elog "To install globally, put your ROM files into '${ROOT}/usr/share/pcem/roms/<system>'."
+ elog "To install locally, put your ROM files into '~/.pcem/roms/<system>'."
+}