summaryrefslogtreecommitdiff
path: root/app-emulation/nemu
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/nemu')
-rw-r--r--app-emulation/nemu/Manifest3
-rw-r--r--app-emulation/nemu/metadata.xml5
-rw-r--r--app-emulation/nemu/nemu-9999.ebuild74
3 files changed, 81 insertions, 1 deletions
diff --git a/app-emulation/nemu/Manifest b/app-emulation/nemu/Manifest
index b043de6dc047..55eeb8d693b9 100644
--- a/app-emulation/nemu/Manifest
+++ b/app-emulation/nemu/Manifest
@@ -4,4 +4,5 @@ DIST nemu-1.3.0.tar.gz 70769 BLAKE2B 73108346c70f7ececd2b20cc91da323f2ecb4049140
EBUILD nemu-1.1.0.ebuild 873 BLAKE2B e12690f1d1126c8dfd810b599e9b35e4ef8d01411609009761df056ae1c297f0ef0968f2e4a5e1a8ec6d905e0bbe168a3b8c2b8d478657f1a3b855512479374f SHA512 8639e85e33e4941e3425473e363c710d8e0cc1a09aed00d31c12a349065ba3be98392cfdb3fb2d82e1381caac17a07f6862733aed0215bff931e4dd33930a2b5
EBUILD nemu-1.2.0.ebuild 873 BLAKE2B e12690f1d1126c8dfd810b599e9b35e4ef8d01411609009761df056ae1c297f0ef0968f2e4a5e1a8ec6d905e0bbe168a3b8c2b8d478657f1a3b855512479374f SHA512 8639e85e33e4941e3425473e363c710d8e0cc1a09aed00d31c12a349065ba3be98392cfdb3fb2d82e1381caac17a07f6862733aed0215bff931e4dd33930a2b5
EBUILD nemu-1.3.0.ebuild 873 BLAKE2B e12690f1d1126c8dfd810b599e9b35e4ef8d01411609009761df056ae1c297f0ef0968f2e4a5e1a8ec6d905e0bbe168a3b8c2b8d478657f1a3b855512479374f SHA512 8639e85e33e4941e3425473e363c710d8e0cc1a09aed00d31c12a349065ba3be98392cfdb3fb2d82e1381caac17a07f6862733aed0215bff931e4dd33930a2b5
-MISC metadata.xml 251 BLAKE2B f3c965f619454b2d17e1039b6c218308c83af9214f41a5b18244ce9bd811b0a0b6e0227fdaac9b1659a2e2467e6b992b771ff6cf431220648363ab8173ee76f2 SHA512 e8203a24b5e739dcf0d94742215ee6ccdccbd00bb43001f9df58d27100fa427b01937065e1d7399e3552532b09179611e06099e3af14aac5fcf9ddc4ca5463da
+EBUILD nemu-9999.ebuild 1916 BLAKE2B 232c49c84167c44c6fc3afd2e1b26cb6f820b53d345956c4d92058368f095206e3351ac431728a6f8847a88e53f09af7e39b5ff24874635b231b9a1ca6df7abc SHA512 87b016f6a485c921222428b96b11687cfb906118cfc398318b14f45ebd1c09aeb710b0cdea389a41e5936478e31645925599b32fe203fe07559debb54d7ed9b4
+MISC metadata.xml 499 BLAKE2B 2d190da58be258c1e5e997128bc65e9f928c9ec86e9be23d43cc881c92d9cd65e9cdee6db7afb92abf799aaa552ad5ddcf6dbdafd26d12c2521e8724f7f98471 SHA512 42e56aaad5eff7d180c6af0ef571f5fca4e101e934fc7506387456d89068ab8446e861dcd1124d85d962bf05b48a26833d0883b7c152c7214c79c324c18d236f
diff --git a/app-emulation/nemu/metadata.xml b/app-emulation/nemu/metadata.xml
index 58c1077b82e4..ad75c6dc879c 100644
--- a/app-emulation/nemu/metadata.xml
+++ b/app-emulation/nemu/metadata.xml
@@ -5,4 +5,9 @@
<email>monsieurp@gentoo.org</email>
<name>Patrice Clement</name>
</maintainer>
+ <use>
+ <flag name="vnc-client">Adds support for external VNC client</flag>
+ <flag name="savevm">Adds support for QEMU savevm snapshots (experimental, QEMU must be patched)</flag>
+ <flag name="ovf">Adds support for OVA/OVF import</flag>
+ </use>
</pkgmetadata>
diff --git a/app-emulation/nemu/nemu-9999.ebuild b/app-emulation/nemu/nemu-9999.ebuild
new file mode 100644
index 000000000000..fe30968437c7
--- /dev/null
+++ b/app-emulation/nemu/nemu-9999.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils linux-info git-r3
+
+DESCRIPTION="ncurses interface for QEMU"
+HOMEPAGE="https://lib.void.so/nemu"
+EGIT_REPO_URI="https://bitbucket.org/PascalRD/nemu.git"
+SRC_URI=""
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="+vnc-client +ovf savevm debug"
+
+RDEPEND="
+ sys-libs/ncurses:0=[unicode]
+ dev-db/sqlite:3=
+ virtual/libusb:1
+ || ( sys-fs/eudev sys-fs/udev )
+ app-emulation/qemu[vnc,virtfs]
+ ovf? (
+ dev-libs/libxml2
+ app-arch/libarchive
+ )
+ vnc-client? ( net-misc/tigervnc )"
+
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext"
+
+src_configure() {
+ local mycmakeargs=(
+ -DNM_WITH_VNC_CLIENT=$(usex vnc-client)
+ -DNM_DEBUG=$(usex debug)
+ -DNM_SAVEVM_SNAPSHOTS=$(usex savevm)
+ -DNM_WITH_OVF_SUPPORT=$(usex ovf)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_pretend() {
+ if use kernel_linux; then
+ if ! linux_config_exists; then
+ eerror "Unable to check your kernel"
+ else
+ CONFIG_CHECK="~VETH ~MACVTAP"
+ ERROR_VETH="You will need the Virtual ethernet pair device driver compiled"
+ ERROR_VETH+=" into your kernel or loaded as a module to use the"
+ ERROR_VETH+=" local network settings feature."
+ ERROR_MACVTAP="You will also need support for MAC-VLAN based tap driver."
+
+ check_extra_config
+ fi
+ fi
+}
+
+pkg_postinst() {
+ elog "Old database is not supported (nEMU versions < 1.0.0)."
+ elog "You will need to delete current database."
+ elog "If upgraded from 1.0.0, execute script:"
+ elog "/usr/share/nemu/scripts/upgrade_db.sh"
+ elog ""
+ elog "For non-root usage execute script:"
+ elog "/usr/share/nemu/scripts/setup_nemu_nonroot.sh linux <username>"
+ elog "and add udev rule:"
+ elog "cp /usr/share/nemu/scripts/42-net-macvtap-perm.rules /lib/udev/rules.d"
+ if use savevm; then
+ elog ""
+ elog "QEMU must be patched with qemu-qmp-savevm-VERSION.patch"
+ elog "Get this patch from nEMU repository"
+ fi
+}