summaryrefslogtreecommitdiff
path: root/app-emulation/libguestfs
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/libguestfs')
-rw-r--r--app-emulation/libguestfs/Manifest4
-rw-r--r--app-emulation/libguestfs/libguestfs-1.48.4.ebuild4
-rw-r--r--app-emulation/libguestfs/libguestfs-1.48.6.ebuild242
3 files changed, 248 insertions, 2 deletions
diff --git a/app-emulation/libguestfs/Manifest b/app-emulation/libguestfs/Manifest
index ba5fb0dd7085..bf12ea12d565 100644
--- a/app-emulation/libguestfs/Manifest
+++ b/app-emulation/libguestfs/Manifest
@@ -1,3 +1,5 @@
DIST libguestfs-1.48.4.tar.gz 19189712 BLAKE2B 50a11254c21903caa62b40b43e3ab3cc9e740dd0c690055c245391d0a980279a897e727f0ff5b063b197b91a1e6fdadc08e257d5cd4ce3df254e5c42abc32ee3 SHA512 76b942de88fa6fb48db667054a2c4fc23dd17b0a6083cddd51f1a77fdac24c0c7acd6be5234ada955b4afa94b0d8023aab50aa152465a6bc65f0e21d4195d50c
-EBUILD libguestfs-1.48.4.ebuild 5815 BLAKE2B 684566a87a7baa8ed9fea8958138ba88d89458fb4787c3560ae30d41d5ff27ffade00db19b3915307568580633c6a618c09f77a75a2df04c7ca2f8440ac88f68 SHA512 39ea2e0d6f69767c2a773d3242ad0d140f792d3876d0fdb24ffd4efc14ba2af330898051c2d8f4cb34de54fc5805d7e7d343e5a09f4e23f3807fc4864cf309a2
+DIST libguestfs-1.48.6.tar.gz 19179600 BLAKE2B 22359ed4b55e29f985dbbbc4f0337eaec32f21a1413bd778656c3f0270891bec520a0b9590e104836eaf9367aeb9ac681b0bf85852fb7a2059da3f7062bc5111 SHA512 7d929db183fbb1d4d1c9159f28871ab4f1bd0be5b3d9fbc5137271666f50c067fd0906674cb1a52c1e070c11a18da4d2aa11bc64ddabda5cac54e72252c6abf2
+EBUILD libguestfs-1.48.4.ebuild 5847 BLAKE2B 3878f05340bc52f586f97d4ead00a31239add6f111d1179a29add4d74749889d1a2d6f35565df5bc7a31a5bcc09cfe6ff4c07083eb11cd1eb731643a2714b85d SHA512 203060ead52b2066762fa232e1cdd3903d4cebe6973697999ae9b4f851dd74b5491abb7018143de27a26298cc899168e5d5421ecc80b3a643fa7b611c5ae785d
+EBUILD libguestfs-1.48.6.ebuild 5847 BLAKE2B c1e22c956684f0e916ec5735b54cf1b3016f7bd14c59dad195ba2d11db1c4c1453c211fa4b3ddf8456e5bd262d3788680d047a60dc6fd1616363aed711152b5c SHA512 94acb7fdeb048b1b6252a853401a417a98a5ed9c428ecd3aca44521be822837c04cd69846afdca45acd7febd8f42306cf0c8660565ccaeec1a1b4d3fe1b97258
MISC metadata.xml 698 BLAKE2B 2a0e16a1041be0a08e428e2fe3398d08623bfe1b16522b9f7e0e7e35a8b5a9c7c4c622d480c6d3c23a9c479c54cce41892b0af8dfa5c28c29fcc394950d73888 SHA512 8aed858a396c37c434fb21a0c3f1028a6bda8021c0ef3581a2c68d8fc8c3832ff2c9a44d14f80696cff4a783e787a647bee01e3770018090e67866f670fc9be7
diff --git a/app-emulation/libguestfs/libguestfs-1.48.4.ebuild b/app-emulation/libguestfs/libguestfs-1.48.4.ebuild
index 9cfc764e17f9..7f8cadfd34f9 100644
--- a/app-emulation/libguestfs/libguestfs-1.48.4.ebuild
+++ b/app-emulation/libguestfs/libguestfs-1.48.4.ebuild
@@ -16,7 +16,7 @@ MY_PV_2="$(ver_cut 2)"
DESCRIPTION="Tools for accessing, inspecting, and modifying virtual machine (VM) disk images"
HOMEPAGE="https://libguestfs.org/"
-SRC_URI="https://libguestfs.org/download/${MY_PV_1}-${SD}/${P}.tar.gz"
+SRC_URI="https://download.libguestfs.org/${MY_PV_1}-${SD}/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2"
SLOT="0/${MY_PV_1}"
@@ -227,6 +227,8 @@ src_install() {
doman "${ED}"/usr/man/man3/Sys::Guestfs.3pm
rm -rf "${ED}"/usr/man || die
fi
+
+ use python && python_optimize
}
pkg_postinst() {
diff --git a/app-emulation/libguestfs/libguestfs-1.48.6.ebuild b/app-emulation/libguestfs/libguestfs-1.48.6.ebuild
new file mode 100644
index 000000000000..76e72067e4a5
--- /dev/null
+++ b/app-emulation/libguestfs/libguestfs-1.48.6.ebuild
@@ -0,0 +1,242 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Bump with app-emulation/guestfs-tools and app-emulation/libguestfs-appliance (if any new release there)
+
+LUA_COMPAT=( lua5-1 )
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit autotools flag-o-matic linux-info lua-single perl-functions python-single-r1 strip-linguas toolchain-funcs
+
+MY_PV_1="$(ver_cut 1-2)"
+MY_PV_2="$(ver_cut 2)"
+[[ $(( ${MY_PV_2} % 2 )) -eq 0 ]] && SD="stable" || SD="development"
+
+DESCRIPTION="Tools for accessing, inspecting, and modifying virtual machine (VM) disk images"
+HOMEPAGE="https://libguestfs.org/"
+SRC_URI="https://download.libguestfs.org/${MY_PV_1}-${SD}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0/${MY_PV_1}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc erlang +fuse gtk inspect-icons introspection libvirt lua +ocaml +perl python ruby selinux static-libs systemtap test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Failures - doc
+COMMON_DEPEND="
+ >=app-admin/augeas-1.8.0
+ app-arch/cpio
+ app-arch/lzma
+ app-arch/rpm
+ app-arch/unzip[natspec]
+ app-arch/xz-utils
+ app-forensics/yara
+ app-cdr/cdrtools
+ app-crypt/gnupg
+ >=app-emulation/qemu-2.0[qemu_softmmu_targets_x86_64,systemtap?,selinux?,filecaps]
+ >=app-misc/hivex-1.3.1
+ dev-lang/perl:=
+ dev-libs/libconfig:=
+ dev-libs/libpcre2
+ dev-libs/libxml2:2=
+ dev-libs/jansson:=
+ >=dev-libs/yajl-2.0.4
+ net-libs/libtirpc:=
+ sys-libs/ncurses:0=
+ >=sys-apps/fakechroot-2.8
+ sys-apps/fakeroot
+ sys-apps/file
+ sys-devel/gettext
+ sys-fs/squashfs-tools:*
+ sys-libs/libcap
+ sys-libs/readline:=
+ virtual/acl
+ virtual/libcrypt:=
+ erlang? ( dev-lang/erlang )
+ perl? (
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Sys-Virt-0.2.4
+ virtual/perl-Getopt-Long
+ virtual/perl-Data-Dumper
+ dev-perl/libintl-perl
+ >=app-misc/hivex-1.3.1[perl?]
+ dev-perl/String-ShellQuote
+ )
+ python? ( ${PYTHON_DEPS} )
+ fuse? ( sys-fs/fuse:= )
+ gtk? (
+ sys-apps/dbus
+ x11-libs/gtk+:3
+ )
+ introspection? (
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/gobject-introspection-1.30.0:=
+ )
+ inspect-icons? (
+ media-libs/netpbm
+ media-gfx/icoutils
+ )
+ libvirt? ( app-emulation/libvirt )
+ lua? ( ${LUA_DEPS} )
+ ocaml? ( >=dev-lang/ocaml-4.03:=[ocamlopt] )
+ selinux? (
+ sys-libs/libselinux:=
+ sys-libs/libsemanage
+ )
+ systemtap? ( dev-util/systemtap )
+"
+# Some OCaml is always required
+# bug #729674
+DEPEND="${COMMON_DEPEND}
+ >=dev-lang/ocaml-4.03:=[ocamlopt]
+ dev-util/gperf
+ dev-ml/findlib[ocamlopt]
+ doc? ( app-text/po4a )
+ ocaml? (
+ dev-ml/ounit2[ocamlopt]
+ || (
+ <dev-ml/ocaml-gettext-0.4.2
+ dev-ml/ocaml-gettext-stub[ocamlopt]
+ )
+ )
+ ruby? ( dev-lang/ruby virtual/rubygems dev-ruby/rake )
+ test? ( introspection? ( dev-libs/gjs ) )
+"
+BDEPEND="virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ app-emulation/libguestfs-appliance
+ acct-group/kvm
+"
+# Upstream build scripts compile and install Lua bindings for the ABI version
+# obtained by running 'lua' on the build host
+BDEPEND="lua? ( ${LUA_DEPS} )"
+
+DOCS=( AUTHORS BUGS ChangeLog HACKING README TODO )
+
+PATCHES=(
+ #"${FILESDIR}"/${MY_PV_1}/
+ #"${FILESDIR}"/1.44/
+)
+
+pkg_setup() {
+ CONFIG_CHECK="~KVM ~VIRTIO"
+ [[ -n "${CONFIG_CHECK}" ]] && check_extra_config
+
+ use lua && lua-single_pkg_setup
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ # bug #794877
+ tc-export AR
+
+ # Skip Bash test
+ # (See 13-test-suite.log in linked bug)
+ # bug #794874
+ export SKIP_TEST_COMPLETE_IN_SCRIPT_SH=1
+
+ # Need to investigate (fails w/ 1.48.4)
+ export SKIP_TEST_QEMU_DRIVE_SH=1
+ export SKIP_TEST_BIG_HEAP=1
+ export SKIP_TEST_NOEXEC_STACK_PL=1
+
+ # Need to be in KVM group
+ export SKIP_TEST_MOUNTABLE_INSPECT_SH=1
+
+ # Missing test data (Fedora image)
+ export SKIP_TEST_JOURNAL_PL=1
+
+ # Disable feature test for kvm for more reason
+ # i.e: not loaded module in __build__ time,
+ # build server not supported kvm, etc. ...
+ #
+ # In fact, this feature is virtio support and requires
+ # configured kernel.
+ export vmchannel_test=no
+
+ # Give a nudge to help find libxcrypt[-system]
+ # We have a := dep on virtual/libcrypt to ensure this doesn't become stale.
+ # bug #703118, bug #789354
+ if ! has_version 'sys-libs/libxcrypt[system]' ; then
+ append-ldflags "-L${ESYSROOT}/usr/$(get_libdir)/xcrypt"
+ append-ldflags "-Wl,-R${ESYSROOT}/usr/$(get_libdir)/xcrypt"
+ fi
+
+ # Avoid automagic SELinux dependency
+ export ac_cv_header_selinux_selinux_h=$(usex selinux)
+
+ # Test suite at least has a bunch of bashisms
+ SHELL="${BROOT}"/bin/bash CONFIG_SHELL="${BROOT}"/bin/bash econf \
+ --disable-appliance \
+ --disable-daemon \
+ --disable-haskell \
+ --disable-golang \
+ --disable-rust \
+ --disable-php \
+ --without-java \
+ --with-extra="-gentoo" \
+ --with-readline \
+ $(usex doc '' PO4A=no) \
+ $(use_enable ocaml) \
+ $(use_enable erlang) \
+ $(use_enable fuse) \
+ $(use_enable introspection gobject) \
+ $(use_enable introspection) \
+ $(use_with libvirt) \
+ $(use_enable lua) \
+ $(use_enable python) \
+ $(use_enable perl) \
+ $(use_enable ruby) \
+ $(use_enable static-libs static) \
+ $(use_enable systemtap probes)
+}
+
+src_test() {
+ local -x LIBGUESTFS_DEBUG=1
+ local -x LIBGUESTFS_TRACE=1
+ local -x LIBVIRT_DEBUG=1
+
+ # Try this?
+ #emake quickcheck
+
+ default
+}
+
+src_install() {
+ strip-linguas -i po
+
+ emake DESTDIR="${D}" install "LINGUAS=""${LINGUAS}"""
+
+ find "${ED}" -name '*.la' -delete || die
+
+ if use perl ; then
+ perl_delete_localpod
+
+ # Workaround Build.PL for now
+ doman "${ED}"/usr/man/man3/Sys::Guestfs.3pm
+ rm -rf "${ED}"/usr/man || die
+ fi
+
+ use python && python_optimize
+}
+
+pkg_postinst() {
+ einfo "Please ensure you are in the 'kvm' group for decent performance!"
+
+ if ! use gtk ; then
+ einfo "virt-p2v NOT installed"
+ fi
+
+ einfo "Note that common tools like virt-resize are now part of app-emulation/guestfs-tools"
+}