summaryrefslogtreecommitdiff
path: root/app-emulation/libguestfs/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/libguestfs/files')
-rw-r--r--app-emulation/libguestfs/files/1.28/0000_bug_499150.patch10
-rw-r--r--app-emulation/libguestfs/files/1.28/0001_add_gentoo_names_to_configure.patch15
-rw-r--r--app-emulation/libguestfs/files/1.28/0002_add_gentooway_to_remove_la_files.patch16
-rw-r--r--app-emulation/libguestfs/files/1.28/0005_enable_gtk_docs_in_broken_autotools-utils-eclass.patch21
-rw-r--r--app-emulation/libguestfs/files/1.28/0103_disable_php_bindings_makefile.patch13
-rw-r--r--app-emulation/libguestfs/files/1.36/0001-Update-libtool-initialization.patch29
-rw-r--r--app-emulation/libguestfs/files/1.36/0002-Add-support-for-Gentoo-in-distribution-detection.patch25
-rw-r--r--app-emulation/libguestfs/files/1.36/0003-Workaround-autotools-utils-detection-of-gtk-doc.patch42
8 files changed, 171 insertions, 0 deletions
diff --git a/app-emulation/libguestfs/files/1.28/0000_bug_499150.patch b/app-emulation/libguestfs/files/1.28/0000_bug_499150.patch
new file mode 100644
index 000000000000..1e0f1a32185e
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.28/0000_bug_499150.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac 2014-01-24 19:04:05.633056872 +0100
++++ b/configure.ac 2014-01-24 19:04:34.685691757 +0100
+@@ -24,6 +24,7 @@
+
+ AC_INIT([libguestfs],libguestfs_major.libguestfs_minor.libguestfs_release)
+ AC_CONFIG_AUX_DIR([build-aux])
++AM_GNU_GETTEXT_VERSION(0.18.3)
+
+ dnl Initialize automake. automake < 1.12 didn't have serial-tests and
+ dnl gives an error if it sees this, but for automake >= 1.13
diff --git a/app-emulation/libguestfs/files/1.28/0001_add_gentoo_names_to_configure.patch b/app-emulation/libguestfs/files/1.28/0001_add_gentoo_names_to_configure.patch
new file mode 100644
index 000000000000..9d209ff53584
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.28/0001_add_gentoo_names_to_configure.patch
@@ -0,0 +1,15 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -482,6 +482,11 @@
+ DISTRO=UBUNTU
+ fi
+ fi
++
++if test -f /etc/gentoo-release; then
++ DISTRO=GENTOO
++fi
++
+ if test -f /etc/arch-release; then
+ DISTRO=ARCHLINUX
+ fi
diff --git a/app-emulation/libguestfs/files/1.28/0002_add_gentooway_to_remove_la_files.patch b/app-emulation/libguestfs/files/1.28/0002_add_gentooway_to_remove_la_files.patch
new file mode 100644
index 000000000000..38a591b811ed
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.28/0002_add_gentooway_to_remove_la_files.patch
@@ -0,0 +1,16 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -1487,8 +1487,10 @@
+
+ dnl Replace libtool with a wrapper that clobbers dependency_libs in *.la files
+ dnl http://lists.fedoraproject.org/pipermail/devel/2010-November/146343.html
+-LIBTOOL='bash $(top_srcdir)/libtool-kill-dependency_libs.sh $(top_builddir)/libtool'
+-AC_SUBST([LIBTOOL])
++dnl LIBTOOL='bash $(top_srcdir)/libtool-kill-dependency_libs.sh $(top_builddir)/libtool'
++dnl AC_SUBST([LIBTOOL])
++LT_INIT
++
+
+ dnl Produce output files.
+ AC_CONFIG_HEADERS([config.h])
diff --git a/app-emulation/libguestfs/files/1.28/0005_enable_gtk_docs_in_broken_autotools-utils-eclass.patch b/app-emulation/libguestfs/files/1.28/0005_enable_gtk_docs_in_broken_autotools-utils-eclass.patch
new file mode 100644
index 000000000000..69b3ae6d0d2d
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.28/0005_enable_gtk_docs_in_broken_autotools-utils-eclass.patch
@@ -0,0 +1,21 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -1491,11 +1491,12 @@
+ ])
+
+ # check for gtk-doc
+-m4_ifdef([GTK_DOC_CHECK], [
+- GTK_DOC_CHECK([1.14],[--flavour no-tmpl])
+-],[
+- AM_CONDITIONAL([ENABLE_GTK_DOC], false)
+-])
++#m4_ifdef([GTK_DOC_CHECK], [
++# GTK_DOC_CHECK([1.14],[--flavour no-tmpl])
++#],[
++# AM_CONDITIONAL([ENABLE_GTK_DOC], false)
++#])
++GTK_DOC_CHECK([1.14],[--flavour no-tmpl])
+
+ dnl Library versioning.
+ MAX_PROC_NR=`cat $srcdir/src/MAX_PROC_NR`
diff --git a/app-emulation/libguestfs/files/1.28/0103_disable_php_bindings_makefile.patch b/app-emulation/libguestfs/files/1.28/0103_disable_php_bindings_makefile.patch
new file mode 100644
index 000000000000..34ab42d27903
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.28/0103_disable_php_bindings_makefile.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.am b/Makefile.am
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -88,9 +88,6 @@
+ if HAVE_HASKELL
+ SUBDIRS += haskell
+ endif
+-if HAVE_PHP
+-SUBDIRS += php
+-endif
+ if HAVE_ERLANG
+ SUBDIRS += erlang erlang/examples
+ endif
diff --git a/app-emulation/libguestfs/files/1.36/0001-Update-libtool-initialization.patch b/app-emulation/libguestfs/files/1.36/0001-Update-libtool-initialization.patch
new file mode 100644
index 000000000000..24da76fbab5e
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.36/0001-Update-libtool-initialization.patch
@@ -0,0 +1,29 @@
+From a5fd133e001bb62d13c47ebc392fbb696a513640 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <g.dartiguelongue@lexfo.fr>
+Date: Wed, 30 Aug 2017 11:30:56 +0200
+Subject: [PATCH 1/3] Update libtool initialization
+
+Use the recommanded macro post libtool-2 release.
+---
+ m4/guestfs_misc.m4 | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/m4/guestfs_misc.m4 b/m4/guestfs_misc.m4
+index 5dce207d7..a2bb39c0d 100644
+--- a/m4/guestfs_misc.m4
++++ b/m4/guestfs_misc.m4
+@@ -17,10 +17,7 @@
+
+ dnl Miscellaneous configuration that doesn't fit anywhere else.
+
+-dnl Replace libtool with a wrapper that clobbers dependency_libs in *.la files
+-dnl http://lists.fedoraproject.org/pipermail/devel/2010-November/146343.html
+-LIBTOOL='bash $(top_srcdir)/libtool-kill-dependency_libs.sh $(top_builddir)/libtool'
+-AC_SUBST([LIBTOOL])
++LT_INIT
+
+ dnl Only build boot-analysis program on x86-64 and aarch64. It
+ dnl requires custom work to port to each architecture.
+--
+2.14.1
+
diff --git a/app-emulation/libguestfs/files/1.36/0002-Add-support-for-Gentoo-in-distribution-detection.patch b/app-emulation/libguestfs/files/1.36/0002-Add-support-for-Gentoo-in-distribution-detection.patch
new file mode 100644
index 000000000000..bf265f718c73
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.36/0002-Add-support-for-Gentoo-in-distribution-detection.patch
@@ -0,0 +1,25 @@
+From 9c423cd2d24b6de924afc6e0d715594bb056288d Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <g.dartiguelongue@lexfo.fr>
+Date: Wed, 30 Aug 2017 11:27:50 +0200
+Subject: [PATCH 2/3] Add support for Gentoo in distribution detection
+
+---
+ m4/guestfs_appliance.m4 | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/m4/guestfs_appliance.m4 b/m4/guestfs_appliance.m4
+index 890b1999c..9b79e1a41 100644
+--- a/m4/guestfs_appliance.m4
++++ b/m4/guestfs_appliance.m4
+@@ -114,6 +114,8 @@ elif test -f /etc/frugalware-release; then
+ DISTRO=FRUGALWARE
+ elif test -f /etc/mageia-release; then
+ DISTRO=MAGEIA
++elif test -f /etc/gentoo-release; then
++ DISTRO=GENTOO
+ else
+ dnl fallback option
+ DISTRO=REDHAT
+--
+2.14.1
+
diff --git a/app-emulation/libguestfs/files/1.36/0003-Workaround-autotools-utils-detection-of-gtk-doc.patch b/app-emulation/libguestfs/files/1.36/0003-Workaround-autotools-utils-detection-of-gtk-doc.patch
new file mode 100644
index 000000000000..087708db396a
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.36/0003-Workaround-autotools-utils-detection-of-gtk-doc.patch
@@ -0,0 +1,42 @@
+From 9bfa78095f6090c377fb40970653d1105a343cb7 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <g.dartiguelongue@lexfo.fr>
+Date: Wed, 30 Aug 2017 11:33:58 +0200
+Subject: [PATCH 3/3] Workaround autotools-utils detection of gtk-doc
+
+---
+ configure.ac | 3 +++
+ m4/guestfs_gobject.m4 | 7 -------
+ 2 files changed, 3 insertions(+), 7 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 268e6a182..65f4231bc 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -121,6 +121,9 @@ m4_include([m4/guestfs_lua.m4])
+ m4_include([m4/guestfs_golang.m4])
+ m4_include([m4/guestfs_gobject.m4])
+
++dnl check for gtk-doc
++GTK_DOC_CHECK([1.14],[--flavour no-tmpl])
++
+ dnl Bash completion.
+ m4_include([m4/guestfs_bash_completion.m4])
+
+diff --git a/m4/guestfs_gobject.m4 b/m4/guestfs_gobject.m4
+index 4b4eab80d..4304f7b00 100644
+--- a/m4/guestfs_gobject.m4
++++ b/m4/guestfs_gobject.m4
+@@ -59,10 +59,3 @@ m4_ifdef([GOBJECT_INTROSPECTION_CHECK], [
+ ],[
+ AM_CONDITIONAL([HAVE_INTROSPECTION], [false])
+ ])
+-
+-# check for gtk-doc
+-m4_ifdef([GTK_DOC_CHECK], [
+- GTK_DOC_CHECK([1.14],[--flavour no-tmpl])
+-],[
+- AM_CONDITIONAL([ENABLE_GTK_DOC], false)
+-])
+--
+2.14.1
+