summaryrefslogtreecommitdiff
path: root/app-emulation/libcacard/libcacard-2.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/libcacard/libcacard-2.6.0.ebuild')
-rw-r--r--app-emulation/libcacard/libcacard-2.6.0.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/app-emulation/libcacard/libcacard-2.6.0.ebuild b/app-emulation/libcacard/libcacard-2.6.0.ebuild
index 22750df56b3f..f79632a12098 100644
--- a/app-emulation/libcacard/libcacard-2.6.0.ebuild
+++ b/app-emulation/libcacard/libcacard-2.6.0.ebuild
@@ -9,7 +9,7 @@ SRC_URI="https://www.spice-space.org/download/libcacard/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="alpha amd64 arm ~arm64 ia64 ~ppc ~ppc64 ~sparc x86"
IUSE="+passthrough static-libs"
RDEPEND=">=dev-libs/nss-3.13
@@ -18,6 +18,19 @@ RDEPEND=">=dev-libs/nss-3.13
DEPEND="${RDEPEND}
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}/${P}-simpletlv-test-fix.patch"
+ )
+
+src_prepare() {
+ default
+
+ # remove test requiring SoftHSMv2 which is not in the tree atm
+ sed -i \
+ -e 's|tests/hwtests$(EXEEXT) \($(am__EXEEXT_1)\)|\1|' \
+ Makefile.in || die
+}
+
src_configure() {
econf \
$(use_enable passthrough pcsc) \