summaryrefslogtreecommitdiff
path: root/app-emulation/img
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/img')
-rw-r--r--app-emulation/img/Manifest5
-rw-r--r--app-emulation/img/img-0.3.6.ebuild32
-rw-r--r--app-emulation/img/img-0.3.9.ebuild32
-rw-r--r--app-emulation/img/metadata.xml11
4 files changed, 80 insertions, 0 deletions
diff --git a/app-emulation/img/Manifest b/app-emulation/img/Manifest
new file mode 100644
index 000000000000..7b58379c4d3d
--- /dev/null
+++ b/app-emulation/img/Manifest
@@ -0,0 +1,5 @@
+DIST img-0.3.6.tar.gz 6043716 BLAKE2B 982a6f470f4b79cd4cc2b06be4060f516786f700872510948a25d5ad313cccf402b0fe26c053f7505b66c170221274568ce44632729c16e1ade680b5dc007b0d SHA512 911cf6a761741a04553d5e526399973c0e943cfda5eead7f94196969fed4f586134358b1e6f023c6cf07e755de802e498991eb320bd50af32649749622a26969
+DIST img-0.3.9.tar.gz 6153717 BLAKE2B b561ed349c2b08f0e3448886b6c979d86fd6d4f47af0f03d7dd479a12f078b99f39e10d6a6b3ba9caffe2a9966102e3f3069fa6eacb70bb36f9842314e8a8e7b SHA512 23bf1e85cb9238742ffef44408bece52b5b0fefbeae9541a7740a4d798d1dc2c0f8efd02d8342842753925135dee843c4a7a20abe3a87ce1c475178461c9b8da
+EBUILD img-0.3.6.ebuild 911 BLAKE2B 556f2aacaabc9fd4c32e887c46a05e9759a405877fefd40294002fb2136d32329b62302abe1f7994f2112ab81b3bdffdbfceddc478b4bee3771eb5068be826fc SHA512 7a038c3c6f1742fa2f765310e5c0547d0d970b9db3fd7fc38e771fa6e016dfd2bd273cb5ff8e858e63b4daeb776cf4b2f594cd7e61da493b54c4a550f60e784b
+EBUILD img-0.3.9.ebuild 911 BLAKE2B 556f2aacaabc9fd4c32e887c46a05e9759a405877fefd40294002fb2136d32329b62302abe1f7994f2112ab81b3bdffdbfceddc478b4bee3771eb5068be826fc SHA512 7a038c3c6f1742fa2f765310e5c0547d0d970b9db3fd7fc38e771fa6e016dfd2bd273cb5ff8e858e63b4daeb776cf4b2f594cd7e61da493b54c4a550f60e784b
+MISC metadata.xml 326 BLAKE2B bade1307a8d5bd0a9945fbb417b8506b7aaa4b66d5a502e18af1f7b008e325b5514e0fc018932396aba1116b5a3c11b12b89c43d925f7e97c8a75efcd9ef4f3d SHA512 a75050de970991e19edf7b7560ca46d27c959b9a91dcf87d40d31532c85c7af24ab29743d7295c731a3153774d33b03afa5c92470ca0c0c572d50c6ec65e5692
diff --git a/app-emulation/img/img-0.3.6.ebuild b/app-emulation/img/img-0.3.6.ebuild
new file mode 100644
index 000000000000..661f99352151
--- /dev/null
+++ b/app-emulation/img/img-0.3.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/img"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="e4a43d044778e3df56e0de3c6ca00706fcca8b50"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
+HOMEPAGE="https://github.com/genuinetools/img"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+RESTRICT="test"
+
+src_compile() {
+ local TAGS=$(usex seccomp 'seccomp' '')
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -tags ${TAGS} -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/README.md
+}
diff --git a/app-emulation/img/img-0.3.9.ebuild b/app-emulation/img/img-0.3.9.ebuild
new file mode 100644
index 000000000000..661f99352151
--- /dev/null
+++ b/app-emulation/img/img-0.3.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/img"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="e4a43d044778e3df56e0de3c6ca00706fcca8b50"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
+HOMEPAGE="https://github.com/genuinetools/img"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+RESTRICT="test"
+
+src_compile() {
+ local TAGS=$(usex seccomp 'seccomp' '')
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -tags ${TAGS} -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/README.md
+}
diff --git a/app-emulation/img/metadata.xml b/app-emulation/img/metadata.xml
new file mode 100644
index 000000000000..06bfaa067c93
--- /dev/null
+++ b/app-emulation/img/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel RĂ¼ger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">genuinetools/img</remote-id>
+ </upstream>
+</pkgmetadata>