summaryrefslogtreecommitdiff
path: root/app-emulation/hyperd
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/hyperd')
-rw-r--r--app-emulation/hyperd/Manifest4
-rw-r--r--app-emulation/hyperd/hyperd-0.7.0-r1.ebuild50
-rw-r--r--app-emulation/hyperd/metadata.xml15
3 files changed, 69 insertions, 0 deletions
diff --git a/app-emulation/hyperd/Manifest b/app-emulation/hyperd/Manifest
new file mode 100644
index 000000000000..5c2ae59f2b75
--- /dev/null
+++ b/app-emulation/hyperd/Manifest
@@ -0,0 +1,4 @@
+DIST hyperd-0.7.0.tar.gz 10885921 SHA256 e79d4e6aebe01d2117e981050ecb88dd24f8a9e45e2fbe1a558bcd1ee5d90b88 SHA512 7fc731b393a6bdf173101ee0a6d0e5a3339c6bb6dc1595fbde5b36df5a674f22e95f599e704925532ca0ee5ca931ebdf9f14bba9ad20b62000aee48408adb73f WHIRLPOOL cf911afabcbd7ec9954ad571d12269cff85fb9a84de81a83b483a002707c6ca2e6e8c43540f08f24ae12ccc5eddddc4280e45d67c3a696cfdd2ee4301458aa3d
+EBUILD hyperd-0.7.0-r1.ebuild 1110 SHA256 a43c617f8d9151801c3b7f267e7413f6742709cd61edfe64e24f8411052ea6ef SHA512 acdf45032156d74c79420741ec66c960ebbfd33110214acc18d7859c0c66d3c7e3a33956bf446c495ce4abcb393e303d5f51780252fb820c22fc2679e2a808b8 WHIRLPOOL 4626b38adb75826929b3d54b8bc122b01c1004dd9dc71b5807b55e515cbd1003ba1bacd4b659532523cadd448f66a8b81518efbca7f6e3b3616789f451a769fd
+MISC ChangeLog 526 SHA256 111f8f2be84abf4301ccf014732a553e6e34ee84663ce70c3bb69d1ca88c9655 SHA512 254b12210dd087dd0955a5e4de72aa7db8a64d11315f7df6b9906ffd1e205f982d7cd871810f954315d78c5204528ff0cb0199b2dfe533e0d59b672226553b2a WHIRLPOOL d0be101519b35b7dc649404495ac20b803b20c1e32cc0394966dec33cb5eb39e456a0184b2d4693dac3392b0785652fa298ad9a0ef0d1c0f524eb10bbc7580c5
+MISC metadata.xml 468 SHA256 00d3eae0cdfa0e60dbc36dfe889092789389162a49a7ababfba74e0ffec59911 SHA512 b2c4074f52b8bc7c291bf295d65e8724235e5bc9ca8ce47b0c9da40312909fa9f471fdf42c43442174ee52aaa724aad29c07caf00d5e06a8046dee86efabca92 WHIRLPOOL 51bd257e471ef6c1dd7a0faf50415783c3335e14ec60d92e600ca90be7aee3c2edf8bc11ce07248b8cf49d3c1da6ec6bf06d6393002f88922cc54653acaad370
diff --git a/app-emulation/hyperd/hyperd-0.7.0-r1.ebuild b/app-emulation/hyperd/hyperd-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..60e350cd094e
--- /dev/null
+++ b/app-emulation/hyperd/hyperd-0.7.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/hyperhq/hyperd"
+
+inherit autotools systemd golang-vcs-snapshot
+
+DESCRIPTION="Hypervisor-based Runtime for OCI"
+HOMEPAGE="https://github.com/hyperhq/hyperd"
+SRC_URI="https://github.com/hyperhq/hyperd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libvirt xen"
+
+RDEPEND="libvirt? ( >=app-emulation/libvirt-1.2.2 )
+ xen? ( app-emulation/xen )"
+DEPEND="${RDEPEND}
+ sys-fs/lvm2"
+
+src_prepare() {
+ pushd src/${EGO_PN} || die
+ default
+ eautoreconf
+ popd
+}
+
+src_configure() {
+ local myeconfargs=( $(use_with libvirt)
+ $(use_with xen) )
+ pushd src/${EGO_PN} || die
+ econf "${myeconfargs[@]}"
+ popd
+}
+
+src_compile() {
+ GOPATH="${S}:$(get_golibdir_gopath)" emake -C src/${EGO_PN}
+}
+
+src_install() {
+ dodoc src/${EGO_PN}/README.md
+ dobin src/${EGO_PN}/hyperd
+ dobin src/${EGO_PN}/hyperctl
+ insinto /etc/hyper/
+ doins src/${EGO_PN}/package/dist/etc/hyper/config
+ systemd_dounit src/${EGO_PN}/package/dist/lib/systemd/system/hyperd.service
+}
diff --git a/app-emulation/hyperd/metadata.xml b/app-emulation/hyperd/metadata.xml
new file mode 100644
index 000000000000..8880e0179c0e
--- /dev/null
+++ b/app-emulation/hyperd/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel RĂ¼ger</name>
+ </maintainer>
+ <use>
+ <flag name="libvirt">Enable support for KVM via libvirt</flag>
+ <flag name="xen">Enable support for the Xen Hypervisor</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">hyperhq/hyperd</remote-id>
+ </upstream>
+</pkgmetadata>