summaryrefslogtreecommitdiff
path: root/app-emulation/go-secbench/go-secbench-0.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/go-secbench/go-secbench-0.1.0.ebuild')
-rw-r--r--app-emulation/go-secbench/go-secbench-0.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emulation/go-secbench/go-secbench-0.1.0.ebuild b/app-emulation/go-secbench/go-secbench-0.1.0.ebuild
new file mode 100644
index 000000000000..fdceccf32659
--- /dev/null
+++ b/app-emulation/go-secbench/go-secbench-0.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/qnib/go-secbench"
+inherit golang-build golang-vcs-snapshot
+
+DESCRIPTION="run and evaluate the docker security benchmark"
+HOMEPAGE="https://github.com/qnib/go-secbench"
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+
+DEPEND="dev-lang/go"
+
+src_compile() {
+ GOPATH="${S}" go build -o bin/go-secbench src/${EGO_PN}/cmd/main.go || die
+}
+
+src_install() {
+ dobin bin/${PN}
+dodoc "src/${EGO_PN}/README.md"
+}