summaryrefslogtreecommitdiff
path: root/app-emulation/docker-runc/docker-runc-1.0.0_rc2_p20170308.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/docker-runc/docker-runc-1.0.0_rc2_p20170308.ebuild')
-rw-r--r--app-emulation/docker-runc/docker-runc-1.0.0_rc2_p20170308.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-emulation/docker-runc/docker-runc-1.0.0_rc2_p20170308.ebuild b/app-emulation/docker-runc/docker-runc-1.0.0_rc2_p20170308.ebuild
new file mode 100644
index 000000000000..0026a2692717
--- /dev/null
+++ b/app-emulation/docker-runc/docker-runc-1.0.0_rc2_p20170308.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/docker/${PN/docker-}"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_/-}"
+ EGIT_COMMIT="54296cf40ad8143b62dbcaa1d90e520a2136ddfe"
+ RUNC_COMMIT="54296cf" # Change this when you update the ebuild
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~arm ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="runc container cli tools (docker fork)"
+HOMEPAGE="http://runc.io"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="apparmor hardened +seccomp"
+
+RDEPEND="
+ apparmor? ( sys-libs/libapparmor )
+ seccomp? ( sys-libs/libseccomp )
+ !app-emulation/runc
+"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test"
+
+src_compile() {
+ # Taken from app-emulation/docker-1.7.0-r1
+ export CGO_CFLAGS="-I${ROOT}/usr/include"
+ export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
+ -L${ROOT}/usr/$(get_libdir)"
+
+ # Setup GOPATH so things build
+ rm -rf .gopath
+ mkdir -p .gopath/src/"$(dirname "${GITHUB_URI}")"
+ ln -sf ../../../.. .gopath/src/"${GITHUB_URI}"
+ export GOPATH="${PWD}/.gopath:${PWD}/vendor"
+
+ # build up optional flags
+ local options=(
+ $(usex apparmor 'apparmor')
+ $(usex seccomp 'seccomp')
+ )
+
+ emake BUILDTAGS="${options[*]}" \
+ COMMIT="${RUNC_COMMIT}"
+}
+
+src_install() {
+ dobin runc
+}