summaryrefslogtreecommitdiff
path: root/app-emulation/docker-proxy/docker-proxy-0.8.0_p20180411.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/docker-proxy/docker-proxy-0.8.0_p20180411.ebuild')
-rw-r--r--app-emulation/docker-proxy/docker-proxy-0.8.0_p20180411.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/app-emulation/docker-proxy/docker-proxy-0.8.0_p20180411.ebuild b/app-emulation/docker-proxy/docker-proxy-0.8.0_p20180411.ebuild
deleted file mode 100644
index a6ad01507cac..000000000000
--- a/app-emulation/docker-proxy/docker-proxy-0.8.0_p20180411.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN="github.com/docker/libnetwork"
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-vcs
-else
- EGIT_COMMIT="c15b372ef22125880d378167dde44f4b134e1a77"
- SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="Docker container networking"
-HOMEPAGE="https://github.com/docker/libnetwork"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE=""
-
-S=${WORKDIR}/${P}/src/${EGO_PN}
-
-RDEPEND="!<app-emulation/docker-1.13.0_rc1"
-
-RESTRICT="test" # needs dockerd
-
-src_compile() {
- GOPATH="${WORKDIR}/${P}" go build -o "bin/docker-proxy" ./cmd/proxy || die
-}
-
-src_install() {
- dodoc ROADMAP.md README.md CHANGELOG.md
- dobin bin/docker-proxy
-}