summaryrefslogtreecommitdiff
path: root/app-emulation/coldfire/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/coldfire/files')
-rw-r--r--app-emulation/coldfire/files/coldfire-0.3.1-build.patch32
-rw-r--r--app-emulation/coldfire/files/coldfire-0.3.1-headers.patch16
2 files changed, 48 insertions, 0 deletions
diff --git a/app-emulation/coldfire/files/coldfire-0.3.1-build.patch b/app-emulation/coldfire/files/coldfire-0.3.1-build.patch
new file mode 100644
index 000000000000..2b54dd4a16f5
--- /dev/null
+++ b/app-emulation/coldfire/files/coldfire-0.3.1-build.patch
@@ -0,0 +1,32 @@
+respect env build settings
+
+--- a/Makefile.rules.in
++++ b/Makefile.rules.in
+@@ -1,9 +1,9 @@
+ CC = @CC@
+-CFLAGS = -Wall -fomit-frame-pointer @CFLAGS@ -I$(TOPSRCDIR)
++CFLAGS = -Wall @CPPFLAGS@ @CFLAGS@ -I$(TOPSRCDIR)
+ LIBS = @LIBS@
+ LD_R = ld -r
+ RM = rm -f
+-LDFLAGS =
++LDFLAGS = @LDFLAGS@
+
+
+ prefix = @prefix@
+
+fix parallel build problems ... objs need generated tracer, and coldfire
+needs subdir objs
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -22,7 +22,8 @@
+ #Force version to be made before subdirectories
+ subdirs-all: version.h
+
+-coldfire: $(OBJS) force
++$(OBJS): | subdirs-all
++coldfire: $(OBJS) force | subdirs-all
+ $(CC) $(LDFLAGS) $(OBJS) $(SUBDIR_OBJS) -o $@ $(LIBS)
+
+
diff --git a/app-emulation/coldfire/files/coldfire-0.3.1-headers.patch b/app-emulation/coldfire/files/coldfire-0.3.1-headers.patch
new file mode 100644
index 000000000000..706b1a2b12c9
--- /dev/null
+++ b/app-emulation/coldfire/files/coldfire-0.3.1-headers.patch
@@ -0,0 +1,16 @@
+make sure we have access to HAVE_* defines to include header files:
+
+run.c: In function ‘sigint’:
+run.c:51:2: warning: implicit declaration of function ‘readline’
+run.c:51:8: warning: cast to pointer from integer of different size
+
+--- a/run.c
++++ b/run.c
+@@ -7,6 +7,7 @@
+ /**********************************/
+
+
++#include "config.h"
+
+ #include <stdio.h>
+ #include <stdlib.h>