summaryrefslogtreecommitdiff
path: root/app-emulation/cloud-init/cloud-init-21.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/cloud-init/cloud-init-21.2.ebuild')
-rw-r--r--app-emulation/cloud-init/cloud-init-21.2.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/app-emulation/cloud-init/cloud-init-21.2.ebuild b/app-emulation/cloud-init/cloud-init-21.2.ebuild
index 55f12c07641e..f99af619353e 100644
--- a/app-emulation/cloud-init/cloud-init-21.2.ebuild
+++ b/app-emulation/cloud-init/cloud-init-21.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -32,14 +32,13 @@ CDEPEND="
dev-python/requests[${PYTHON_USEDEP}]
dev-python/jsonpatch[${PYTHON_USEDEP}]
dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
"
DEPEND="
${CDEPEND}
test? (
>=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
)
"
@@ -69,8 +68,8 @@ python_prepare_all() {
}
python_test() {
- # Do not use Makefile target as it does not setup environment correclty
- esetup.py nosetests -v --where cloudinit --where tests/unittests || die
+ # Do not use Makefile target as it does not setup environment correctly
+ esetup.py pytest -v cloudinit tests/unittests || die
}
python_install() {