summaryrefslogtreecommitdiff
path: root/app-emulation/cloud-init/cloud-init-18.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/cloud-init/cloud-init-18.5.ebuild')
-rw-r--r--app-emulation/cloud-init/cloud-init-18.5.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/app-emulation/cloud-init/cloud-init-18.5.ebuild b/app-emulation/cloud-init/cloud-init-18.5.ebuild
new file mode 100644
index 000000000000..c4ff15cbfd9b
--- /dev/null
+++ b/app-emulation/cloud-init/cloud-init-18.5.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cloud instance initialisation magic"
+HOMEPAGE="https://launchpad.net/cloud-init"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.2[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${CDEPEND}
+ >=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ net-analyzer/macchanger
+ sys-apps/iproute2
+ sys-fs/growpart
+ virtual/logger
+"
+
+PATCHES=(
+ # Fix Gentoo support
+ # https://code.launchpad.net/~gilles-dartiguelongue/cloud-init/+git/cloud-init/+merge/358777
+ "${FILESDIR}"/${PN}-18.4-fix-packages-module.patch
+ "${FILESDIR}"/${PN}-18.4-gentoo-support-upstream-templates.patch
+ "${FILESDIR}"/18.4-fix-filename-for-storing-locale.patch
+ "${FILESDIR}"/18.4-fix-update_package_sources-function.patch
+ "${FILESDIR}"/18.4-add-support-for-package_upgrade.patch
+ # From master
+ "${FILESDIR}"/${PV}-fix-invalid-string-format.patch
+)
+
+src_prepare() {
+ # Fix location of documentation installation
+ sed -i "s:USR + '/share/doc/cloud-init:USR + '/share/doc/${PF}:" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Do not use Makefile target as it does not setup environment correclty
+ esetup.py nosetests -v --where cloudinit --where tests/unittests || die
+}
+
+python_install() {
+ distutils-r1_python_install --init-system=sysvinit_openrc,systemd --distro gentoo
+}
+
+python_install_all() {
+ keepdir /etc/cloud
+
+ distutils-r1_python_install_all
+
+ # installs as non-executable
+ chmod +x "${D}"/etc/init.d/*
+}
+
+pkg_postinst() {
+ elog "cloud-init-local needs to be run in the boot runlevel because it"
+ elog "modifies services in the default runlevel. When a runlevel is started"
+ elog "it is cached, so modifications that happen to the current runlevel"
+ elog "while you are in it are not acted upon."
+}