summaryrefslogtreecommitdiff
path: root/app-emulation/aranym/aranym-1.1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/aranym/aranym-1.1.0-r1.ebuild')
-rw-r--r--app-emulation/aranym/aranym-1.1.0-r1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/app-emulation/aranym/aranym-1.1.0-r1.ebuild b/app-emulation/aranym/aranym-1.1.0-r1.ebuild
index 7f7bb559528d..f471b146140f 100644
--- a/app-emulation/aranym/aranym-1.1.0-r1.ebuild
+++ b/app-emulation/aranym/aranym-1.1.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools multibuild toolchain-funcs xdg
+inherit autotools flag-o-matic multibuild toolchain-funcs xdg
DESCRIPTION="Atari Running on Any Machine, VM running Atari ST/TT/Falcon OS and TOS/GEM apps"
HOMEPAGE="https://aranym.github.io"
@@ -54,6 +54,13 @@ src_prepare() {
}
src_configure() {
+ # configure probe fatally errors out since it tries to peek at LTO'ed code using grep
+ # https://bugs.gentoo.org/854510
+ # https://github.com/aranym/aranym/commit/52c56bba30ddea27a0a7179da89cac1c71228de6
+ #
+ # Fixed in git master. Try removing this on the next version bump.
+ filter-lto
+
tc-export_build_env
export CC_FOR_BUILD=$(tc-getBUILD_CC) CXX_FOR_BUILD=$(tc-getBUILD_CXX)