summaryrefslogtreecommitdiff
path: root/app-emacs
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/Manifest.gzbin69299 -> 69800 bytes
-rw-r--r--app-emacs/avy-embark-collect/Manifest4
-rw-r--r--app-emacs/avy-embark-collect/avy-embark-collect-0.21.ebuild32
-rw-r--r--app-emacs/avy-embark-collect/files/50avy-embark-collect-gentoo.el5
-rw-r--r--app-emacs/avy-embark-collect/metadata.xml13
-rw-r--r--app-emacs/compat/Manifest4
-rw-r--r--app-emacs/compat/compat-28.1.2.2.ebuild39
-rw-r--r--app-emacs/compat/compat-29.1.1.0.ebuild41
-rw-r--r--app-emacs/embark-consult/Manifest4
-rw-r--r--app-emacs/embark-consult/embark-consult-0.21.ebuild34
-rw-r--r--app-emacs/embark-consult/files/50embark-consult-gentoo.el1
-rw-r--r--app-emacs/embark-consult/metadata.xml13
-rw-r--r--app-emacs/embark/Manifest4
-rw-r--r--app-emacs/embark/embark-0.21.ebuild50
-rw-r--r--app-emacs/embark/files/50embark-gentoo.el2
-rw-r--r--app-emacs/embark/metadata.xml29
-rw-r--r--app-emacs/hl-todo/Manifest2
-rw-r--r--app-emacs/hl-todo/hl-todo-3.5.0.ebuild21
-rw-r--r--app-emacs/with-editor/Manifest4
-rw-r--r--app-emacs/with-editor/with-editor-2.8.3.ebuild22
-rw-r--r--app-emacs/with-editor/with-editor-3.3.0.ebuild29
21 files changed, 245 insertions, 108 deletions
diff --git a/app-emacs/Manifest.gz b/app-emacs/Manifest.gz
index bc60e4ec471e..ff9c6ddcda3f 100644
--- a/app-emacs/Manifest.gz
+++ b/app-emacs/Manifest.gz
Binary files differ
diff --git a/app-emacs/avy-embark-collect/Manifest b/app-emacs/avy-embark-collect/Manifest
new file mode 100644
index 000000000000..613cdbf331c1
--- /dev/null
+++ b/app-emacs/avy-embark-collect/Manifest
@@ -0,0 +1,4 @@
+AUX 50avy-embark-collect-gentoo.el 237 BLAKE2B 441ef0f4f19d48b3fdb340525632ac70bb2db7d46bf370d0cab51cb23ea56a21c18d92105f5784f30cc3764e6278579f1f17049f70216a902f5fcdc1afdbf0c4 SHA512 daea26c30a4675e9f8285dbbe8fead18a3245e84c2b8af1e37b3230e8786497b553b512a219444eb3ced1486e69cd26e86dfa1c3e45da182908993558afeb1db
+DIST embark-0.21.tar.gz 102588 BLAKE2B 5a578fe25018591e4dbbe4b683ce1e8669003fdedef3c6eecdf039fdcdc7b2d5accbd95faebe369b5dac90be8beb3be7c0507190f2cac4556a25a58709aef7c9 SHA512 ab450ab17d17fa4673615d6daef9495d4e567ab612f4a732f7536427b71dffecbb0456accc7adb28cedb3f1a73709fa2e51cb01f20902dc7748755ee1ea2442c
+EBUILD avy-embark-collect-0.21.ebuild 671 BLAKE2B dd2f9262a6dedcda67331c9ffb1ca5d12806d58d0bcadb841fb718fd4f082282edbefb8297fc850010408cd72b74d53d3cd47e5b6acee8a9f92ff407970da40e SHA512 8e0e8c8ebe5668e1fa5b078490265239822ad04450c7a7d11c4b470ddba5ab4b55b1423e4e2fbdb00e261c03ad0fa8f9866de3a19d74a4eaad922bd460350517
+MISC metadata.xml 419 BLAKE2B 9c67112b069db1f3656bbe3f14d52212578fa04e2fa5a39e963014637aee47c2d635a881794f03004a8b2a03471de6106a2ace40483ab1218423a94ebcb3af83 SHA512 547d90d7b62b0c7413d63ce242ebd5f4795b8f253d34d273d07b01bafc0e7f6996c55a1244227b0c2f62ab43f09e85bae581ae23585d21f4b32edf4aa173cb44
diff --git a/app-emacs/avy-embark-collect/avy-embark-collect-0.21.ebuild b/app-emacs/avy-embark-collect/avy-embark-collect-0.21.ebuild
new file mode 100644
index 000000000000..e8284f9f9e65
--- /dev/null
+++ b/app-emacs/avy-embark-collect/avy-embark-collect-0.21.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Use avy to jump to Embark Collect entries"
+HOMEPAGE="https://github.com/oantolin/embark/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/oantolin/embark.git"
+else
+ SRC_URI="https://github.com/oantolin/embark/archive/${PV}.tar.gz
+ -> embark-${PV}.tar.gz"
+ S="${WORKDIR}"/embark-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/avy
+ app-emacs/embark
+"
+BDEPEND="${RDEPEND}"
+
+ELISP_REMOVE="embark-consult.el embark-org.el embark.el"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/avy-embark-collect/files/50avy-embark-collect-gentoo.el b/app-emacs/avy-embark-collect/files/50avy-embark-collect-gentoo.el
new file mode 100644
index 000000000000..2b2686ce8069
--- /dev/null
+++ b/app-emacs/avy-embark-collect/files/50avy-embark-collect-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'avy-embark-collect-act "avy-embark-collect"
+ "Act on an Embark Collect candidate." t)
+(autoload 'avy-embark-collect-choose "avy-embark-collect"
+ "Choose an Embark Collect candidate." t)
diff --git a/app-emacs/avy-embark-collect/metadata.xml b/app-emacs/avy-embark-collect/metadata.xml
new file mode 100644
index 000000000000..fda35757dfa2
--- /dev/null
+++ b/app-emacs/avy-embark-collect/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/oantolin/embark/issues/</bugs-to>
+ <remote-id type="github">oantolin/embark</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/compat/Manifest b/app-emacs/compat/Manifest
index d7328083ce75..b38966967a98 100644
--- a/app-emacs/compat/Manifest
+++ b/app-emacs/compat/Manifest
@@ -1,10 +1,6 @@
-DIST compat-28.1.2.2.tar.gz 82479 BLAKE2B 154104a3d1cf953f712de357d21736d648289dbdaccb0f9ca5cbd44cb1e41b9b7b4b52394548658b47216f9205f28d2020b015d22b5d0c4df63c79794ddfc56e SHA512 65cafbf4d48815f447e412c4dbd87c5bd3357df5302660a5296582648926f8e3fe96b4b90b53674f18be8affe66af95c8db7e58d7a9dd63d2b57983962e5a53c
-DIST compat-29.1.1.0.tar.gz 94072 BLAKE2B 675f0bbf4411fb0d2c2e8f77bcd62dbe56da1f052bd6e390dade0c8075eaa480bb387280a29ae09396a2f4bf27746ae1065d38dd1b7882b9c8c0ec3a4eb776e5 SHA512 5c7b093314cd8f8d8cbab4f470a64d3f104d0e79d2881f2f2309700c6fe5f58a72a8a65379868edba33c0b6af1d43f1474e2fefc65c033f39981d29fca35259a
DIST compat-29.1.3.3.tar.gz 124534 BLAKE2B 680a404a4819ebbd95f94e2112f8fe3e08cd7c47204319f231c844bdc064153e7df0f653ac9614e6b6185f30b4e82b52aeb8317d74f5aa1c89252c4e6b6afa52 SHA512 fb69e2cff11daea1e3ba6a4755dccb81850c0e64b335978c5a30cb8236108ae369149d8f2e04746884281c01535aba6e6c5ac3c319497d511ecdd090bed83510
DIST compat-29.1.4.0.tar.gz 127066 BLAKE2B e070ee6f64ad8a0ead91e8ef5fb6bdad95e4f0a8d16f8e513fcd60a91714f0fe2d8d084a23be5d6421d7129c603186db5ec80af3f2725f288e15c846c571ea3f SHA512 027341e06ab9f3c6c109a1bfee513b7ac1b472ed9e7002f731be2fa944920ec6805a928f69c7369ab98c818cee87dd3dfe0c217a4595752701f9939171f9f4de
DIST compat-29.1.4.1.tar.gz 127809 BLAKE2B e558747786932f49643d0869b2a4e9c8a6cae1e2386c99a65584ef55a9ba54ed00f172b86372a23f6fe43a1565c16d5e3e08933e3636c6e36344a8bd7d38e347 SHA512 3ebb02a8c41e056e7414f9c978066e888e58cc53b420f63051a6c46d486be2735517f03dbc191d4fefa3a058c469c9d718c9cd5f951745c5c09d9603352b7572
-EBUILD compat-28.1.2.2.ebuild 930 BLAKE2B 631216acf4c5c967e10307e80fcb3ed2b2148cf74c26d350b98e0a52d18de6d487993736f1d91654967d920843922f722ebc7ca2373644549a5b1892acf0dc27 SHA512 60b4af0e99c62e75673cbc6c57e8709258173d4429bacb0c5b8f01c890cb70b2b7f5186770efa7eda6961452991a12a23d70df818345a5c497d28d44459a4614
-EBUILD compat-29.1.1.0.ebuild 980 BLAKE2B 38f57f53bc0442f9dedffcb71927feb4faad3bd372f64c6d26ff2c89ba6026e1c6649152cd12333328bcee853eed9dcfadbf31e24220a63b40a228647a74c7f3 SHA512 9ab988f939d1b5ff8e35e28a86ce8548ac1cd1c7abf7606814a5f2d06400ee1d1796a6e66bab8b4a012ee4b4d2dff7170d5f3f654b64a67f15e2d8a330b0e0d5
EBUILD compat-29.1.3.3.ebuild 980 BLAKE2B 38f57f53bc0442f9dedffcb71927feb4faad3bd372f64c6d26ff2c89ba6026e1c6649152cd12333328bcee853eed9dcfadbf31e24220a63b40a228647a74c7f3 SHA512 9ab988f939d1b5ff8e35e28a86ce8548ac1cd1c7abf7606814a5f2d06400ee1d1796a6e66bab8b4a012ee4b4d2dff7170d5f3f654b64a67f15e2d8a330b0e0d5
EBUILD compat-29.1.4.0.ebuild 981 BLAKE2B ecea895f3354c9534333f5a64b2652c0a29c10d7a004855b5a2277c6e586fb3939d9d7bb98b1056a41e12feb92dc72e78b62d7bcacd7db2c55dfbf16cffff9d0 SHA512 e7687b7eee936154c7fa1767fd14cfc3a497740c85bd39f52e264e87c7facceec5f9f511ef65198ccc2011960372efcfe3c26d479015b17f3aa41fdf64809992
EBUILD compat-29.1.4.1.ebuild 980 BLAKE2B 38f57f53bc0442f9dedffcb71927feb4faad3bd372f64c6d26ff2c89ba6026e1c6649152cd12333328bcee853eed9dcfadbf31e24220a63b40a228647a74c7f3 SHA512 9ab988f939d1b5ff8e35e28a86ce8548ac1cd1c7abf7606814a5f2d06400ee1d1796a6e66bab8b4a012ee4b4d2dff7170d5f3f654b64a67f15e2d8a330b0e0d5
diff --git a/app-emacs/compat/compat-28.1.2.2.ebuild b/app-emacs/compat/compat-28.1.2.2.ebuild
deleted file mode 100644
index 03355a84adab..000000000000
--- a/app-emacs/compat/compat-28.1.2.2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit elisp
-
-DESCRIPTION="Compatibility libraries for Emacs"
-HOMEPAGE="https://git.sr.ht/~pkal/compat/"
-SRC_URI="https://git.sr.ht/~pkal/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-
-BDEPEND="sys-apps/texinfo"
-
-ELISP_TEXINFO="${PN}.texi"
-
-src_compile() {
- emake compile ${PN}.info
-}
-
-src_test() {
- local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
- if [[ "${has_json}" != t ]] ; then
- local line
- while read line ; do
- ewarn "${line}"
- done <<-EOF
- Your current Emacs version does not support native JSON parsing,
- which is required for running tests of ${CATEGORY}/${PN}.
- Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
- to select that version.
- EOF
- else
- emake test
- fi
-}
diff --git a/app-emacs/compat/compat-29.1.1.0.ebuild b/app-emacs/compat/compat-29.1.1.0.ebuild
deleted file mode 100644
index b7d5a4710150..000000000000
--- a/app-emacs/compat/compat-29.1.1.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit elisp
-
-DESCRIPTION="Compatibility libraries for Emacs"
-HOMEPAGE="https://github.com/emacs-compat/compat/
- https://git.sr.ht/~pkal/compat/"
-SRC_URI="https://github.com/emacs-compat/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-
-BDEPEND="sys-apps/texinfo"
-
-ELISP_TEXINFO="${PN}.texi"
-
-src_compile() {
- emake compile ${PN}.info
-}
-
-src_test() {
- local has_json="$("${EMACS}" ${EMACSFLAGS} --eval "(princ (fboundp 'json-parse-string))")"
- if [[ "${has_json}" != t ]] ; then
- local line
- while read line ; do
- ewarn "${line}"
- done <<-EOF
- Your current Emacs version does not support native JSON parsing,
- which is required for running tests of ${CATEGORY}/${PN}.
- Emerge >=app-editors/emacs-27 with USE="json" and use "eselect emacs"
- to select that version.
- EOF
- else
- emake test
- fi
-}
diff --git a/app-emacs/embark-consult/Manifest b/app-emacs/embark-consult/Manifest
new file mode 100644
index 000000000000..33f98099059f
--- /dev/null
+++ b/app-emacs/embark-consult/Manifest
@@ -0,0 +1,4 @@
+AUX 50embark-consult-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST embark-0.21.tar.gz 102588 BLAKE2B 5a578fe25018591e4dbbe4b683ce1e8669003fdedef3c6eecdf039fdcdc7b2d5accbd95faebe369b5dac90be8beb3be7c0507190f2cac4556a25a58709aef7c9 SHA512 ab450ab17d17fa4673615d6daef9495d4e567ab612f4a732f7536427b71dffecbb0456accc7adb28cedb3f1a73709fa2e51cb01f20902dc7748755ee1ea2442c
+EBUILD embark-consult-0.21.ebuild 685 BLAKE2B c4ceb6c7b6b1fca3a59e89a4315f9f6a3739d8739d09805c131503ebb66cfe2cb60ec69d8d73edfeea309ac9d59b14dac2db1af01f11541274ebe78b926ade0b SHA512 780cdcc67955b79954b7aaa5f6fa8f2d882ef21207b2a3bd736eb35367070f6cc6b9202810893a784ced439abbfc60a86829a3f0bfa5804219db1bbd72c23cda
+MISC metadata.xml 419 BLAKE2B 9c67112b069db1f3656bbe3f14d52212578fa04e2fa5a39e963014637aee47c2d635a881794f03004a8b2a03471de6106a2ace40483ab1218423a94ebcb3af83 SHA512 547d90d7b62b0c7413d63ce242ebd5f4795b8f253d34d273d07b01bafc0e7f6996c55a1244227b0c2f62ab43f09e85bae581ae23585d21f4b32edf4aa173cb44
diff --git a/app-emacs/embark-consult/embark-consult-0.21.ebuild b/app-emacs/embark-consult/embark-consult-0.21.ebuild
new file mode 100644
index 000000000000..5938c7ef66e4
--- /dev/null
+++ b/app-emacs/embark-consult/embark-consult-0.21.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Consult integration for Embark"
+HOMEPAGE="https://github.com/oantolin/embark/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/oantolin/embark.git"
+else
+ SRC_URI="https://github.com/oantolin/embark/archive/${PV}.tar.gz
+ -> embark-${PV}.tar.gz"
+ S="${WORKDIR}"/embark-${PV}
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/consult
+ app-emacs/embark
+"
+BDEPEND="${RDEPEND}"
+
+ELISP_REMOVE="avy-embark-collect.el embark-org.el embark.el"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/embark-consult/files/50embark-consult-gentoo.el b/app-emacs/embark-consult/files/50embark-consult-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/embark-consult/files/50embark-consult-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/embark-consult/metadata.xml b/app-emacs/embark-consult/metadata.xml
new file mode 100644
index 000000000000..fda35757dfa2
--- /dev/null
+++ b/app-emacs/embark-consult/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/oantolin/embark/issues/</bugs-to>
+ <remote-id type="github">oantolin/embark</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/embark/Manifest b/app-emacs/embark/Manifest
new file mode 100644
index 000000000000..2053a39f0ae1
--- /dev/null
+++ b/app-emacs/embark/Manifest
@@ -0,0 +1,4 @@
+AUX 50embark-gentoo.el 84 BLAKE2B 04485be0f020ecfee67d3985e9a4160a68e3f099384fab1c005080bc25342efee20e300bb0e02461b9fbaaf7a54b4ece8cb61d38de8a9fb15f67bde1e94efc64 SHA512 007f925facdedd5584abce60d4ccd64636ba754f1474ab77583399d93e793cbc5e78fdfed39cc5705db7cfb80e4d79e5dff2f9f9e15ea0c87ca96592a2f2c1b8
+DIST embark-0.21.tar.gz 102588 BLAKE2B 5a578fe25018591e4dbbe4b683ce1e8669003fdedef3c6eecdf039fdcdc7b2d5accbd95faebe369b5dac90be8beb3be7c0507190f2cac4556a25a58709aef7c9 SHA512 ab450ab17d17fa4673615d6daef9495d4e567ab612f4a732f7536427b71dffecbb0456accc7adb28cedb3f1a73709fa2e51cb01f20902dc7748755ee1ea2442c
+EBUILD embark-0.21.ebuild 993 BLAKE2B aa96d6503dbc683e0a5966b49e5dde3a11d8fb2f68ee159192d43fd5ac223a955ee84ff7f6705be4cc5519026a216da12be86a840597ecac54976a74a9fdcde4 SHA512 560bb6ec4892fffcc17dfabbf6086360e16ec0df86caf5873a475ad58df8c91bbc558b6112e002be2aca4dec6207df80d14016349d3a3d4ec4041ad5f6d9fa01
+MISC metadata.xml 1526 BLAKE2B 02def263b6f7219e1764917ef493bb87105508b4bcb9b82364ca366bf73a3d8e9a0097525763659ed4758fdf87726e7be5e31acd701990d7a843a14a2cf211a0 SHA512 2f2e8c30b5e9bd0243577769ef9ce748075877f9c66513e18adafa9f3ce60bbbe3ce3f02704aa0354c01a18865532034e2acbafca9b515ccbddca824dd56f10b
diff --git a/app-emacs/embark/embark-0.21.ebuild b/app-emacs/embark/embark-0.21.ebuild
new file mode 100644
index 000000000000..38aa5db83044
--- /dev/null
+++ b/app-emacs/embark/embark-0.21.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp optfeature
+
+DESCRIPTION="Conveniently act on minibuffer completions inside GNU Emacs"
+HOMEPAGE="https://github.com/oantolin/embark/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/oantolin/${PN}.git"
+else
+ SRC_URI="https://github.com/oantolin/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+BDEPEND="${RDEPEND}"
+
+ELISP_REMOVE="avy-embark-collect.el embark-consult.el"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ doinfo ${PN}.texi
+}
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ optfeature "Avy integration for Embark" app-emacs/avy-embark-collect
+ optfeature "Consult integration for Embark" app-emacs/embark-consult
+}
diff --git a/app-emacs/embark/files/50embark-gentoo.el b/app-emacs/embark/files/50embark-gentoo.el
new file mode 100644
index 000000000000..933ac84875b9
--- /dev/null
+++ b/app-emacs/embark/files/50embark-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/embark-autoloads.el" nil t)
diff --git a/app-emacs/embark/metadata.xml b/app-emacs/embark/metadata.xml
new file mode 100644
index 000000000000..84bb06449c69
--- /dev/null
+++ b/app-emacs/embark/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Embark makes it easy to choose a command to run based on what is near
+ point, both during a minibuffer completion session (in a way familiar to
+ Helm or Counsel users) and in normal buffers. Bind the command embark-act
+ to a key and it acts like prefix-key for a keymap of actions (commands)
+ relevant to the target around point. With point on an URL in a buffer you
+ can open the URL in a browser or eww or download the file it points to. If
+ while switching buffers you spot an old one, you can kill it right there
+ and continue to select another. Embark comes preconfigured with over a
+ hundred actions for common types of targets such as files, buffers,
+ identifiers, s-expressions, sentences; and it is easy to add more actions
+ and more target types. Embark can also collect all the candidates in a
+ minibuffer to an occur-like buffer or export them to a buffer in a
+ major-mode specific to the type of candidates, such as dired for a set of
+ files, ibuffer for a set of buffers, or customize for a set of variables.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/oantolin/embark/issues/</bugs-to>
+ <remote-id type="github">oantolin/embark</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/hl-todo/Manifest b/app-emacs/hl-todo/Manifest
index e09ce2133120..2f64e24fb016 100644
--- a/app-emacs/hl-todo/Manifest
+++ b/app-emacs/hl-todo/Manifest
@@ -1,6 +1,8 @@
AUX 50hl-todo-gentoo.el 180 BLAKE2B 967e85d2d5738a45f21cc1bb038ac64366a0774d88fda4b542521f76ee204f88b950769eb120d2f537b0a48fdd239d17453263c19aefcbd1f2bf14d886cfcf88 SHA512 9b9b437d6ea14762afac357012a307599677f115bc1659d0c07cfd7db4eefa95b5a7104d03db101cdfefed05a9e510324a11066772e5642891c054675424e533
DIST hl-todo-3.4.1.tar.gz 5762 BLAKE2B fbc3e2d1c9e6492f55487e6ffc306588e1d27b758e97a538de77f56743f7717a3596bda072aa6cfb249c67e76f32263e07ca299e20fc635e585af32caef120ff SHA512 4cbde1f5c0697cb6906d355aff879f8a8b2ae1fbcb1a16016c1d6663ad520ba4bbc625d038975501b9deee827e52ac84cf0e8ca38ad538395ca1c9f7f82cba57
DIST hl-todo-3.4.2.tar.gz 5764 BLAKE2B 17a2569a0ff5423705d079d72c3b7d63d376b8247e80631c014b2874559ef95ea4695a110cc347c1fa35dfe1c2aebc7ff74af49f21e06560357e4f50f664b18a SHA512 a04e2b78a237b11152559a6d029168f24afba67cf2cf6ffeeb5d01a9e65312e30bd2910b41007c04335ce6e43e59163205d52e700dd499d89b19c87e5c3ca5bf
+DIST hl-todo-3.5.0.tar.gz 18295 BLAKE2B 1e67083cb2d772d13d0503a38d3a54ac0d9f1185e3474d13138f52762b7c46f0f378027d7ec7af27f4f47de3a3999e058e2364ea4ba25dd9f2d1d40dd18ae45d SHA512 260f9e556532ef96a58caf206f6ad7ad23110093f79ae1382c24d42a6edeb43f46b47074d1335dfc579d5fc430f6e58c1f812ca12d220538e71bfebe8da7c4d9
EBUILD hl-todo-3.4.1.ebuild 435 BLAKE2B a873cd74aaa793014d001443c015df5aaf83df6d8b9bb7996224b56c1b4f7ceccd9ff169b09e636872a39f50212e1641082f1a68d8b98be97e90efde4bc0e6e5 SHA512 89bbec14097aac184afdf9e6723c766b35039097e57df2455e886b1c677abf7e65f0de37766dc1d7e31d5bbe2a4d0c1b34dc786030d58cf22c89e0c282321c4a
EBUILD hl-todo-3.4.2.ebuild 436 BLAKE2B e7c8d138673f677ac4390aeb543a86f7f76342ffe5fcfe7537d1e59036e86f15e467e959b6417564ff24e4eeb51aa8c20279c751a6d9b3aef0bdbfdf3b40a980 SHA512 f926c95bfc4079f6649e691e691abb38eba149467d2513c519fd92d63dda82ed1662d11f69a216f4fa897838a17bd4eebc778f9be24aa20d0f92034596eda36f
+EBUILD hl-todo-3.5.0.ebuild 490 BLAKE2B 7ac87d0d2766081299de9e46585628e01b966eaac9868db32a25eb6e6bb5ee6ec865b0c344cf318f19211892701eca3bb3079a2a5abe8d14c92c9c828b03c8e0 SHA512 aa42800426b3e02db704fbe2b9b6037705c980cd421367dad29278616cda5a6356539837deac5e01c9b959a50ae13c36eaddff0b77f1759c6abca5ebbc2e4d8d
MISC metadata.xml 361 BLAKE2B d64dcf7b0a3a4d6fce92bc067d14e85ef5f4124414269aced39eacbce3fe1f2e96a5342886dbc8bcca39a0dfd6b2c2919ef404b106b408e3894f0c6e595971cb SHA512 3b795dfdb6a9c151218874c8a753474ba352e4d8d701de6f08340e9e11456752fcbeefcb715da11a1930ede0a6cb079bbe99c0d77e772413b5db86749d9a5581
diff --git a/app-emacs/hl-todo/hl-todo-3.5.0.ebuild b/app-emacs/hl-todo/hl-todo-3.5.0.ebuild
new file mode 100644
index 000000000000..34d06cf8e099
--- /dev/null
+++ b/app-emacs/hl-todo/hl-todo-3.5.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Highlight TODO and similar keywords in comments and strings"
+HOMEPAGE="https://github.com/tarsius/hl-todo/"
+SRC_URI="https://github.com/tarsius/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-emacs/compat-29.1.4.0"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/with-editor/Manifest b/app-emacs/with-editor/Manifest
index b431ebacaadc..b3a939224e69 100644
--- a/app-emacs/with-editor/Manifest
+++ b/app-emacs/with-editor/Manifest
@@ -1,10 +1,10 @@
AUX 50with-editor-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
-DIST with-editor-2.8.3.tar.gz 30648 BLAKE2B 8989f8506fb58c1f54efa4fcb72fa8ddd477c0c73d82672028bdb027f74093b62c44ab5a545cd9db2e0e3222bf461e605aebc805112c5ae8486c224b22806c26 SHA512 389aa084f7dfb7f7b59a37802441718e20ee70d88b9af9631b1fc547e4c3238d053bb2b3ef50a4e6332fc3befae183a49d55b3c7bd7719a149cf83001d23810c
DIST with-editor-3.0.5.tar.gz 31985 BLAKE2B 9d4bda1f4e7ae3ec5c9014b0e7a74bf703e9b80990b138ef6108275c9a117611d542e1dad03bb8537c7e8e3ffbbf3aac433bb4d3fe5eb07378f27dc1579a13ca SHA512 cc60a69ebfbb7d802a7bc64b56bf866111799b5a2a3140dd203bc3a4257756f558e81169b418bce2daa91e7aab7feb4d22115fcedf9efe46026745c4e3cf0268
DIST with-editor-3.1.1.tar.gz 32063 BLAKE2B 835781302cd5c686b0fffcb1c4e7513b76cfabe90b3d2c24becfa92722429622e46ea9953118be62e655f7d2db5401816e5bfd978bc90b7e66a8ec5cca767b32 SHA512 cb0c2273371a30a53b4d9a528f2a5a885f88fa05f71db1e3377aa8eb4fba7b35f9bc7c1911c56aa18823e3404bebaca7ea09d37f886061fb97eb00f6310a778e
DIST with-editor-3.2.0.tar.gz 32146 BLAKE2B c0f223e433b8bebef4e7e9bdee4b460d4e5bd5819340cccc3bedf39cec3633033a4fb39974d8b55caf244cc41f73007bc8ee4714e24bc726e55f1b2c5984dc69 SHA512 2857ca6e5aec2c1552088340b0bd819986aa797edbff05effce0a4db3f3b9b9df945b25424e4b43e4ed0392449fe8b75caedf3ba755d29ded6c781a51d57ef39
-EBUILD with-editor-2.8.3.ebuild 571 BLAKE2B 154541ee16d2e962425978ff031d25a2c10c3a2d650dfe1cdedfc583adb4ddff1fb42f7c3055886446d3f6d5e9482a5f28cee0698a8e0407537d3541e4a76111 SHA512 36d1af98c2589dbacc6c41ce596f10ae0b36819e0d0fb0a36780b42ea8455884a6a29ed44205a170353f0e0ca995fe451bcbd95c747bb07cdd329b21d0a7f2dd
+DIST with-editor-3.3.0.tar.gz 33250 BLAKE2B 6dab10a489c2592a32091e708c7f4c7e4c80794569e0fdcef14407cc83e067ace4a2efb29c97ecf40e1d0f5f2557f7ecc78992e1a65e10ed1c39e812431ff0bc SHA512 1e703f0793068f4080ab9af553a682ffb8897d95d0fc61668773c9ff380a0ba966e6f458f2428269c4c113c8ec296472b15a3459dad7f01549fc3387a080fda0
EBUILD with-editor-3.0.5.ebuild 578 BLAKE2B 2d0064a558e72bc87d5e2f1f8d6e8c5d8c4c13ddb71cf954b832afdca5c467f243589c18575451e5bc1c6f9936d715f5070adcf616814e98e0a33e08981da314 SHA512 7ecc385994016db7f68cb66d93a06f236a50856aab97230fc3f29ed9389f3990079d7f32d301565fe46214a6ad64bbd2517b21c1eaa1a8e16f2d91e2caa14221
EBUILD with-editor-3.1.1.ebuild 625 BLAKE2B d71122de6ee6018e97d0aa64dc79f3b0fcc544daf0cf8bffaed6b1d74a4fff8ac081b0a7ee63723e2c1822a4c85cd8f824e754774d2dec65148d48d6e4291b07 SHA512 83d58098ecddc469867fea899fce792361a9629302a44960579651c35d6b37694bfb6109b402e61ab692e82139637a25c84aa43153a3b07f5a2453ff1f03ca2d
EBUILD with-editor-3.2.0.ebuild 583 BLAKE2B fa3f47d8362a7033eb4a331f74bd6950ab4807e4e7667e497e5e62822d556fffa43e6ac786b5b1bac379e27f533e094887c48d26c59580a759532750b93eb05b SHA512 ec3003ae2687c11ea813e62ac4c00c3bc3c3966da2fbcc1694a803033722967fa7a0e939c6948b7033659a9f7c82cce35645c744ce68d7ef39a72103d550a4d6
+EBUILD with-editor-3.3.0.ebuild 673 BLAKE2B 3c1f7af2638fc7f51ec7883a9840688bc5eb523e8b61c3a65fef5a536d673593b08762a193f9005d571458d51419d350735a47091a5a39f28b58dc48dd3957df SHA512 14977f64564136aa81a5b319dfe57e86721a2df7844558c213b69eaf6cfd74e29cfb6b10af2154758ed1dae732eb39578ebfbf63271cd075b31717d25519fe6f
MISC metadata.xml 708 BLAKE2B f2e619818ede95a7a0b17cc7f36f903f4210ddc634d4f0edf27886e8fbc4d084daa5ef67c8167ef2f39930141c8dbe1e98c4e5992b7af35234499fa73e9de4cc SHA512 bf422e1a42e025426795319834a7fa75252e8f2c42da1d82098e2def918ed9c4f827978753c86cc4e41cde581bcdc8eb2c9781d75849a80ab6f94f945b4cdea3
diff --git a/app-emacs/with-editor/with-editor-2.8.3.ebuild b/app-emacs/with-editor/with-editor-2.8.3.ebuild
deleted file mode 100644
index 9b7fe8257830..000000000000
--- a/app-emacs/with-editor/with-editor-2.8.3.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit elisp
-
-DESCRIPTION="Use the Emacsclient as the \$EDITOR of child processes"
-HOMEPAGE="https://magit.vc/manual/with-editor"
-SRC_URI="https://github.com/magit/with-editor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
-
-SITEFILE="50${PN}-gentoo.el"
-ELISP_TEXINFO="*.texi"
-DOCS="README.md with-editor.org"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-DEPEND="${DEPEND} sys-apps/texinfo"
diff --git a/app-emacs/with-editor/with-editor-3.3.0.ebuild b/app-emacs/with-editor/with-editor-3.3.0.ebuild
new file mode 100644
index 000000000000..b8d4e5c7d0eb
--- /dev/null
+++ b/app-emacs/with-editor/with-editor-3.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Use the Emacsclient as the \$EDITOR of child processes"
+HOMEPAGE="https://magit.vc/manual/with-editor/
+ https://github.com/magit/with-editor/"
+SRC_URI="https://github.com/magit/with-editor/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}/lisp
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.1
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+DOCS=( ../README.org ../docs/${PN}.org )
+ELISP_TEXINFO="../docs/*.texi"
+SITEFILE="50${PN}-gentoo.el"