summaryrefslogtreecommitdiff
path: root/app-emacs
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/Manifest.gzbin34176 -> 34330 bytes
-rw-r--r--app-emacs/ghub/Manifest4
-rw-r--r--app-emacs/ghub/files/50ghub-gentoo.el3
-rw-r--r--app-emacs/ghub/ghub-2.0.0.ebuild21
-rw-r--r--app-emacs/ghub/metadata.xml29
-rw-r--r--app-emacs/with-editor/Manifest2
-rw-r--r--app-emacs/with-editor/with-editor-2.7.2.ebuild24
7 files changed, 83 insertions, 0 deletions
diff --git a/app-emacs/Manifest.gz b/app-emacs/Manifest.gz
index 94f64bdbf980..b04b45972542 100644
--- a/app-emacs/Manifest.gz
+++ b/app-emacs/Manifest.gz
Binary files differ
diff --git a/app-emacs/ghub/Manifest b/app-emacs/ghub/Manifest
new file mode 100644
index 000000000000..d836e4f0d9b3
--- /dev/null
+++ b/app-emacs/ghub/Manifest
@@ -0,0 +1,4 @@
+AUX 50ghub-gentoo.el 124 BLAKE2B 84170098bd01bb9f165eaf06f7cb21c56d2caaf964d2658520311757845d053072a7704fcb90cce2a2dfbd2385f357d2e7569061ebe0ca41b575efd752d29fd8 SHA512 596c7e75560f3734b57525bdfb42f3985fb49ab4d86637231361f6673d2431c0a6e73f91f58f003f9027f1143b9be3f4330ef2e1ff6c627ca6057256f4afbfca
+DIST ghub-2.0.0.tar.gz 48150 BLAKE2B b9142f33f92dc08a1d5f3f3467361866b41d0d2c943465e803987a41a7bbba1bc4c7e30c058e6e3899110a57d3e1d49545df01efbceb67711186e6411ebc9a58 SHA512 39e1ac1760e1a8532ee5d6fd29386ccc24d7f0278f6c900d565a709f86ac6acf01ae49a3462b54054d5b0040102db82ea048157a12663c46b0c45fe11f2e86d6
+EBUILD ghub-2.0.0.ebuild 490 BLAKE2B a96add2961b13f3dfe3da9ae81223a92cc81e822b314379d5217e6591f4dcf323d38208d8b278f6094273ab901c72ed96f5b920ff445a43599b030e303450ac0 SHA512 8f4c91c9485dcb48253231006114a7f8112e250e296b89d752caee2d85fe9587941f27a35178d658aec29b56eb71d891154d35f147c91b154288b5c7fcfd21fb
+MISC metadata.xml 1273 BLAKE2B d1248c9061827cfb587b5d4a54ba5aeaba5be8302bc1a2f11252b9fe0946d96ce292f01983a2e82b23008649ee44af169d570a3226887fc22852edb022d1608a SHA512 e8161b23fd2310b303508c80c6af7b428c77ce2eb594bc3bd52b71eab874350d8f8920fa7e348fe48b5f6302fe6242665724dfbe83e308ee5e9d0e8813f2dbf1
diff --git a/app-emacs/ghub/files/50ghub-gentoo.el b/app-emacs/ghub/files/50ghub-gentoo.el
new file mode 100644
index 000000000000..37d6696a3da1
--- /dev/null
+++ b/app-emacs/ghub/files/50ghub-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ghub-create-token "ghub" nil t)
+(autoload 'ghub-token-scopes "ghub" nil t)
diff --git a/app-emacs/ghub/ghub-2.0.0.ebuild b/app-emacs/ghub/ghub-2.0.0.ebuild
new file mode 100644
index 000000000000..4b577810fe60
--- /dev/null
+++ b/app-emacs/ghub/ghub-2.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="minuscule client library for the Github API"
+HOMEPAGE="https://magit.vc/manual/ghub"
+SRC_URI="https://github.com/magit/ghub/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="*.texi"
+DOCS="README.md"
+
+DEPEND="sys-apps/texinfo"
diff --git a/app-emacs/ghub/metadata.xml b/app-emacs/ghub/metadata.xml
new file mode 100644
index 000000000000..864702cccea5
--- /dev/null
+++ b/app-emacs/ghub/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+Ghub is a library that provides basic support for using the Github API
+from Emacs packages. It abstracts access to API resources using only
+a handful of functions that are not resource-specific.
+
+Ghub handles the creation, storage and use of access tokens using a
+setup wizard to make it easier for users to get started and to reduce
+the support burden imposed on package maintainers. It also comes with
+a comprehensive manual to address the cases when things don't just
+work as expected or in case you don't want to use the wizard.
+
+Ghub is intentionally limited to only provide these two essential
+features — basic request functions and guided setup — to avoid being
+too opinionated, which would hinder wide adoption. It is assumed that
+wide adoption would make life easier for users and maintainers alike,
+because then all packages that talk to the Github API could be
+configured the same way.
+</longdescription>
+<upstream>
+ <remote-id type="github">magit/ghub</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/with-editor/Manifest b/app-emacs/with-editor/Manifest
index b6c818a80b1b..f6b3c2818e07 100644
--- a/app-emacs/with-editor/Manifest
+++ b/app-emacs/with-editor/Manifest
@@ -2,7 +2,9 @@ AUX 50with-editor-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c6723772
DIST with-editor-2.5.10.tar.gz 28081 BLAKE2B 6e5b0478509022669ecada46a26dc74d4277b0221f8a1691690e60c56a4e24a1c47526c1b75e0b283d2651749069c2a9e0f277ab3805f42c98d2b3d271076b98 SHA512 797c7d905eeb4d7398dfba10e4a9b7e7729098a87e48dd75c14fd80f1dd9c5a9693033367a0a9788c4b6c6cc3aa8d2a6ef66ac8bddd24457a61c830887e66a59
DIST with-editor-2.5.8.tar.gz 27978 BLAKE2B a14db76077ec2254f79856c018ea4aed277997b3b35d0cdd1992ded2a5715a13dc2fd909041eafb69150e5bfbc7441e6d5b1549a20e0937aac2a59413cbcd01f SHA512 abd42a096e3318cc25576b240df1ed670de327afabe675d3df12780c392779f33b88e7a76d125f31cf37e3b22eda88391329c73d21ccc834e611893e759ea3e0
DIST with-editor-2.6.0.tar.gz 28124 BLAKE2B b727fc645cba8c85e0ff688ffbb7fd165feeb3e2fe5033475d9f9b333435cdbb4bc6e0c05f862021c1cd32dcdf1c813a0d3a8fb6221a757c7cf4ee4853d40272 SHA512 454af6222f54b6695aedb085b6f9a4e60d4ebd9dd6047d67cba13087d3966670aa63358dff45633f3492152f6a15c4c1e92efbaaa787867fef9edcf8b14f690c
+DIST with-editor-2.7.2.tar.gz 30121 BLAKE2B a610348a3a2b26059bf58b4b26fdb4e2edddcf70604db7c9d69d2050f4ed1ac745cf94638656339a915ac11a2abe0e8eee5fcb73c768747a8d14078931106332 SHA512 9d412928ce5234d3541d717b5b800312c82495f937088cb8308ff64ab92d2639ce078cdc8eb86d34b775a0e6567409249d58d94eb61183b82b5c19e2465905a7
EBUILD with-editor-2.5.10.ebuild 673 BLAKE2B 28e76191273b926fa2ff32e8a2649081a6f1fe825c3b544b7fdbf2d32d24a731db60d0233c84effd5cb488ed1b3d81bc1cee7cfda5535eaef4a52b8a10b8230f SHA512 de1f447911eab432ea9efc4c6a0dfd6e669bada47c797160592aa446ab26240a303bb887a605e282b5864e32e5f272006713d331bf644367fb0d2bae2fd88c5f
EBUILD with-editor-2.5.8.ebuild 672 BLAKE2B c4975e572dd90ba5f559c4f055b5761428fe1d1948e35328f26c0c33b4e1bc89078888ecf42fcd8d4bc35816279c377b22d2de0d9ae624a4a9fde5264524faf2 SHA512 b05314fa3013b5e0772dfce3755b97dafeb89549faf91768367b3581506b1c760edec1b9244aa6bd2845ffb62d6bcc054bf648f08fac3901bc28cba3ad88c9d5
EBUILD with-editor-2.6.0.ebuild 650 BLAKE2B f48f97a175c0c3530348926a6d213837d604224f6ddcf320f3cf8116b58e3671e807b28346c81130ab810fbbad8600229554d3a3df052737a30dbf9a868b889e SHA512 67de51aef7529f56ae3ad2ad1f5a013ed8946ad4c5370c7c7ad3675cd4b3ae6bff7c7f9fce870f463f9c756b8c127df8732007b678267ac67f1bb9ab568efc1a
+EBUILD with-editor-2.7.2.ebuild 650 BLAKE2B ee112b0810c2887cff5b32f8d908e554418047ae5e1a849e22f52c7c86cd4c91df74ace9abf52e0aabe1940fac4646a2329fc6575953ba3a5e6706f739c5880f SHA512 71ea9ef54e63f64f229e64119475368156b8858f1ab20d9af1755bb61ceae632075af6287ad42546f0b9eb441fdd8d1ede739d0fc9129d4c022892f947b39613
MISC metadata.xml 684 BLAKE2B 8deeae00b1046056120a352a462a4c93039275356dd5731edbb0975883f745b0a2b49f4109c89ef0535f97d29a095b803b8e91834ef95a67b479a0baaf518de8 SHA512 9c5cc636acec025b66df91e9a2500a9f5beeefeab3be42f2eb291d3a221151ca1748e80709b3bfac68a800c34cfd954339f1edbb2c9247ac85b4efe47c29621a
diff --git a/app-emacs/with-editor/with-editor-2.7.2.ebuild b/app-emacs/with-editor/with-editor-2.7.2.ebuild
new file mode 100644
index 000000000000..e967a12c4df8
--- /dev/null
+++ b/app-emacs/with-editor/with-editor-2.7.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Use the Emacsclient as the \$EDITOR of child processes"
+HOMEPAGE="https://magit.vc/manual/with-editor"
+SRC_URI="https://github.com/magit/with-editor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="*.texi"
+DOCS="README.md with-editor.org"
+
+DEPEND=""
+# Versions of magit before 2.5.0 bundled with-editor
+RDEPEND="!!<app-emacs/magit-2.5.0 ${DEPEND}"
+DEPEND="${DEPEND} sys-apps/texinfo"