summaryrefslogtreecommitdiff
path: root/app-emacs
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/Manifest.gzbin69797 -> 70446 bytes
-rw-r--r--app-emacs/edit-indirect/Manifest4
-rw-r--r--app-emacs/edit-indirect/edit-indirect-0.1.10.ebuild23
-rw-r--r--app-emacs/edit-indirect/files/50edit-indirect-gentoo.el3
-rw-r--r--app-emacs/edit-indirect/metadata.xml18
-rw-r--r--app-emacs/markdown-mode/Manifest2
-rw-r--r--app-emacs/markdown-mode/markdown-mode-2.5-r1.ebuild33
-rw-r--r--app-emacs/ssass-mode/Manifest4
-rw-r--r--app-emacs/ssass-mode/files/50ssass-mode-gentoo.el3
-rw-r--r--app-emacs/ssass-mode/metadata.xml19
-rw-r--r--app-emacs/ssass-mode/ssass-mode-0.2_p20200211.ebuild21
-rw-r--r--app-emacs/vue-html-mode/Manifest4
-rw-r--r--app-emacs/vue-html-mode/files/50vue-html-mode-gentoo.el3
-rw-r--r--app-emacs/vue-html-mode/metadata.xml21
-rw-r--r--app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild24
-rw-r--r--app-emacs/vue-mode/Manifest4
-rw-r--r--app-emacs/vue-mode/files/50vue-mode-gentoo.el4
-rw-r--r--app-emacs/vue-mode/metadata.xml14
-rw-r--r--app-emacs/vue-mode/vue-mode-0.4.ebuild40
19 files changed, 234 insertions, 10 deletions
diff --git a/app-emacs/Manifest.gz b/app-emacs/Manifest.gz
index 001a8a5d36f1..d131c2345b14 100644
--- a/app-emacs/Manifest.gz
+++ b/app-emacs/Manifest.gz
Binary files differ
diff --git a/app-emacs/edit-indirect/Manifest b/app-emacs/edit-indirect/Manifest
new file mode 100644
index 000000000000..9f78b86001ac
--- /dev/null
+++ b/app-emacs/edit-indirect/Manifest
@@ -0,0 +1,4 @@
+AUX 50edit-indirect-gentoo.el 140 BLAKE2B 944e2e6d5c58312838d64ff3849960f4a22589f4e682a2aac1c2f25de6acc6a1aa615b91e4de429d15ce4ac3cb6af6c77dc4a092841f38f48d9967bb71b429e4 SHA512 48298e0be07d56e30810134065e05460c4fb6ed18d9bddd752f20aa7eee174f17c3cdeb4c7ad2660a6b3931f39810e2f39aea0f79d0b15a279ffb1970e0916b5
+DIST edit-indirect-0.1.10.tar.gz 5270 BLAKE2B c54d6c47b67e257bde5cf4f075b3c28ea1711f2002d64389018eb088ee6a0084adf77d75a44661630b197326dc3d357694f7f43d3e2f87ebca3d5489fa169076 SHA512 5b1dc2b73bf61072e8687f0923a852cf9e49ae9817dd676d6a503361b86a906641716cb743b0cc9c30dddaaf772bdc30f63a87a58869e99139dab8a0f4c0a367
+EBUILD edit-indirect-0.1.10.ebuild 504 BLAKE2B cd6ee2fd9b4c145eac91049e3c1605c35559e825f969d5dc657ae3a7b41df02f8f6b24649998c74ccfb8a65e568a56a4cc8736f2a9300bd5ed7dab49948eab76 SHA512 2da6a2cdef69903a174490191d04bad70d810c55456cdbde90cd9f0d54c072258c6ca945ce6daaedd523f45b748b0a8f23d9d9d5762ce12456d3cbdccfacacb7
+MISC metadata.xml 647 BLAKE2B 2c100bcd2a2e4b0c89507902906ac8a03b656fe1b854bcc19c0f2868aca69a5365d9ebcf6ceeacd9fb5c7d78a35f081502b6e472a287864709fe7b008ee2c81c SHA512 ada96c5560eb10394b2945157a1fcc8c2c62e806f73265e29362213f3433641d91dd84bad72a3c8dc1bc72b12804286252b4cc3261fc253dd01c011a98ed7b79
diff --git a/app-emacs/edit-indirect/edit-indirect-0.1.10.ebuild b/app-emacs/edit-indirect/edit-indirect-0.1.10.ebuild
new file mode 100644
index 000000000000..ca35092609a1
--- /dev/null
+++ b/app-emacs/edit-indirect/edit-indirect-0.1.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Edit regions in separate Emacs buffers"
+HOMEPAGE="https://github.com/Fanael/edit-indirect/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Fanael/${PN}.git"
+else
+ SRC_URI="https://github.com/Fanael/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/edit-indirect/files/50edit-indirect-gentoo.el b/app-emacs/edit-indirect/files/50edit-indirect-gentoo.el
new file mode 100644
index 000000000000..3523a6574dd3
--- /dev/null
+++ b/app-emacs/edit-indirect/files/50edit-indirect-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'edit-indirect-region "edit-indirect"
+ "Edit the region BEG..END in a separate buffer." t)
diff --git a/app-emacs/edit-indirect/metadata.xml b/app-emacs/edit-indirect/metadata.xml
new file mode 100644
index 000000000000..06616bbdfe27
--- /dev/null
+++ b/app-emacs/edit-indirect/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Edit buffer regions in separate Emacs buffers, like org-edit-src-code (from
+ the Org package) but for arbitrary regions. Used by markdown-mode.
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/Fanael/edit-indirect/issues/</bugs-to>
+ <remote-id type="github">Fanael/edit-indirect</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/markdown-mode/Manifest b/app-emacs/markdown-mode/Manifest
index 0bca981d02c9..a8b085dd3b30 100644
--- a/app-emacs/markdown-mode/Manifest
+++ b/app-emacs/markdown-mode/Manifest
@@ -5,5 +5,5 @@ AUX markdown-mode-2.5-test.patch 1314 BLAKE2B f238a3bf1426845c83d7882fd745350166
DIST markdown-mode-2.4.tar.gz 211229 BLAKE2B 49a369d1b418634449cdac3103e1b107b5dd839edba6a3329539b80cf21bfb0f01aa436ec6deb256bfb5f03ef73b716943730adc4a87b52262dfccbd7923556e SHA512 8bf2acd7f402c036c57521340d26cea150935964f04f1343c2e17147d63226c815150be62c0b79a2ba48e55b3155d94f38caf1ec43c21d4f32dee6e73cc261a0
DIST markdown-mode-2.5.tar.gz 218329 BLAKE2B ea4f3e316383951c00e6a68e388db228567b7a06ac87bb268f28c026a8518e9a8516f27d137c79c24727bd71c785a6e9f1217d160e472abc7bdba2c5bda17f16 SHA512 6bb4d79a5a4c3d3891fc8be4d357fa6dccae9f3eeb8f6c04f840da6cfe6875090ebcc0b1a74961e2a4ac1a59389781fa37ef2420383019983705c2cc66db5b8e
EBUILD markdown-mode-2.4-r1.ebuild 694 BLAKE2B 51fad8b8a0aff638419404ec87303cd9d1d1feae82a15d4112e1133a61d747bb64c59302491010a8d20370471f6d69deb14d729f056cd81d4fce45a9ca330e05 SHA512 bf1669c8608c707f3e4ccce9ef8ab67469b012b2375919513df011e067b6aaec3fdf23c4a4b85ca27fdc4fb1a276474022f186aa8f1da1e16435c91d1c111206
-EBUILD markdown-mode-2.5-r1.ebuild 791 BLAKE2B 1843c02f9cd4a26c5c367bef11105c84ebcd69a55515573e24dc6d92854a448ea7afbff4e1480cce616f150fa393941708da489d85f5a363d028dcb7f1572880 SHA512 c7aa013684e4a161d6c9332bc77e5bffa41a4291c69885064c4533299773a34933fba3ad7ac9b5d29cbf92e6d96abb3d5bb60fd6b02cdd488c62a2079eaf2ea2
+EBUILD markdown-mode-2.5-r1.ebuild 938 BLAKE2B 14e002ddccd8e50ebd69a8ff0dd624ce9c4f3b624c483d844eb26318199085907f056c384e7990d37cfca27160cd2896f31ac3bc637dcca72905a6cb7bd17eb3 SHA512 c80a615a239651364f825648dd3158da7da9c5e572620ab5edeff0765b1d1a46d973bb1723681a52507ee44a014a7d759852dd789679e300d5d13f4290f4f651
MISC metadata.xml 477 BLAKE2B 4bb74aa04027605e0346a684271091a4d5f11929eab118dd7f5ed0f4292de563903cfae69242a459c8ba51f99135ffa09e021238478e9c6b38bee2e6cf52f882 SHA512 b3be952d7a6e47c5957ee6c7342eef5cfd8ad39d0d9dd0920797fccca36525b4f60dd621bcb4587e0ab63e64c067c7a8e97f498d84b3b8370595ec817fc07903
diff --git a/app-emacs/markdown-mode/markdown-mode-2.5-r1.ebuild b/app-emacs/markdown-mode/markdown-mode-2.5-r1.ebuild
index 82e1e0ff7742..e11c0d58dab2 100644
--- a/app-emacs/markdown-mode/markdown-mode-2.5-r1.ebuild
+++ b/app-emacs/markdown-mode/markdown-mode-2.5-r1.ebuild
@@ -3,11 +3,12 @@
EAPI=8
-inherit elisp
+inherit elisp optfeature
DESCRIPTION="Major mode for editing Markdown-formatted text files"
HOMEPAGE="https://jblevins.org/projects/markdown-mode/"
-SRC_URI="https://github.com/jrblevin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/jrblevin/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
@@ -15,19 +16,33 @@ KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="|| (
+RDEPEND="
+ || (
dev-python/markdown2
dev-python/markdown
virtual/pandoc
- )"
-BDEPEND="test? (
- virtual/pandoc
- || ( app-text/aspell[l10n_en] app-text/hunspell[l10n_en] )
-)"
+ )
+"
+BDEPEND="
+ test? (
+ virtual/pandoc
+ || (
+ app-text/aspell[l10n_en]
+ app-text/hunspell[l10n_en]
+ )
+ )
+"
PATCHES=(
"${FILESDIR}"/${PN}-2.5-markdown-command.patch
"${FILESDIR}"/${PN}-2.5-test.patch
)
+
+DOCS=( CHANGES.md CONTRIBUTING.md README.md )
SITEFILE="50${PN}-gentoo.el"
-DOCS="CHANGES.md CONTRIBUTING.md README.md"
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ optfeature "editing Markdown source code blocks" app-emacs/edit-indirect
+}
diff --git a/app-emacs/ssass-mode/Manifest b/app-emacs/ssass-mode/Manifest
new file mode 100644
index 000000000000..c420ccdcc44b
--- /dev/null
+++ b/app-emacs/ssass-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50ssass-mode-gentoo.el 100 BLAKE2B e246459d7e11d988c74b1b472d7524b64c9471019a902513f5fbd245ef075390a8342f547b2d015c7177fa3dcb3490359a1b86dc39cb53ba8d1477783634c457 SHA512 87df2e8a75b5ad5294afaf73497845132e675fe4194454394d631a714d903a9b828e5f86da15be362d6f595450f16111584d1df9dd8f04ad94049dae4a5c26ca
+DIST ssass-mode-0.2_p20200211.tar.gz 15364 BLAKE2B cdf2b48c3cbb861d89b29673ba3bbcfc2149850086227d58b8d6919f0d7d77914942fe8318e77e96f29e6fea5aeeba9e93c1fd3afbf6e669017e93e0c8de646b SHA512 5e3f2effc4ffb7534811f263cae970c2c7f6d96706cbd11f628f4267acca89550b2ced37f1968c76e32b55cd2dfea9976a11901817de8d5af965ffe4df436a4b
+EBUILD ssass-mode-0.2_p20200211.ebuild 541 BLAKE2B bdf49ed810585e7017397d8588558903f975bd72b48b1d1b3732e37c588dceccb7005018dd44673539edeeb4256d73f01af46e44297a84275000f59a0681f142 SHA512 038ed13fc2257eeb538a463a569103214d2842772a3024f55ce4aec1a2c7708c5c6cafede6f4b04c67e3c554c167271f9ca36456b61536460d920059d226eb75
+MISC metadata.xml 671 BLAKE2B 2c9cf822807ca607add60a068b45935d17ad8772a83bd5f2718373fe9a50ad0a6483ceb032d65f62217a9185abb9010003521de09e43b03921095333fe85e036 SHA512 dcc1accfffdee08fda62d1687c2a21a6ed0c2430f7ed23e13ead69d68927c94f3df30abaef24952099c5c75afd2e59d6dc8e9ca0e9170f5830bbac5c65dbd2ec
diff --git a/app-emacs/ssass-mode/files/50ssass-mode-gentoo.el b/app-emacs/ssass-mode/files/50ssass-mode-gentoo.el
new file mode 100644
index 000000000000..cb9781f2f567
--- /dev/null
+++ b/app-emacs/ssass-mode/files/50ssass-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ssass-mode "ssass-mode"
+ "Major mode for Sass" t)
diff --git a/app-emacs/ssass-mode/metadata.xml b/app-emacs/ssass-mode/metadata.xml
new file mode 100644
index 000000000000..2b6d61246ac1
--- /dev/null
+++ b/app-emacs/ssass-mode/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ This mode is a clean-room clone of Natalie Weizenbaum's sass-mode, with a
+ few compromises to support mmm-mode. If sass-mode doesn't break for you,
+ use that.
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/AdamNiederer/ssass-mode/issues/</bugs-to>
+ <remote-id type="github">AdamNiederer/ssass-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/ssass-mode/ssass-mode-0.2_p20200211.ebuild b/app-emacs/ssass-mode/ssass-mode-0.2_p20200211.ebuild
new file mode 100644
index 000000000000..5bf8db2af8ae
--- /dev/null
+++ b/app-emacs/ssass-mode/ssass-mode-0.2_p20200211.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+[[ ${PV} == *_p20200211 ]] && COMMIT=96f557887ad97a0066a60c54f92b7234b8407016
+
+inherit elisp
+
+DESCRIPTION="Write Sass in Emacs without a Turing Machine"
+HOMEPAGE="https://github.com/AdamNiederer/ssass-mode/"
+SRC_URI="https://github.com/AdamNiedererw/${PN}/archive/${COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${COMMIT}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/vue-html-mode/Manifest b/app-emacs/vue-html-mode/Manifest
new file mode 100644
index 000000000000..8f93db77718d
--- /dev/null
+++ b/app-emacs/vue-html-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50vue-html-mode-gentoo.el 119 BLAKE2B d90f13954dc7478c279f74985906b30f49ed6cb2fd99b77c5ce06fef9fb01fd860f89d6e176186a57d2e109c7db8e94ce520a2085f5b09b31d7669c7891904b4 SHA512 098e37fe09325f9bf8dd06919e44a06c212efef58b24bfdaba20f3bebb7734a4ecac1fe18dd48615ccb6ece0852f221a1cab364a54ee2ef1f8fa3633b9158c1e
+DIST vue-html-mode-0.2.tar.gz 17744 BLAKE2B 460a6f67c00d3b2e7372209766c2dc1729ff5ac1ef9ca8951ac0677937130d5b54cb3c22702d304efe70aa57117af067b6a103197738efa1f5ee77f285e01c18 SHA512 8fe8f19059d64355af9ae2ac95aba2ac71b50153f5a3270fd75b70433bce3fa628a04abe03dea84671dabe5c604b7b0ae298b33214038ef9fa5dff8aaf418a56
+EBUILD vue-html-mode-0.2.ebuild 549 BLAKE2B 130ee0da8d350810da96f42ce87be79cd6919e53e15b9cba2431ba677a6fed4ac93f1b9a5f9f09eeb9ae5c6025ce3359399cdb141c02a066dd866db82daa0e98 SHA512 2ccacc7ea3d578e4d51532ad3f948773de1c62be5cbedbc92bb75be1b5b4258ed12e20f697da52628564f15436cbdf0f719794915a1ab7a886ee719ae679280c
+MISC metadata.xml 873 BLAKE2B c14c69cecd4dd6c84fa9e0a2c8fd70fb9a72faa26be5c027323dadf0e263f67709f7d27d5b6a6607dab9cc1ca976257235ca80edebb269467a017d8097b34909 SHA512 477bcafaa2067146959fd7fe58aaf64ebe7f08ded64a98a6f2c504bf36e66fd17c02578287d0f25c50930551ab1e7644ca1bd84000ab3460c03207244b8f1d8f
diff --git a/app-emacs/vue-html-mode/files/50vue-html-mode-gentoo.el b/app-emacs/vue-html-mode/files/50vue-html-mode-gentoo.el
new file mode 100644
index 000000000000..0bc482778051
--- /dev/null
+++ b/app-emacs/vue-html-mode/files/50vue-html-mode-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'vue-html-mode "vue-html-mode"
+ "Major mode for Vue.js templates." t)
diff --git a/app-emacs/vue-html-mode/metadata.xml b/app-emacs/vue-html-mode/metadata.xml
new file mode 100644
index 000000000000..d51da01a3b2d
--- /dev/null
+++ b/app-emacs/vue-html-mode/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ The main features of this mode are syntax highlighting (enabled with
+ font-lock-mode or global-font-lock-mode), and html-mode integration. Vue
+ component files are best edited with the excellent vue-mode, which the
+ author of this package also contributes to. This mode is included in
+ vue-mode, and is the default mode for editing template blocks.
+ </longdescription>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/AdamNiederer/vue-html-mode/issues/</bugs-to>
+ <remote-id type="github">AdamNiederer/vue-html-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild b/app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild
new file mode 100644
index 000000000000..420647bc0094
--- /dev/null
+++ b/app-emacs/vue-html-mode/vue-html-mode-0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Major Emacs mode for editing Vue.js templates"
+HOMEPAGE="https://github.com/AdamNiederer/vue-html-mode/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/AdamNiederer/${PN}.git"
+else
+ SRC_URI="https://github.com/AdamNiederer/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/vue-mode/Manifest b/app-emacs/vue-mode/Manifest
new file mode 100644
index 000000000000..7bed9ee28ec7
--- /dev/null
+++ b/app-emacs/vue-mode/Manifest
@@ -0,0 +1,4 @@
+AUX 50vue-mode-gentoo.el 180 BLAKE2B 9ca9863d184ef744515c48be2f9980b204c34e0e31b34c1b54df14ee5b9d4f3aadaee8488174cbc1f02dc81828f7b8e80f19e4bb02db1a4975f5d53559011e21 SHA512 2347049804865b784c49be20ea3b5a1abb72310826fd4e388a6ead3aac35afd1968e9144519815193b7c0934ed3721ec893597bed2de4c1b0dea0a93faf3e350
+DIST vue-mode-0.4.tar.gz 12023 BLAKE2B bb20f56544b8bd67ece2753febb88c854b1ba243aeb7bc394cfece877a521c16fcb9284c4fcb2099b1cf65a0ae63252502668cf69f78043eebb68e295c620505 SHA512 2612b9928a6a2b209b82326e5600287072a284a7d4c431029d775be517893cef6825c0bb011689ab9d7258631ea2007d1613343b6bf8bf0676847a2dcfd039c6
+EBUILD vue-mode-0.4.ebuild 765 BLAKE2B 587638269abe52f955acde8c193e6b89dacd6cc38216ea5f93d2e4fe71a70cb4a85520a4dd938f8cec18c4dc5d3db67cc021f65adac8bfc462d8169a2b99fc6d SHA512 4574f11c797cda28776e3d26fc2948ca4a6e478bd45dc04ecfed3918e66344e3e3f6c1469042f52dafd21de04d1dc91378252f104496ad32079e0f47d18b850d
+MISC metadata.xml 457 BLAKE2B 3e51a512d37230e50320a474faa19bbf3f5c06dd512fab1c328feef02e5c5831c5ce26b9663f8f4b518136ebefb790ce64fbf2195b49fec1c8774d81b86b9071 SHA512 b65abaf483508f551c00c00273f5ec06397a46687a90f678a3541bacfc8948df5df18ec63a2b45d69a861dc8a19bd6e4487a507bfd0cb74908b673892bec389b
diff --git a/app-emacs/vue-mode/files/50vue-mode-gentoo.el b/app-emacs/vue-mode/files/50vue-mode-gentoo.el
new file mode 100644
index 000000000000..15091349f763
--- /dev/null
+++ b/app-emacs/vue-mode/files/50vue-mode-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'vue-mode "vue-mode"
+ "Major mode for vue component based on mmm-mode" t)
+(add-to-list 'auto-mode-alist '("\\.vue\\'" . vue-mode))
diff --git a/app-emacs/vue-mode/metadata.xml b/app-emacs/vue-mode/metadata.xml
new file mode 100644
index 000000000000..aa019a01b771
--- /dev/null
+++ b/app-emacs/vue-mode/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <stabilize-allarches />
+ <upstream>
+ <bugs-to>https://github.com/AdamNiederer/vue-mode/issues/</bugs-to>
+ <remote-id type="github">AdamNiederer/vue-mode</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-emacs/vue-mode/vue-mode-0.4.ebuild b/app-emacs/vue-mode/vue-mode-0.4.ebuild
new file mode 100644
index 000000000000..9cad8b7de4e8
--- /dev/null
+++ b/app-emacs/vue-mode/vue-mode-0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Major Emacs mode for vue component based on mmm-mode"
+HOMEPAGE="https://github.com/AdamNiederer/vue-mode/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/AdamNiederer/${PN}.git"
+else
+ SRC_URI="https://github.com/AdamNiederer/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/edit-indirect
+ app-emacs/mmm-mode
+ app-emacs/ssass-mode
+ app-emacs/vue-html-mode
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/undercover
+ app-emacs/s
+ )
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert-runner test