summaryrefslogtreecommitdiff
path: root/app-emacs/with-editor/with-editor-3.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/with-editor/with-editor-3.1.1.ebuild')
-rw-r--r--app-emacs/with-editor/with-editor-3.1.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/with-editor/with-editor-3.1.1.ebuild b/app-emacs/with-editor/with-editor-3.1.1.ebuild
new file mode 100644
index 000000000000..c65cb0d82eb1
--- /dev/null
+++ b/app-emacs/with-editor/with-editor-3.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Use the Emacsclient as the \$EDITOR of child processes"
+HOMEPAGE="https://magit.vc/manual/with-editor"
+SRC_URI="https://github.com/magit/with-editor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${P}/lisp"
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="../docs/*.texi"
+DOCS="../README.md ../docs/with-editor.org"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} sys-apps/texinfo"