summaryrefslogtreecommitdiff
path: root/app-emacs/webpaste/webpaste-3.2.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/webpaste/webpaste-3.2.2-r1.ebuild')
-rw-r--r--app-emacs/webpaste/webpaste-3.2.2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/webpaste/webpaste-3.2.2-r1.ebuild b/app-emacs/webpaste/webpaste-3.2.2-r1.ebuild
new file mode 100644
index 000000000000..27a00d8097bc
--- /dev/null
+++ b/app-emacs/webpaste/webpaste-3.2.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Paste parts of buffers to several pastebin-like services from Emacs"
+HOMEPAGE="https://github.com/etu/webpaste.el/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/etu/${PN}.el.git"
+else
+ SRC_URI="https://github.com/etu/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}.el-${PV}"
+
+ KEYWORDS="amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ app-emacs/request
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/undercover
+ )
+"
+
+# Remove failing tests
+ELISP_REMOVE="
+ tests/integration/test-webpaste-providers.el
+ tests/unit/test-webpaste-provider-creation.el
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests buttercup tests