summaryrefslogtreecommitdiff
path: root/app-emacs/wanderlust/wanderlust-2.15.9_p20230624.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/wanderlust/wanderlust-2.15.9_p20230624.ebuild')
-rw-r--r--app-emacs/wanderlust/wanderlust-2.15.9_p20230624.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/app-emacs/wanderlust/wanderlust-2.15.9_p20230624.ebuild b/app-emacs/wanderlust/wanderlust-2.15.9_p20230624.ebuild
index 46ac05de3bae..660576a2538f 100644
--- a/app-emacs/wanderlust/wanderlust-2.15.9_p20230624.ebuild
+++ b/app-emacs/wanderlust/wanderlust-2.15.9_p20230624.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -22,6 +22,11 @@ RDEPEND=">=app-emacs/apel-10.8
bbdb? ( app-emacs/bbdb )"
DEPEND="${RDEPEND}"
+ELISP_REMOVE="
+ tests/test-dist.el
+ tests/test-rfc2368.el
+"
+
SITEFILE="50${PN}-gentoo.el"
src_configure() {
@@ -35,6 +40,10 @@ src_compile() {
emake all info PACKAGE_LISPDIR="NONE"
}
+src_test() {
+ emake test PACKAGE_LISPDIR="NONE"
+}
+
src_install() {
emake \
LISPDIR="${ED}${SITELISP}" \