summaryrefslogtreecommitdiff
path: root/app-emacs/vertico
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/vertico')
-rw-r--r--app-emacs/vertico/Manifest4
-rw-r--r--app-emacs/vertico/files/50vertico-gentoo.el2
-rw-r--r--app-emacs/vertico/metadata.xml12
-rw-r--r--app-emacs/vertico/vertico-0.20.ebuild27
4 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/vertico/Manifest b/app-emacs/vertico/Manifest
new file mode 100644
index 000000000000..6876c171ac30
--- /dev/null
+++ b/app-emacs/vertico/Manifest
@@ -0,0 +1,4 @@
+AUX 50vertico-gentoo.el 82 BLAKE2B 89e0376cb0361d71ad40318455820607ac23fe004dbc80c77c9943a94426c47ee409956e0770a1f8c3157b50f0f105275337b0c94b597755dac59baeac29eecc SHA512 ea5c77218cab48e770cf56d1732b8101bbe453fe5e98fccf92c6adf53fd3aa8c1c3fd4d33e02fcb02d7ef44c56661e9c593588ffefec0852ecd43c00da30a5dd
+DIST vertico-0.20.tar.gz 40899 BLAKE2B 73f42eefc43095c58c38570fac2fc915f7a1d7095f2b1864834eb57d658114ee3a4a98fb834c64793810505e171602801d8a492eecc7349137833442fc02b715 SHA512 0e683a572fec4ba223f03672461b4888667e35202dd1b2efc139127d3327d6d7a6d7eab96549239e6dad6e86054854b49a3be553ce482fd2e683bdb029e3a9c0
+EBUILD vertico-0.20.ebuild 520 BLAKE2B edbaf5bc705dfd6c08b2ba2a253ed15c0e7293de324d27bc9745a85417dc49fe4a483a0e6f89d15b7eb4b624f90e9b56dc8adbef7db4975320cac08f9a3baf6b SHA512 4e5554b24d22b0efdc3122b35c9d5717e3a44ece867eb99cd257b270b14b10c277de23a3f8d9463c2e11f9dedb2c02c030f3274ee522310188afc97a9951fecc
+MISC metadata.xml 359 BLAKE2B d5d9e7f1c0ec1dc75d7fde73aa75f364f15740857e6a2bf39b3374424c3fcff4e79ceda481141598fee17c694b4c3538059f5bf95186aad6d535eacabcdb3341 SHA512 93e435f0f7bdb4d26a48525109688b964049a0b61d4b5633bd61dfd14ab68a5bd7e367d0cb7e45f5f1a57d73b8b63a9b2f8b0da9ac289bd4242da3b6f434b987
diff --git a/app-emacs/vertico/files/50vertico-gentoo.el b/app-emacs/vertico/files/50vertico-gentoo.el
new file mode 100644
index 000000000000..a7d1b3665969
--- /dev/null
+++ b/app-emacs/vertico/files/50vertico-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/vertico-autoloads" nil t)
diff --git a/app-emacs/vertico/metadata.xml b/app-emacs/vertico/metadata.xml
new file mode 100644
index 000000000000..f5159c9e8ada
--- /dev/null
+++ b/app-emacs/vertico/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">minad/vertico</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/vertico/vertico-0.20.ebuild b/app-emacs/vertico/vertico-0.20.ebuild
new file mode 100644
index 000000000000..d2415e174e28
--- /dev/null
+++ b/app-emacs/vertico/vertico-0.20.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Vertical interactive completion"
+HOMEPAGE="https://github.com/minad/vertico"
+SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+ mv extensions/*.el . || die
+}
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}