summaryrefslogtreecommitdiff
path: root/app-emacs/undo-tree/undo-tree-0.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/undo-tree/undo-tree-0.8.1.ebuild')
-rw-r--r--app-emacs/undo-tree/undo-tree-0.8.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-emacs/undo-tree/undo-tree-0.8.1.ebuild b/app-emacs/undo-tree/undo-tree-0.8.1.ebuild
new file mode 100644
index 000000000000..dfeb0ba97404
--- /dev/null
+++ b/app-emacs/undo-tree/undo-tree-0.8.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=24
+
+inherit readme.gentoo-r1 elisp
+
+DESCRIPTION="Undo trees and visualization"
+HOMEPAGE="http://www.dr-qubit.org/undo-tree.html"
+SRC_URI="https://gitlab.com/tsc25/${PN}/-/archive/release/${PV}/${PN}-release-${PV}.tar.gz"
+S="${WORKDIR}"/${PN}-release-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+SITEFILE="50${PN}-gentoo.el"
+DOC_CONTENTS="To enable undo trees globally, place '(global-undo-tree-mode)'
+ in your .emacs file."
+
+DEPEND="app-emacs/queue"
+RDEPEND="${DEPEND}"