summaryrefslogtreecommitdiff
path: root/app-emacs/transient/transient-0.5.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/transient/transient-0.5.2.ebuild')
-rw-r--r--app-emacs/transient/transient-0.5.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/transient/transient-0.5.2.ebuild b/app-emacs/transient/transient-0.5.2.ebuild
new file mode 100644
index 000000000000..ab8accfcb76d
--- /dev/null
+++ b/app-emacs/transient/transient-0.5.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Transient commands abstraction for GNU Emacs"
+HOMEPAGE="https://magit.vc/manual/transient/
+ https://github.com/magit/transient/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG README.org docs/${PN}.org )
+ELISP_TEXINFO="docs/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.1
+"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ default
+}