summaryrefslogtreecommitdiff
path: root/app-emacs/rust-mode/rust-mode-1.0.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/rust-mode/rust-mode-1.0.5.ebuild')
-rw-r--r--app-emacs/rust-mode/rust-mode-1.0.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/rust-mode/rust-mode-1.0.5.ebuild b/app-emacs/rust-mode/rust-mode-1.0.5.ebuild
new file mode 100644
index 000000000000..bd23bef33b88
--- /dev/null
+++ b/app-emacs/rust-mode/rust-mode-1.0.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A major emacs mode for editing Rust source code"
+HOMEPAGE="https://github.com/rust-lang/rust-mode"
+SRC_URI="https://github.com/rust-lang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -l rust-mode.el -l rust-mode-tests.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}