summaryrefslogtreecommitdiff
path: root/app-emacs/pymacs
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/pymacs')
-rw-r--r--app-emacs/pymacs/Manifest3
-rw-r--r--app-emacs/pymacs/files/pymacs-0.26-setup.patch11
-rw-r--r--app-emacs/pymacs/pymacs-0.26-r5.ebuild (renamed from app-emacs/pymacs/pymacs-0.26-r4.ebuild)25
3 files changed, 26 insertions, 13 deletions
diff --git a/app-emacs/pymacs/Manifest b/app-emacs/pymacs/Manifest
index fb390e3023fd..87f01cd5ae32 100644
--- a/app-emacs/pymacs/Manifest
+++ b/app-emacs/pymacs/Manifest
@@ -1,4 +1,5 @@
AUX 50pymacs-gentoo.el 183 BLAKE2B f1a4b874bb339b653c4fb6fb186bd7e531151c34d1df58be6963288d4443438fcae0f82c92a1667b4e7cb739bc2f7c6fd8d8d5f6d4e91413ee5bec47a609cc2e SHA512 f59fed86f859b796c901088b38fb570a5e5527d774a15456105ce75598c31fd20d0afaa62ad9cbf12063810fa592dbbd7c33aaece5871b36b488e5af6de0fac2
+AUX pymacs-0.26-setup.patch 260 BLAKE2B 7582ebfd6aa3cdf530b782b307f6fa4a6d4f08bedcc6019ff43873ff8450824f4ddba1528777bfbbfe7bd774b688afe15710b10ca5c3786280209c1ee5c3c168 SHA512 835d11ba138f526748d64234fde8c9216d59b2b9c3bb9f5169b0a3c77ed633495d8095021d0fe5928eb3f9352c91ec3e0065ff122ec8ec21104ed885bd7809e5
DIST pymacs-0.26.tar.gz 123373 BLAKE2B 0c467435d18ebcbe7b263e90096363e201dd84ba770fa702beefac4318a713954c316f335ee005ea88370be29c3710a7df04fb05b6efd3816beedbb88e38126d SHA512 ae245de130f435d947788c5ac11d8ce6534df80f70a4e35fff903f22d2b79b0f66925059ebaf53bde45cd6660ac0a8a224490f4f9e256a84e3a08f6468c14dd2
-EBUILD pymacs-0.26-r4.ebuild 1220 BLAKE2B 74f1698f08ba66734932b478caca0f79f26463c1092f7157b708f91d719f9eaf2f31b703e09595cfab636a444ed9366977bf14b7319468339c7fde78e15afb06 SHA512 3b9303242539cfe066e9711738e4f195bc3b8852672dab7221bf4d8080830a2786987c926b018af83db3027d791120da6977a7fb3411f7fa9ae9919c4ddb4747
+EBUILD pymacs-0.26-r5.ebuild 1333 BLAKE2B c2a467a9f428fc8bdcc7ca249f929446a6c90685c5f84904ff245c1d0aaa29e23622427b2eda87cd172efcd3989fd22f23a59f6f8373a2239b698806427d8769 SHA512 8f57a922c2fb5ef98edc10aa26e7e7913749c6fea27f1231d0b84ccabf443d1f1d91ecaebdbc9a1550ba0cf5c09f95ae127659edff85bcd196e8262cd939c0af
MISC metadata.xml 436 BLAKE2B 4239aac38b2303531a3792704946f0039b484aaa1561a336ffb4955aecd3a6881051a8de0a8d9c2b2c628e2ef45a448519fa70efd2698a64a4f07d38adb04b07 SHA512 4be8dd1573dee1c631449a512d6da4ff02f9917c4132477ad5383432521087a3f5468698d1a0b9906fc76367b75bca9d25e6da3ce0142be5fb4e4b7e225651d9
diff --git a/app-emacs/pymacs/files/pymacs-0.26-setup.patch b/app-emacs/pymacs/files/pymacs-0.26-setup.patch
new file mode 100644
index 000000000000..5d774b7d4dfb
--- /dev/null
+++ b/app-emacs/pymacs/files/pymacs-0.26-setup.patch
@@ -0,0 +1,11 @@
+--- a/setup.py
++++ b/setup.py
+@@ -70,7 +70,7 @@ def cfg_to_args(path='setup.cfg'):
+ config = RawConfigParser()
+ f = codecs.open(path, encoding='utf-8')
+ try:
+- config.readfp(f)
++ config.read_file(f)
+ finally:
+ f.close()
+
diff --git a/app-emacs/pymacs/pymacs-0.26-r4.ebuild b/app-emacs/pymacs/pymacs-0.26-r5.ebuild
index bebfd8782b42..5d51948e9238 100644
--- a/app-emacs/pymacs/pymacs-0.26-r4.ebuild
+++ b/app-emacs/pymacs/pymacs-0.26-r5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit elisp distutils-r1
@@ -12,13 +12,15 @@ DESCRIPTION="A tool that allows both-side communication between Python and Emacs
HOMEPAGE="https://www.emacswiki.org/emacs/PyMacs
https://github.com/dgentry/Pymacs/"
-if [[ ${PV} == *9999* ]] ; then
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
+
EGIT_REPO_URI="https://github.com/dgentry/${PN^}.git"
else
SRC_URI="https://github.com/dgentry/${PN^}/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
- S="${WORKDIR}"/${P^}
+ S="${WORKDIR}/${P^}"
+
KEYWORDS="amd64 arm ~hppa ~ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
fi
@@ -33,16 +35,13 @@ BDEPEND="
)
"
-DOCS=( ${PN}.rst )
+PATCHES=( "${FILESDIR}/${PN}-0.26-setup.patch" )
+
+DOCS=( "${PN}.rst" )
SITEFILE="50${PN}-gentoo.el"
python_configure() {
- emake PYSETUP=: PYTHON=${EPYTHON} prepare
-}
-
-src_prepare() {
- distutils-r1_src_prepare
- elisp_src_prepare
+ emake PYSETUP=":" PYTHON="${EPYTHON}" prepare
}
src_compile() {
@@ -50,7 +49,9 @@ src_compile() {
elisp_src_compile
if use doc; then
- VARTEXFONTS="${T}"/fonts emake RST2LATEX=rst2latex.py ${PN}.pdf
+ # docutils 0.21.1 renamed rst2latex.py to rst2latex
+ local r2l=$(command -v rst2latex || command -v rst2latex.py || die)
+ VARTEXFONTS="${T}"/fonts emake RST2LATEX="${r2l}" ${PN}.pdf
fi
}