summaryrefslogtreecommitdiff
path: root/app-emacs/org-modern/org-modern-1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/org-modern/org-modern-1.3.ebuild')
-rw-r--r--app-emacs/org-modern/org-modern-1.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/org-modern/org-modern-1.3.ebuild b/app-emacs/org-modern/org-modern-1.3.ebuild
new file mode 100644
index 000000000000..b7d30e300fee
--- /dev/null
+++ b/app-emacs/org-modern/org-modern-1.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Modern style for your GNU Emacs Org buffers"
+HOMEPAGE="https://github.com/minad/org-modern/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/minad/${PN}.git"
+else
+ SRC_URI="https://github.com/minad/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.0
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( README.org example.org )
+SITEFILE="50${PN}-gentoo.el"