summaryrefslogtreecommitdiff
path: root/app-emacs/mastodon/mastodon-1.0.18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/mastodon/mastodon-1.0.18.ebuild')
-rw-r--r--app-emacs/mastodon/mastodon-1.0.18.ebuild21
1 files changed, 16 insertions, 5 deletions
diff --git a/app-emacs/mastodon/mastodon-1.0.18.ebuild b/app-emacs/mastodon/mastodon-1.0.18.ebuild
index 99625fea4848..2a79521adfed 100644
--- a/app-emacs/mastodon/mastodon-1.0.18.ebuild
+++ b/app-emacs/mastodon/mastodon-1.0.18.ebuild
@@ -9,19 +9,30 @@ inherit elisp
DESCRIPTION="Emacs client for Mastodon, federated microblogging social network"
HOMEPAGE="https://codeberg.org/martianh/mastodon.el/"
-SRC_URI="https://codeberg.org/martianh/${PN}.el/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}.el/lisp"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://codeberg.org/martianh/mastodon.el.git"
+ S="${WORKDIR}/${P}/lisp"
+else
+ SRC_URI="https://codeberg.org/martianh/${PN}.el/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}.el/lisp"
+
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
RDEPEND="
app-emacs/persist
app-emacs/request
"
-BDEPEND="${RDEPEND}"
+BDEPEND="
+ ${RDEPEND}
+"
DOCS=( ../README.org )
ELISP_TEXINFO="../${PN}.texi"